OSPF基础

Report
OSPF基础
日期:
引入
 RIP路由协议存在无法避免的缺陷,多用于构建中小
型网络
 随着网络规模的日益扩大,RIP路由协议已经不能完
全满足需求
 OSPF 路由协议解决了很多RIP路由协议无法解决的
问题,因而得到了广泛应用
课程目标
学习完本课程,您应该能够:
 掌握OSPF路由协议基本原理
 熟练配置单区域OSPF
目录
 OSPF基本原理
 配置OSPF
 OSPF信息显示与调试
什么是OSPF
l
OSPF(Open Shortest Path First,开放最
短路径优先)是IETF 开发的基于链路状态的
自治系统内部路由协议
l
OSPF仅传播对端设备不具备的路由信息,网
络收敛迅速,并有效避免了网络资源浪费
l
OSPF直接工作于IP层之上,IP协议号为89
l
OSPF以组播地址发送协议包
OSPF协议工作过程概述
OSPF协议工作过程概述
OSPF启动
没有
接口是否启动OSPF
不做任何处理
计算路由
启动
与DR/BDR交互链路状态,
邻居状态达到Full状态
定时发送Hello包,寻找邻居
是否接收到
邻居的Hello包
有
邻居状态达到
2-WAY状态
已选举
DR/BDR
是否选举?
仅与DR/BDR
建立邻接关系
未选举
没有
继续等待接收
进行DR/BDR选举
选举完成
l
OSPF协议工作过程主要有四个阶段:

www.h3c.com
寻找邻居、建立邻接关系、链路状态信息传递、计算路由
OSPF基础
Router ID
含义与作用
用来在整个OSPF域中唯一标识一台路由器,该参数同时表
明了LSA的生成者信息
选举规则:
手工设置的 router id x.x.x.x
The highest loopback address
The highest active physical interface address
注:
1 参与Router ID选举的接口可以没有激活OSPF
2 RID一旦生效 必须重启OSPF进程(Reset Ospf Process)才
能更改(有时需要重启路由器)
OSPF基础
网络类型
OSPF支持以下四种网络类型
点到点(P2P)
点到多点(P2MP)
广播网络(Broadcast)
NBMA
NBMA的网络类型需要静态指定邻居,其余网络类型邻居自动发现
广播网络和NBMA的网络上需要进行DR/BDR的选举
在P2P和Broadcast网络上,Hello报文以组播地址(224.0.0.5)
进行发送;在P2MP NBMA VL(Virtual-Link)上 Hello报文以
单播地址进行发送
OSPF基础
DR/BDR
DR
DRother
BDR
DRother
交换Hello包和LSA,数据库同步后 最终会形成Full的状态
只交换Hello包,数据库同步后 最终会形成Two-Way的状态
OSPF基础
DR/BDR选举
l 选举规则

首先比较 Interface Priority(默认值为1, 可以通过ospf drpriority修改)


l
Priority=0则意味着此路由器必然是DRother (在Hub-andSpoke的NBMA网络中通过指定Spoke路由器的优先级为0来
确保Hub路由器DR的角色)
优先级相同则通过RID打破僵局(Tie-Breaker)
两大原则

稳定压倒一切(非抢占)

快速相应(BDR自动接替DR)
OSPF基础
邻居状态机
Down
尝试发送Hello信息
给邻居,但还没有
收到任何信息(仅
仅在NBMA模式有
效)
Attempt
Init
尚未收到邻居的Hello,
开始发送Hello给邻居
收到了来自邻居的hello,但
邻居的Hello信息中没有本路
由器的ID(这个状态表明邻居
还没有收到来自本地发送的
Hello)
通过LSR和LSU报文
的交互获取尚未发现
的详细的链路状态信
息
Loading
双向邻居关系建立
(互相看到对方的
Hello包中有自己
的RID),如果是多
点访问网络,本阶
段同时完成
DR/BDR选举
2-way
ExStart
DD报文交互的准备阶
段(协商Master/Slave
关系和DD报文的初始
序列号)
Exchange
路由器之间
完成了数据
库的同步
DD报文交互阶段
Full
OSPF基础
区域类型
区域是从逻辑上将路由器划分为不同的组,每个组用区域号(Area ID)来标识 ,
一个路由器可以属于不同的区域,但是一个网段(链路)只能属于一个区域,或
者说每个运行OSPF的接口必须指明属于哪一个区域 。
l
OSPF区域分为非骨干区域和骨干区域两大类
l
所有非骨干区域必须和骨干区域直接相连。
目录
 OSPF基本原理
 配置OSPF
 OSPF信息显示与调试
配置OSPF
组网图如下:
G2/1/1
G2/1/1
RT1
RT0
AREA 0
G2/1/2
G3/1/1
RT2
G2/1/2
G3/1/1
RT3
组网描述:
设备RT0和设备RT1相连的端口属于AREA0,设备RT0和设备RT2相连的端口
属于AREA1,设备RT1和设备RT3相连的端口属于AREA2,三台设备之间运
行OSPF。
配置OSPF
具体配置步骤如下:
1.配置设备RT0
(1)配置与RT1相连接口的IP地址
[Sysname]interface GigabitEthernet 2/1/1
[Sysname-GigabitEthernet2/1/1]ip address 192.168.1.1 30
(2)配置与RT2相连接口的IP地址
[Sysname]interface GigabitEthernet 2/1/2
[Sysname-GigabitEthernet2/1/2]ip address 10.1.1.1 30
(3)配置环回口
[Sysname]interface LoopBack 0
[Sysname-LoopBack0]ip address 1.1.1.1 32
配置OSPF
(4)配置OSPF
[Sysname]router id 1.1.1.1
[Sysname]ospf
[Sysname-ospf-1]area 0
[Sysname-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.3
[Sysname-ospf-1]area 1
[Sysname-ospf-1-area-0.0.0.1]network 10.1.1.0 0.0.0.3
配置OSPF
2.配置设备RT1
(1)配置与RT0相连接口的IP地址
[Sysname]interface GigabitEthernet 2/1/2
[Sysname-GigabitEthernet2/1/2]ip address 192.168.1.2 30
(2)配置与RT3相连接口的IP地址
[Sysname]interface GigabitEthernet 2/1/2
[Sysname-GigabitEthernet2/1/2]ip address 20.1.1.1 30
(3)配置环回口
[Sysname]interface LoopBack 0
[Sysname-LoopBack0]ip address 2.2.2.2 32
配置OSPF
(4)配置OSPF
[Sysname]router id 2.2.2.2
[Sysname]ospf
[Sysname-ospf-1]area 0
[Sysname-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.3
[Sysname-ospf-1]area 2
[Sysname-ospf-1-area-0.0.0.2]network 20.1.1.0 0.0.0.3
配置OSPF
2.配置设备RT2
(1)配置与RT0相连接口的IP地址
[Sysname]interface GigabitEthernet 3/1/1
[Sysname-GigabitEthernet3/1/1]ip address 10.1.1.2 30
(2)配置环回口
[Sysname]interface LoopBack 0
[Sysname-LoopBack0]ip address 3.3.3.3 32
(3)配置OSPF
[Sysname]router id 3.3.3.3
[Sysname]ospf
[Sysname-ospf-1]area 1
[Sysname-ospf-1-area-0.0.0.1]network 10.1.1.0 0.0.0.3
配置OSPF
3.配置设备RT3
(1)配置与RT2相连接口的IP地址
[Sysname]interface GigabitEthernet 3/1/1
[Sysname-GigabitEthernet3/1/1]ip address 20.1.1.2 30
(2)配置环回口
[Sysname]interface LoopBack 0
[Sysname-LoopBack0]ip address 4.4.4.4 32
(3)配置OSPF
[Sysname]router id 4.4.4.4
[Sysname]ospf
[Sysname-ospf-1]area 2
[Sysname-ospf-1-area-0.0.0.2]network 20.1.1.0 0.0.0.3
目录
 OSPF基本原理
 配置OSPF
 OSPF信息显示与调试
显示OSPF邻居信息
该路由器的Router ID
[H3C]display ospf peer
OSPF Process 1 with Router ID 1.1.1.1
Neighbor Brief Information
Area: 0.0.0.0
Router ID
Address
2.2.2.2
192.168.1.2
Pri
1
Dead-Time
39
Interface
S0/2/0
State
Full/ -
Area: 0.0.0.1
Router ID
Address
3.3.3.3
10.1.1.2
Pri
1
Dead-Time
37
Interface
S0/2/1
State
Full/ -
邻居路由器的
Router ID
邻居路由器
的接口地址
路由器
优先级
显示OSPF路由信息
<H3C>display ospf routing
OSPF Process 1 with Router ID 1.1.1.1
Routing Tables
Destination
20.1.1.0/30
10.1.1.0/30
192.168.1.0/30
Cost
3124
1562
1562
Routing for Network
Type
NextHop
Inter
192.168.1.2
Stub
10.1.1.1
Stub
192.168.1.1
AdvRouter
2.2.2.2
1.1.1.1
1.1.1.1
Area
0.0.0.0
0.0.0.1
0.0.0.0
Total Nets: 3
Intra Area: 2 Inter Area: 1 ASE: 0 NSSA: 0
目标地址
路由开销
路由类型
下一跳地址
路由发布者
区域ID
其他OSPF显示命令
OSPF信息显示命令
l
显示OSPF摘要信息
[Router] display ospf brief
l
显示启动OSPF的接口信息
[Router] display ospf interface
l
显示OSPF的出错信息
[Router] display ospf error
l
显示OSPF的进程信息
[Router] display ospf INTEGER<1-16635>
www.h3c.com
调试OSPF
l
调试OSPF
OSPF事件调试信息
<Router> debugging ospf event
l
OSPF链路状态通告调试信息
<Router> debugging ospf lsa
l
OSPF包调试信息
<Router> debugging ospf packet
l
OSPF路由计算调试信息
<Router> debugging ospf spf
l
OSPF进程调试信息
<Router> debugging ospf INTEGER<1-65535>
www.h3c.com
本章总结
 OSPF是链路状态路由协议,使用SPF算法计算最短
路径,选路更合理,不会产生路由环路
 OSPF通过DR/BDR选举减少邻接关系,网络链路状
态信息同步通过DR/BDR进行管理
 OSPF通过划分区域管理的方式优化运行
 OSPF网络收敛快、信息传递可靠、节省网络资源、
支持VLSM,适用于中小型网络,经细致规划后也可
用于大型网络

similar documents