Planilhas Eletrônicas

Report
Reinventando o Ensino Médio
Tecnologia da
Informação
TINP : Planilhas
Eletrônicas
Por
–
–
–
–
–
–
Márcio L. Bunte de Carvalho
Luiz Chaimowicz
Mirella M. Moro <<<<<<<<<<<<<
Ana Paula Couto e Silva
Gisele L. Pappa
Antônio Mendes
UFMG
OBSERVAÇÃO
• Se você nunca usou uma planilha eletrônica,
esta apresentação é para você
• Se você já usou ou sabe tudo de planilha
eletrônica, esta apresentação pode não ser
para você, mas pode ser para seus alunos
OU SEJA
aqui, prestenção
REM TINP 2o ANO
2
Conteúdo
1.
2.
3.
4.
Introdução a planilhas eletrônicas
Visão geral do LibreOffice Calc
Sugestões de atividades
Atividade prática
REM TINP 2o ANO
3
Antes de tudo: pt-br.libreoffice.org
REM TINP 2o ANO
4
1. Introdução a Planilhas Eletrônicas
Antigamente
• Papel
• Cálculos
demorados
• Gráficos???
REM TINP 2o ANO
Depois
HOJE
• Calculadora
• Cálculos
complexos em
várias etapas
• Gráficos
desenhados à
mão
• Planilhas
• “Quaquer”
cálculo em um
clique
• Gráficos
maravilhosos
configuráveis
5
Planilhas Eletrônicas
Cálculos
Cálculos em etapas
simples e
Funções
complexos
Gráficos
REM TINP 2o ANO
6
Planilhas Eletrônicas
• Cálculos simples e complexos?
– Matemáticos, financeiros, contábeis, etc.
– Juros simples, juros compostos
– Funções variadas: desvio padrão, média ponderada,
domingo de Páscoa, se ano é bissexto, etc
• Aplicações reais
– Orçamento doméstico
– Gerenciamento financeiro de pequenos negócios
– Empréstimos e financiamentos
REM TINP 2o ANO
7
Planilhas Eletrônicas: Grááááficos
REM TINP 2o ANO
8
Gráficos Úteis
para
Professores
REM TINP 2o ANO
9
Imaginem as Possibilidades
Exemplo Real: Turmas Intro a Bancos de Dados da profa. Mirella @ UFMG
LEGENDA:
E + P = Exercícios + Participação
TP2 = Segundo trabalho prático
TP1 = Primeiro trabalho prático
P3 = Terceira prova, cumulativa
P2 = Segunda prova
P1 = Primeira prova
FINAL = MÉDIA-PONDERADA {tudo}
CONCEITOS =
A a D são aprovados;
E reprovado;
F reprovado por frequência
Observacão: avaliações das Turmas 2008/2 a 2013/2 =
665 alunos matriculados e
615 alunos fizeram a primeira prova.
REM TINP 2o ANO
10
Intro a planilhas
em geral
REM TINP 2o ANO
LibreOffice Calc
11
2. Visão geral do LibreOffice Calc
CALC = Planilha de Cálculo do LibreOffice
Funções = fórmulas para cálculos complexos
Gráficos = dinâmicos em 2D e 3D
Macros = gravar e executar tarefas repetitivas
Compatível com Excel, HTML, CSV, etc
REM TINP 2o ANO
12
Outras Funcionalidades
• Digitação e edição de dados em várias planilhas
ao mesmo tempo
• Possibilidade de arrastar dados de uma planilha
para outra
• Impressão horizontal e vertical da planilha
• Mesclagem de células na horizontal e vertical
• Formatação condicional através de caixas de
diálogo
• Etc.
REM TINP 2o ANO
13
Barra de
ferramentas
padrão
Barra de título
Interface
Barra de ferramentas
de formatação
Barra de menu
Barra de
fórmulas
Célula
ativa
Cabeçalho
das colunas
Célula ativa
(caixa de nomes)
Cabeçalho
das linhas
Barras de
rolagem
Abas das
folhas
Barra de
estado
14
Caixa de
Nomes
Assistente
de funções
Botão de Botão de
soma
função
REM TINP 2o ANO
Linha de
entrada
15
Básico: somar duas células
1. Dadas duas células com
valores quaisquer: A1 e B1
2. Clicar na célula C1
3. Digitar a fórmula desejada
= A1 + B1
Ou seja, a célula C1 vai receber (por
isso começa com = ) o resultado da
fórmula:
conteúdoA1 MAIS conteúdoB1
4. ENTER
REM TINP 2o ANO
16
Básico: operações
entre duas células
• Exemplo funciona para as demais operações,
cuidado com os operadores
+ soma
- subtração * multiplicação / divisão
• Operadores lógicos também funcionam
= igual
> < >= <= <> diferente
Para eles o resultado na célula será
VERDADEIRO ou
FALSO
= A1 > B1 
REM TINP 2o ANO
17
Replicando a mesma operação
grande facilidade de planilhas
Agora você deseja fazer a divisão (ou qualquer
outra operação) para várias linhas da planilha
1. Selecione a célula com a fórmula definida
2. Com o mouse clicado, arraste-o para todas as
células desejadas
3. Veja o conteúdo da última célula = A4/B4
REM TINP 2o ANO
18
Opa opa opa
outra grande facilidade de planilhas
• Funciona, mas está horrível
• Formatar as casas decimais
1. Selecionar as células desejadas
(pode ser coluna inteira ou linha inteira, basta
clicar na LETRA ou no NÚMERO)
2. Ir ao menu FORMATAR e depois
CÉLULAS
Abre-se uma nova janela cheia de
opções maravilhosas
REM TINP 2o ANO
19
3. A categoria NÚMERO é a default; selecionar então o
FORMATO desejado
Por exemplo -1234,12 = números com duas casas
decimais
REM TINP 2o ANO
20
Nesta mesma janela é possível formatar TUDO:
fonte, efeitos da fonte, alinhamento, bordas, plano de
fundo, proteção de célula
Como o exemplo (lindo) à direita mostra
REM TINP 2o ANO
21
Funciona só
para duas
células?
REM TINP 2o ANO
Que pobreza!
K Q NÃO
22
Operações com intervalos de células
E claro que funciona para qualquer
função disponível: mínimo, média,
desvio padrão, arredondar, etc.
REM TINP 2o ANO
CÉL.
A1
B3
C3
D3
E3
A4
A5
A6
A7
A8
CONTEÚDO
= SOMA(B4:E8)
= SOMA(B4:B8)
= SOMA(C4:C8)
= SOMA(D4:D8)
= SOMA(E4:E8)
= SOMA(B4:E4)
= SOMA(B5:E8)
= SOMA(B5:E8)
= SOMA(B5:E8)
= SOMA(B5:E8)
23
Planilhas é só
para
números?
REM TINP 2o ANO
Porque até
agora: só
números
K Q NÃO
24
Números e Texto
Planilha para notas de alunos e turmas
TEXTO
CARACTERE
STRING NÚMEROS
REM TINP 2o ANO
25
Para ordenar
1. Seleciona dados a serem ordenados (linha 4 em diante)
2. Menu Dados, opção CLASSIFICAR
REM TINP 2o ANO
26
Ordena: crescente ou descrescente
por UMA ou MAIS colunas
REM TINP 2o ANO
27
Resultado: nome ordem alfabética
REM TINP 2o ANO
28
Outra funcionalidade interessante
Dados > Filtro > Autofiltro
REM TINP 2o ANO
1. Selecione a linha com os cabeçalhos da tabela
(nesse caso a linha 3)
2. Menu DADOS, selecione FILTRO e AUTOFILTRO29
• Aparecem “botões” para cada coluna
• Clica e aparece menu personalizado para a mesma
REM TINP 2o ANO
30
• Por exemplo, apenas T1 e T2 estão selecionados para a
coluna TURMA
• Então os dados das demais ficam de fora dessa
visualização (embora continuem na planilha)
REM TINP 2o ANO
31
Blablabla
REM TINP 2o ANO
Tudo isso
eu já sabia
Então faça
isto:
32
Dada a planilha anterior com
nome, sexo e turma do aluno
+ as notas de 3 provas e a notal final
REM TINP 2o ANO
33
Calcular *AUTOMATICAMENTE*
utilizando os recursos da planilha
• Informar para cada aluno se ele foi aprovado
(notafinal >= 6) ou não
• Número de aprovados
• Número de reprovados (notafinal <6)
• Número de meninOs e meninAs aprovados
• Número de meninOs e meninAs reprovados
• Distribuição do número de alunos por conceito:
A >=9; 8 <= B < 9; 6 <= C < 8; 4 <= D < 6; E < 4
• Média por turma das notas da prova1, prova2,
prova3 e notafinal
• E fazer gráficos resumindo essas estatísticas
REM TINP 2o ANO
34
REM TINP 2o ANO
35
REM TINP 2o ANO
36
(de novo)
Gráficos Úteis
para
Professores
REM TINP 2o ANO
37
Espero ter
convencido
todos
REM TINP 2o ANO
Planilhas
são
LEGAIS!!!!!
Mas e para
os alunos?!
38
3. Sugestões de Atividades
• Fazer planejamento financeiro para comprar
uma bicicleta em 10 meses, porém:
– São três opções de lojas, cada um com uma taxa
mensal de juros diferente
– Descobrir o preço final da bicicleta após
contabilizar os juros das parcelas
– O exemplo para os alunos pode ser com bicicleta,
mas pode ampliar para compra de carro, casa, etc
REM TINP 2o ANO
39
Sugestões Disponíveis no Material
• Como montar um jogo de palavras cruzadas
utilizando planilhas eletrônicas
• Pizzaria com Programa Fidelidade [a seguir]
• Organização de excursão de alunos [a seguir]
• Diversas utilizando gráficos
REM TINP 2o ANO
40
Pizzaria com Programa Fidelidade
•
•
•
•
•
Você é o proprietário de uma pizzaria e deseja aumentar
seu volume de vendas e fidelizar seus clientes.
Para isso, você decide criar uma incrível promoção: a
pizzaria irá conceder descontos para os clientes que
compraram mais de uma pizza no mês anterior.
Se o cliente comprou 2 ou 3 pizzas no mês anterior, ele terá
um desconto de 5%.
Se ele comprou 4 ou 5 pizzas no mês anterior, ele terá um
desconto de 10%.
Se ele comprou 6 ou 7, 15%.
Finalmente, se o cliente comprou 8 pizzas ou mais, o
desconto será de 20%.
PERGUNTA-SE:
– Como controlar o desconto concedido aos clientes?
– Como calcular o preço de venda das pizzas (após o desconto)?
REM TINP 2o ANO
41
Excursão de Alunos
• Sua turma de planeja realizar uma excursão de fim do ano.
• A organização ficará sob a responsabilidade dos alunos e
eles decidiram criar uma planilha eletrônica para controlar
melhor a relação de alunos interessados em ir ao passeio,
assim como realizar o registro dos pagamentos.
• As condições de pagamento são:
– À vista no total de R$ 100,00 por pessoa.
– Em duas parcelas no valor de R$ 55,00 reais (por pessoa) cada
• Será necessário coletar dados diversos dos alunos
participantes (nome, telefone, etc)
• Após fazer o cadastro dos interessados, a organização deve
gerenciar os pagamentos: quem fez, quanto, quando, etc
• Como o espaço de tempo para o pagamento é amplo, os
alunos organizadores querem acompanhar o andamento da
arrecadação para viagem, requisitando dados como: qual o
total de pagamentos realizados, qual o total levantado,
quantos são os pagamentos parcelados, etc.
REM TINP 2o ANO
42
Esses foram
exemplos
REM TINP 2o ANO
Agora
Mãos à
Obra
43
4. Atividade Prática
• Para a atividade prática, escolha uma das opções a
seguir e tente completá-la dentro do tempo (e
fique à vontade para olhar todas e tentar um pouco
de cada )
– Notas dos alunos
– Palavras cruzadas
– Pizzaria com programa de fidelidade
• Links para a descrição em
http://goo.gl/rWTf3h
Ou https://sites.google.com/site/remtimg >> Documentos
REM TINP 2o ANO
44

similar documents