Lección 1

Report
Introducción
La información constituyen el corazón de
su negocio.
 Multitud de tipos de datos diferentes:
datos financieros, datos de producción,
datos de clientes, datos de proveedores,
datos sobre la competencia, datos de
recursos humanos...
 Se encuentran en bases de datos, hojas
de cálculo, documentos de texto, páginas
Web y archivos multimedia.

Sistemas de información
Los sistemas denominados operacionales,
se centran en la recopilación de los datos
operativos de su negocio, es decir,
reflejan el día a día de las transacciones y
eventos que se han ido produciendo en
su organización.
 Los sistemas para la toma de decisiones
se utilizan para “tomarle el pulso” al
negocio y dar sustento a las decisiones
estratégicas.

Fuentes de información
Basess de datos.
 OLAP (On-Line Analytical Processing),
 Minería de Datos (Data Mining),
 Almacenes de Datos (DataWareHouses),
 Sistemas ERP/CRM (Enterprise Resource
Planning/Customer Relationship
Management) y
 Portales Corporativos

Bases de datos
Conjunto de datos crudos estructurado
en filas (registros) y columnas (campos)
 La interfaz predominante utiliza tablas
cuadriculadas organizadas en filas y
columnas, presentando más datos de los
necesarios para el usuario en un
momento dado, duplicando valores y
ocultando mucha información que
pudiera resultar útil .

Bases de datos
Preguntas
¿Cuántos colores diferentes hay de
bolígrafos y lapiceros?
 ¿Cuál es el color más frecuente?
 ¿Hay objetos azules y pequeños?
 ¿Cuántos objetos rojos hay?
 ¿De qué colores son los objetos
pequeños?
 ¿Qué colores no están disponibles en los
objetos pequeños?

Características
Las tablas de este tipo no están diseñadas
para una interpretación sencilla de los
datos.
 Están diseñadas para simplificar la
introducción de datos y su
almacenamiento.
 Para hacer preguntas a la base de datos
uno debe emplear un lenguaje
estructurado que el ordenador pueda
comprender (Lenguaje SQL)

Formularios y reportes
Estas herramientas proporcionan
respuestas estables a necesidades de
información muy específicas, que fueron
previstas y definidas ya durante la fase de
diseño.
 Facilitan la obtención de datos
 Ocultan las relaciones entre ellos, pero
que son imprescindibles para entender la
naturaleza de los datos.

Qlikview - Características
Interfaz única, que no se basa en tablas,
formularios o informes, sino que muestra
varias presentaciones en una única
interfaz
 Permite la formulación de preguntas con
un simple clic de ratón
 Ayuda al usuario a comprender e
interpretar de forma más eficiente la
información, al mostrar las relaciones
existentes entre los datos.

Qlikview - Interfaz
Qlikview - Estructura
Datos existentes en múltiples fuentes, ERP,
Excel, Archivos planos, Bases de datos, etc.
 Modelo que plantea la obtención de
información con base en las relaciones de
los datos mediante queries de lógica
asociativa (AQL)
 Conjunto de elementos de tabla y gráficos
que permite al usuario opera el modelo.

Qlikview - Estructura
Qlikview - Proceso



QlikView construye una base de datos
asociativa durante el proceso mismo de carga
de los datos de una determinada fuente.
La información redundante es
automáticamente eliminada y las tablas
asociadas se relacionan de manera
automática.
No existe la necesidad de definir índices ni
claves de búsqueda, ya que cada concepto se
convierte en un criterio de selección que es
posible consultar directamente.
Qlikview - Modelo
Además, el espacio requerido para la base
de datos asociativa es tan solo una fracción
del que se necesitaría con un modelo
relacional con idénticos datos.
 El archivo .qvw generado incluye los datos
cargados y el modelo.
 Existe el servidor web, en el que el modelo
y los datos se quedan en él y el navegador
los muestra y permite su manejo.

Qlikview - Ejemplo
Qlikview - Ejemplo
Qlikview - Ejemplo
Qlikview - Ejemplo
Qlikview - Ejemplo
Ejercicio Introductorio
Instalar Qlikview
 Cargar Practica1.qvw
 Verificar ejemplos
 Página en blanco (Diseño-añadir hoja)
 Paso a paso

◦ Poner selectores
◦ Verificar ejemplos
Qlikview - Ejemplo
QlikView utiliza colores para permitir al usuario la interpretación
de los resultados de su consulta (con un clic del ratón). Los
valores en los que se ha hecho clic resaltan en verde y se
denominan valores seleccionados. Los valores que están
asociados con los valores seleccionados permanecen en blanco
y se llaman valores opcionales. Todos aquellos valores que no
estén relacionados con los valores seleccionados mediante clic
de ratón se denominan valores excluidos y están deshabilitados,
con el fondo en gris.
Qlikview - Ejemplo
Imaginémonos el siguiente ejemplo. Hay tres objetos en pantalla: dos
cuadros de lista con varios valores y un gráfico de barras. Los cuadros
de lista indican los diversos objetos disponibles y los colores posibles de
objetos. El gráfico de barras muestra la cantidad de cada objeto.
El valor Azul en el cuadro de lista Color, aparece resaltado para indicar de esta
forma que él es el valor seleccionado. Azul, Negro y Rojo en el cuadro de lista
Color cambian su color a gris e indican así que no están asociados con Azul, es
decir, que no existen objetos Verdes que también sean Azul, Negro o Rojo.
Observe también que el gráfico ha actualizado las barras solamente para
aquellos objetos que se asocien con el valor Verde. Las cantidades se han
actualizado y reflejan las cantidades de lapiceros y bolígrafos Azules
Qlikview - Ejemplo
QlikView permite hacer selecciones de esta manera en tantos objetos
como sea necesario. Podríamos continuar afinando la consulta con más
detalles haciendo clic en el valor Bolígrafos del cuadro de lista Objeto
(véase el ejemplo de abajo.) QlikView respondería resaltando el valor
Bolígrafo, para indicar que también está seleccionado (además del valor
Verde en el cuadro de lista Color). El valor Lapicero cambia a gris,
indicando de este modo que no está asociado con Azul y Bolígrafo, y el
gráfico también se actualiza de tal forma que sólo mostraría los Bolígrafos
azules.
Regresando a Qlikview
Requiere de Windows 98, 2000, XP, Windows NT 4.0 SP 6, Vista o
Windows 7. Existe en versiones 32 y 64 bits
Versiones stand-alone y Qlikview Server
En la stand-alone
•Una licencia por cada computadora
•Acceso todos los usuarios a la descarga de datos
•Cada usuario puede hacer sus propios modelos
•Se requiere al menos un Qlikview de ésta versión
•Entre más memoria se tenga mejor se recomiendo mínimo 2 Gb.
En la versión server
•Los modelos se ponen a disposición de usuarios que no pueden
cambiarlos pero si utilizarlos.
•Los modelos se corren en el servidor.
•Se utiliza un plug-in para el Internet Explorer (gratuito)
•Se requieren comprar licencias de acceso para los usuarios
•Entre más memoria se tenga mejor se recomiendo mínimo 4 Gb.
Capacidades de Qlikview
En general la memoria existente es el límite para un modelo.
No existe límite en el número de tablas, ni en el número de campos,
filas o celdas de una tabla en particular. El único límite es que un sólo
campo no puede contener más de 2.000.000.000 (dos mil millones) de
valores distintos .
Dado que QlikView carga los datos desde una base de datos inicial, y
los adapta a su tecnología AQL, éstos se hallan altamente optimizados,
dando como resultado por lo general que una aplicación QlikView
ocupe sólo el 10-30% de su tamaño en la fuente original.
Los sistemas operativos de 64bits no tienen el límite de 4Gb en
memoria y por lo tanto pueden manejar archivos muy grandes.
QlikView normalmente requiere de 3 a 4 veces más de RAM para la
ejecución del script que para utilizar el documento cargado, habrá
muchos casos en que los documentos puedan ejecutar su script en
una máquina de 64 bits pero que posteriormente se puedan utilizar en
una máquina de 32 bits.
Fuentes de datos
QlikView carga datos desde las siguientes fuentes de información:
• Archivos de texto delimitados por cualquier separador
• Archivos de texto con registros de tamaño fijo.
• AS/400 Data Interchange Format (DIF).
• Hojas de cálculo Microsoft Excel
• Tablas HTML contenidas en cualquier página web
• Tablas XML
• Bases de datos asociativas de QlikView
• Fuentes de datos ODBC : SQL, Oracle, MySQL
• Fuentes de datos OLEDB
QlikView incluye la posibilidad de cargar datos desde estas fuentes
(excepto ODBC/OLEDB) utilizando HTTP o FTP. Esto significa que el
archivo origen puede ubicarse en un servidor Web o un servidor FTP
en una localización remota, con lo que QlikView puede conectar con el
mismo y cargar los datos de origen de manera directa.
Script de carga
Con el fin de extraer datos de una base de datos original, QlikView
ejecuta un Script de carga. El Script de carga define las bases de datos
de origen y las tablas y campos que debieran cargarse en QlikView.
Además se pueden calcular nuevas variables y registros mediante más
de 150 funciones disponibles en el script.
QlikView incluye un asistente que genera automáticamente el script
para facilitar su creación. Para aplicaciones sencillas sólo hay que
seleccionar el archivo que se desea cargar; y QlikView determinará
automáticamente el tipo de archivo y generará el script requerido para
cargar todos los datos de origen. Para aplicaciones más complejas
puede que sea necesario editar el script de carga manualmente o
combinar distintas fuentes de modo poco convencional. El robusto
lenguaje de script de QlikView incluye asimismo sintaxis para el control
de flujo, por ejemplo, bucles, procesamiento condicional, limpieza de
datos y subrutinas.
Ayuda
Todas la ventanas de propiedades tienen el botón
‘Ayuda’
Contenido. Información estructurada como libro
Índice. Información estructurada por temas
Buscar. Búsqueda de palabras
Ayuda
En la opción Índice teclear la palabra formato
Ayuda
Lección 1
Abrir un documento
1 Inicie QlikView con un doble-clic sobre el icono QlikView
2 Elija Abrir en el menú Archivo.
3 Seleccione el archivo Tutorial.qvw y haga clic en Abrir.
Lección 1
Partes de un documento
•La barra de menú de QlikView; bajo ésta,
•La barra de herramientas. Debajo de la barra de herramientas
hay una o más pestañas.
•Cada pestaña va vinculada a una hoja.
•En cada hoja hay una serie de objetos de hoja.
•El objeto de hoja más básico es el cuadro de lista.
•Cada cuadro de lista representa una columna (campo) de la
base de datos cargada, y contiene una serie de valores (de
campo).
•Los cuadros de estadísticas, gráficos, cuadros de selección
múltiple y cuadros de tabla son objetos de hoja que se pueden
crear para lograr una mejor visión general de los datos.
•Los botones se utilizan para ejecutar ciertos comandos.
Lección 1
Selecciones
Lección 1
Selecciones
En el cuadro de lista País, sitúe el cursor del ratón sobre el valor
Albania y haga clic en él.
El color de la celda cambia a verde., lo que indica que
este valor está seleccionado. El valor seleccionado
filtra los datos mostrados en todos los demás objetos
de todas las páginas. Al instante podrá ver qué
valores de los restantes cuadros de lista son
compatibles con la selección, y cuales no.
Un valor que está relacionado con la selección se
denomina opcional. Las celdas de los valores
opcionales son de color blanco.
Una celda cuyos contenidos sean incompatibles (esto
es, cuyo valor no aparezca nunca en combinación con
el valor seleccionado es decir no esté relacionado)
recibe la denominación de excluida. Las celdas de
valores excluidos se muestran en color gris.
Lección 1
Selecciones
En el cuadro de lista País, sitúe el cursor del ratón sobre el valor
Albania y haga clic en él.
Para deshacer la selección, puede hacer clic
nuevamente en la celda seleccionada, o en otra celda
del mismo cuadro de lista. La nueva selección
reemplazará a la anterior.
Para seleccionar más de un tema dentro de un
mismo cuadro de lista, hay que mantener pulsada
la tecla CTRL a la vez que se seleccionan los
valores adicionales. Si los valores seleccionados
lindan con la primera selección, también se
puede arrastrar el cursor del ratón manteniendo
pulsado el botón izquierdo.
Lección 1
Selecciones
Combinar selecciones
Se puede seleccionar un valor opcional de otro cuadro de lista junto con
un valor anteriormente seleccionado.
1. Haga clic en el botón Borrar de la barra de
herramientas para eliminar las selecciones.
2. Haga clic en la pestaña Ventas.
3. Supongamos que desea saber qué vendedor vendió
productos a Captain Cook’s Surfing School en Mónaco.
Busque el cliente en el cuadro de lista Cliente hasta
encontrar el valor Captain Cook’s Surfing School.
4. Seleccione el valor con un clic.
5. En el cuadro de lista País están en blanco, es decir,
que son compatibles con la selección. Seleccione
Monaco.
Ahora puede ver que Joe Cheng es el vendedor que
estaba buscando. El valor Joe Cheng es el único valor
compatible con Captain Cook’s Surfing School y Monaco.
Lección 1
Selecciones
Mantener presentes los criterios de selección
Dos herramientas para recordar las selecciones actuales
El cuadro de Selecciones actuales
La ventana de selecciones que aparece en el menú Ver –
Selecciones Actuales
Lección 1
Selecciones
Mover selecciones
Es posible mover las selecciones actuales de un cuadro de lista activado
mediante las teclas del teclado:
1 Haga clic en el botón Borrar de la barra de herramientas.
2 Vaya a la hoja Geografía.
3 Seleccione el valor Afganistan. Los valores relacionados con este
valor se mostrarán a continuación en los demás cuadros de lista.
4 Utilice la tecla
de su teclado para desplazar la selección actual
un paso hacia abajo en el cuadro de lista. Verá que los demás objetos
se actualizan para pasar a mostrar el resultado de la nueva selección.
Para mover la selección hacia arriba, elija la tecla
.
Lección 1
Selecciones
Búsquedas de texto
Otra manera de buscar en los datos es a través de las búsquedas de
texto. En general, ésta es la mejor manera de buscar en listas muy
extensas. Supongamos que está buscando el valor Suecia.
. Borre sus selecciones eligiendo
1.
Borrar, del menú.
2. Haga clic en la barra de título del
cuadro de lista País (en la hoja
Geografía) para activarlo.
Los objetos de hoja activos en este
documento tienen una barra de título
de color verde.
3. Teclee las letras "sw". La cadena de
búsqueda aparecerá en una ventana
aparte, entre dos asteriscos que
representan cero o más caracteres
Al pulsar la tecla INTRO se
seleccionarán todos los
países cuyos nombres
contengan "sw". También se
puede hacer clic en un país
para seleccionarlo
directamente.
Lección 1
Selecciones
Búsquedas numéricas
De forma similar, se puede buscar en campos que contengan datos
numéricos. Puede comenzar su búsqueda con mayor que ">" o menor
que "<“ seguido de un número. Supongamos que desea seleccionar
todos los países con un área inferior a 100 km2.:.
1. Borre sus selecciones eligiendo Borrar,
del menú.
2. Haga clic en la barra de título del cuadro
de lista Área(km2).
3. Teclee <100. La cadena se mostrará en
una ventana aparte.
4. Ahora sólo los números inferiores a 100
son opcionales en el cuadro de lista.
Pulse INTRO para seleccionarlos.
Lección 1
Selecciones
Búsquedas numéricas
De forma similar, se puede buscar en campos que contengan datos
numéricos. Puede comenzar su búsqueda con mayor que ">" o menor
que "<“ seguido de un número. Supongamos que desea seleccionar
todos los países con un área inferior a 100 km2.:.
1. Borre sus selecciones eligiendo Borrar,
del menú.
2. Haga clic en la barra de título del cuadro
de lista Área(km2).
3. Teclee <100. La cadena se mostrará en
una ventana aparte.
4. Ahora sólo los números inferiores a 100
son opcionales en el cuadro de lista.
Pulse INTRO para seleccionarlos.
Lección 1
Selecciones
Ir hacia adelante o hacia atrás en la lista de
selecciones
QlikView recuerda las últimas 100 selecciones. Con un clic
en el botón Atrás de la barra de herramientas, se puede
volver a la selección anterior:
1 Haga clic en el botón Atrás de la barra de herramientas.
Observe que se visualiza la selección anterior.
2 Haga clic de nuevo en Atrás para retroceder otro paso
más. Para avanzar en la lista de selecciones, realice lo
siguiente:
3 Haga clic en el botón Adelante en la barra de
herramientas y observe el resultado.
Lección 1
Selecciones
Bloquear y desbloquear selecciones
La lógica de QlikView sustituye por defecto una selección
anterior por una nueva, si la anterior está en conflicto con
la nueva selección.
1. Seleccione un valor excluido (gris). Observe cómo su
selección anterior desaparece. Para evitar esto, las
selecciones se pueden bloquear. Las celdas de una
selección bloqueada son azules. Cuando una nueva
selección está en conflicto con la bloqueada, no se
ejecutará.
2. Elija Bloquear del menú Selecciones o de la barra de
herramientas. Se bloquearán todas las selecciones
evitando que sean borradas por error.
3. Si intenta seleccionar un valor excluido en otro cuadro
de lista verá que no es posible.
4. Para desbloquear todas las selecciones, elija
Desbloquear del menú Selecciones o de la barra de
herramientas.
Lección 1
Selecciones
Marcadores de Selección
Se puede guardar un conjunto de selecciones para su utilización posterior:
1. Seleccione uno o varios valores, después elija Añadir Marcador en el
menú Marcadores. El nombre predefinido para el marcador creado es
el de la fecha actual más un número consecutivo. Este nombre
predefinido se puede cambiar por un texto más explicativo.
2. Escriba un nombre apropiado
para su marcador en el diálogo y
haga clic en Aceptar.
3. Abra de nuevo el menú
Marcadores. El marcador figura
en la lista de marcadores
creados.
4. Para volver a mostrar el conjunto
de selecciones guardado no hay
más que seleccionar el marcador
de la lista.
Lección 1
Selecciones
Guardar su trabajo
1. Para guardar una copia de la
aplicación elija Guardar Como en
el menú Archivo.
2. Escriba MiTutorial.qvw o algo
similar en el cuadro Nombre de
Archivo, y haga clic en Guardar.
QlikView guardará la copia.
MiTutorial.qvw contiene ahora
todos los cambios efectuados,
mientras el documento original
(Tutorial.qvw) se queda sin
cambios.
Ahora puede cerrar el archivo:
3. Elija Cerrar en el menú Archivo.

similar documents