CCNP수업내용정리

Report
WAN환경 (broad cast 사용 못함)
이 선로에 가능 전송속도에
맞게 주위에서 전송을 받던
지 보내던지 해야함
스위치를 통해서 같은 네트워크로 묶음
DLCI번호
DA:MAC주소
SA:MAC주소
ICMP8
frame-relay에서는 DLCI값을 보고 정보를 이동시킴
한 포트에 여러 개의 장비
를 연결(실제로 연결하는
것이 아닌 가상으로 연결)
네트워크 상에 2개의 장비만 있음
주 인터페이스(기본) = multipoint
point-to-point = 2대장비만 있음, 더 이상 연결을 못함( broadcast 불가능)
multipoint = 여러 연결가능을 가지고 있을 때
구분 못하고 다 전송
AS 50
AS 100
AS가 다르면 서로 통신 불가능
int s1/0
encapsulation frame-relay <- 이 설정을 해야 서브 인터페이스에서 multipoint 설정가능
int s1/0.12 multipoint
int s1/0
ip ospf network point-to-multipoint <- opsf에 대한 설정기능(서브 인터페이스와는 무관
EIGRP
RIP
rip -> eigrp (redistribute) : D EX
내부 eigrp정보 (같은AS): D
서로 다른 프로토콜은 서로 사용하는 매트릭이 다르므로 서로 연결되어 작동하지 않음
매트릭이 같도록 바꿔줘야 함(재분배)
경로 선정시
1. AD 보고 선정
2. Metric 보고 선정
ospf
균등 로드 분산
최적경로에서 metic이 같은 여러경로로 통신
비균등 로드 분산
metic값을 임의로 조정(X? 배로 조정)
최적경로와 최적경로의 임의로 조정된 metic값보다 적으면서 후속경로가
최적경로로 선출되어 비균등으로 통신
정보전달시 출발, 목적지 주소
출발지 주소 = 송신 interface의 ip
목적지 주소 = pdu, network type에 따라 변경됨
frame-relay 환경
1
물리적으로 끊어짐
3
2
1 -> 2로 traceroute 시도
traceroute는 위치를 이동할 때마다 한번씩 맨 처음 물어본 곳에 자기의 정보를 보
내줌
1->3으로 왔을 때 3에서 물리적 끊어짐을 감지하는 시간은 3분
3에서 1로 가장 가까운 길은 물리적으로 끊어진 경로
3분동안 계속 끊어진 곳으로 자기 정보를 보내니 1에서 traceroute에 대한 정보를
받지 못하고 traceroute 중단됨
13.13.2.0
13.13.1.0
OSPF, RIP, EIGRP프로토콜에서
network 13.13.1.0, network 13.13.2.0
의 의미는?
1. 네트워크 업데이트할 내용
2. network로 설정한 인터페이스로 네트워크정보 전달
passive-interface default 모든 인터페이스로 정보 업데이트 x
no passive-interface default 필요한 인터페이스로만 정보 업데이트
암호 = 기밀성(특정한 사람만 볼 수 있음)
인증 = 무결성(중간에 정보가 변경되었는지 확인하는 것)
key chain EIGRP_AUTH <=key chain이름 설정
key 20110109 <= 잠그는 열쇠
key-string cisco01234 <=암호
md5 -> 암호화는 가능, 복호화는 불가능
md5로 암호화하여 보낸 정보가 내가 가지고 있는 md5로 암호화한 내
용과 같은지 확인하여 받아 들이거나 받아 들이지 않음(HELLO패킷)
eigrp query
-> 자신의 최적 경로가 죽으면 차선책이 없으면 다른 쪽에 정보를 물어봄
(3분안에 응답이 없으면 neighbor 끊음)
문제 발생
SIA현상
query 전달
query 전달
문제 발생과 관련없는
곳에서 연결이 끊어짐
query 응답없음
query 전달
대규모 네트워크에서
는 사용 못함
SIA현상 해결법
1. query 응답기다리는 시간을 늘림
2. stub설정(자신이 마지막이라고 표시하고 query 안 받음)
3. summary
신뢰적 관계
broadcast < multicast < unicast
distribute-list
주는 쪽(in, out )과 받는 쪽(in, out )에서 설정
point-to-multipoint(실제 연결과는 다르게 가상으로 만들어짐)
컴퓨
터1
컴퓨
터
sw
컴퓨
터2
실제로 컴퓨터는 sw와
하나로 연결되지만
논리적으로 컴퓨터는
컴퓨터1과 컴퓨터2
하고 연결된 것
ospf (대형망에서 사용)
-> as별, LSA-Type별 네트워크 정보 저장
area 0
eigrp
ASBR
area1
ABR
area2
세그먼트는 같은 네
트워크 프로토콜이
동작해야 한다
DR, BDR선출이유
: 모든 장비가 네이버를
선출하면 비효율적
반장에게 변화를 알리고
반장이 모두에게 알림
DR
BDR
DRother -> DR
-> BDR(예비용)
모두에게 정보 보냄
DRother->DR(224.0.0.6)
DR->DRother(224.0.0.5)
ospf priority
1~255(상대 값) – 값을 비교 (DR, BDR,DRother 선출)
0(절대 값) – Drother(무조건)
NBMA
DR, BDR 수동선출 : neighbor 명령어를 통해서
nbma환경에서는 broadcast, multicast를 사용 할 수 없기 때문에
ospf
area0
area1
area100
area 100에서 통신이 가능하게 하기 위한 방법
1. area0에 area100을 붙이기
2. area100을 area1안으로 포함시키기
3. area0과 virtual link로 연결
virtual-link확인
show ip ospf virtual-links
ospf
NBMA(multipoint) : frame-relay 기본
point-to-multipoint설정하면: frame-relay(NBMA) -> point-to-multipoint 변경
D E1 ABR로 가는 길이 여러 개
D E2 ABR로 가는 길이 한 개
ABR
정보들어옴
LSA-Type
LSA-Type1은 show ip ospf database router로 자세히 봐야함 (너무 길어서 따로
봐야함)
stub (Type-5 안 받음)
rip
여기에 괜히 RIP의 정보
를 주어서 부하를 발생
시킬 필요 없음
ospf
eigrp
rip의 정보는 안 주고 ABR의 주소만 광고로 넘겨줌
ABR
ABR은 RIP의 정보를 가지고 있음
ospf
ASBR
Type5로 distribute 함
ASBR있으면 stub를 못함
totally stub (Type-3, 4, 5 안 받음)
nssa
type 5번을 stub는 못 받음
type 7로 재분배(type 5 재분배를 대신함)
eigrp
ospf
ASBR
type5 -> type7
ABR
ospf
ospf -> rip
rip
network 13.0.0.0
network 150.1.0.0
ospf
network 13.13.9.1 area0
network 13.13.9.3 area0
rip이 ospf보다 먼저 라우
터5로
네트워크 정보를 광고하
였으면
rip의 network 13.0.0.0에
13.13.9.1와 13.13.9.3
,13.13.9.4을
포함되므로
라우터5에서는
13.13.9.1과 13.13.9.3은
rip으로만 나타남
(먼저 광고된 내용이 프로
토콜이 바꿔서 광고된 내용
보다 우선순위를 가짐)
13.13.9.4
rip
13.13.9.1
ASBR
150.1.13.1
13.13.9.3
ospf
(as0)
라우
터5
tag 100
tag 20
tag 30
tag 40
tag20, tag100만 받도록 설정
13.13.1.0/24
1
loop동작
.1
.2
1에 설정되어 있는 내용
172.16.0.0
172.16.1.1
요약 (172.16.0.0/16)
~
172.16.255.255
* 0.0.0.0 13.13.1.1
2
2에 설정되어 있는 내용
D 172.16.0.0/16 13.13.1.2
갑자기 1에서 172.16.1.1의 내용이 삭제되었음
2에서 1로 172.16.1.1의 내용이 남아 있는 줄 알고 172.16.1.1로 정보를 보내고자
한다면
1에서는 *0.0.0.0 13.13.1.1의 테이블정보를 보고 2로 보냄
이렇게 되면 1과 2사이에서 정보가 계속 loop로 동작을 함
이것을 막고자 1에서 요약된 정보에 대해서
172.16.0.0 null0
로 테이블정보를 추가하여 loop동작을 방지함
(eigrp, ospf에서 자동으로 loop방지로 사용됨, rip은 사용 안함)
홀수 네트워크를 와일드카드 마스크로 나타내기
172.16.0000000 1
172.16.0000001 1
172.16.0000010 1
~
172.16.1111111 1
------------------0. 0.1111111 0
172.16.1.0 0.0.254.255
공통부분
와일드마스크
access-list 10 172.16.0.0 0.0.255.255
access-list 10 172.18.0.0 0.0.255.255
access-list 10 172.19.0.0 0.0.255.255
access-list은 중간에 끼워넣기가 불가능
ip prefix-list TEST permit 172.16.0.0/16 seq 10
지정 안하면
자동으로 5씩
증가함
access-list은 중간에 끼워넣기가 가능
172.16.0.0
~
기존정보
172.16.255.255
----------------172.16.0.0 (요약정보)
access-list (둘다 포함)
ip prefix-list (둘 중 한 개만 or 둘 다 포
함 가능)
route-map
여러 개의 조건을 하나로 묶음 -> 묶은 내용 적용
예)
router ospf 1
redistribute rip subnets <- 한 개의 조건만 적용됨, 여러 개의 조건 적용 안됨
redistribute rip matric 100 subnets route-map test
조건이 없으면 이것 실행
(set 설정 없음)
조건에 속하면 조건에 해
당 행동 수행
(set 설정 있음)
허용
순서나타냄
route-map TEST permit 10
match tag 100
set ???
deny 차단
①match -> ②permit -> ③set
route-map TEST permit 15
! <- 아무것도 없으면 조건없이 통과시키겠다는 의미
deny any (보이지는 않지만 암묵적으로 마지막에 붙어 있음)
redistribute -> 재분배 (다른 프로토콜로)
distribute-list -> 해당 프로토콜에서 원하는 라우팅 정보만 전달
ip할당방법
ipv4 : 수동, dhcp
ipv6 : 수동, dhcp, eui-64
eui-64
-> 네트워크 대역만 받아 뒤에 mac주소내용을 추가하여 만듬
link-local
=라우터 자체의 ip
link-local
=라우터 자체의 ip
show int f0/0 <- mac address 확인
show ipv6 int bri <- link-local address 확인
show ipv6 route <- ipv6 라우팅 테이블 보기
ipv6
ipv6
ipv4
양쪽 ipv6의 내용을 중간의 ipv4에서 알아보지 못하고 통과 시키는 방법
L3
L3
ipv4
ipv6
data
원래는 아래와같이 ipv4에서 사용하나 여기서는 그것을 응용함
L3
L3
ipv4
ipv4
data
BGP
-> EIGRP, OSPF위에서 동작
라우팅테이블
C 172.1.1.1 F0/0
B 199.12.1.1 13.13.13.13
D 13.13.13.13 172.1.1.1
B -> D -> C로 라우팅 테이블 정보를 보고 이동
라우터1을 넘어서 서로
논리적연결
(ping이 가능하면 됨)
AS 100
AS 200
AS 300
1
BGP 동작 X
syn =>
D의 정보(B의 정보로 갈 수 있는 통로를 알아야 함)에 해당하는 B정보가 와야
만 다른 곳에 그 정보를 광고함
(B정보가 있어도 D에 해당하는 정보에 없으면 라우팅 테이블에 안 보임)
블랙홀현상 ->
1라우터가 B의 정보가 없으므로 B에 해당하는 목적지로 가고자 하는 정보가
들어오면 어디로 가야하는지 정보가 없으므로 들어온 정보 삭제
Full mesh -> 인터페이스를 모두 연결
AS 100
AS 200
Route-reflector
AS 100
AS 200
OSPF
BR과 같은 역할
가상으로 묶음
AS 100
AS 200
EB
IBGP
EBGP
IBGP
AS 100
AS 200
4
5
1
BGP 동작 X
DMZ (OSPF, EIGRP, RIP등과 같은 프로토콜이
라우팅정보를 공유하는 프로토콜이 동작하지 않음)
BGP는 기본적으로 다른 AS의 인터페이스가 NEXT홉으로 지정됨
같은 AS안에서 NEXT홉은 다 동일함
1라우터에서 4로 가는 길을 모르므로 NEXT홉으로 4가 설정되면
라우팅동작을 제대로 수행하지 못함
해결법
1. static으로 NEXT홉을 지정해줌
2. 자동으로 NEXT홉을 5으로 지정하게 설정
AS 300
논리 인터페이스 연결 (보통 loopback 연결)
loop back
loop back
연결이 끊어져도
loopback의 정보는 연결되어 있는
다른 곳으로 광고되어 다른 라우터에
서 가지고 있으므로 ping이 가능하므
로 peer가 계속 유지
router bgp 200
network <- network으로 설정한 내용이 다른 곳으로 정보 광고됨
네이버를 맺기 위해서는 네이버로 가는 길을 알고 있어야 함
neighbor 2.2.2.2 remote-as 200
신의 인터
이스 주소
neighbor 1.1.1.1 remote-as 200
1.1.1.1
SA: 1.1.1.1
DA: 2.2.2.2
2.2.2.2
정보보냄
1.1.1.1이
자신의 네이버 목록
에 있으면 서로 네이
버연결
SA <- update-source 명령어로 loopback으로 바꾸기 가능
show ip bgp sum명령어의 결과값
state/pfxfcd
2
2개의 네트워크정보 받음
ebgp : 1홉 (기본)
ibgp : 255홉 (기본)
show ip bgp
*> 최적경로 있음(갈 수 있음)
BGP (여러 개의 라우터를 묶어서 한 개의 라우터로 생각
AS 200
AS 100
distance-vector는 홉의 제한이 있기 때문에 멀리 전파되지 못함
네트워크 정보를 관리하는 정도(개수)
BGP(distance-vector) > OSPF(link-state) > RIP(distance-vector)

similar documents