MRHS Post Mission An..

Report
Mine Reconnaissance and
Hydrographic Suite (MRHS)
Post Mission Analysis Processing
MarineSonic .MST files
SSS Data review and Targeting
MST to XTF
Isis
HTI
ext.
Target
Pro
SSS
mosaics
Triton
Map
Review
Hist.
.con
Overview of processing operations – REMUS 100 AUV
*Items covered in this document in Yellow
Remus Marine Sonic .MST to .XTF conversion
• Triton MST to XTF converter
• Convert multiple .MST files to .XTF for processing
• Use Shift+ Click to select
Triton Isis - Initialization
• Isis default display.
• Minimum screen resolution 1280 x 1024.
• Reset recommended for new project or data type.
Triton Isis – Basic Playback and review of SSS data
Reset Isis windows
Faster playback
Slower playback
Stop, (exit playback mode)
Right click
Load XTF, > start playback
Navigation
Status:
Range
Pitch, Roll,
Heading, Speed,
Depth, Altitude
File, Date, Time,
Ping number
• Channel on/off
• Slant-range correct
• Speed correct
• Threshold / Weight
PAUSE, Use <spacebar>
AT END
Triton Isis – TVG corrected data
• Auto-TVG on
• Threshold adjusted
• By default Isis imagery is reversed (white shadows)
• Manual (Custom) TVG v Auto TVG?
• The image in the Isis waterfall is used to create the Mosaic.
TargetPro
• Double-click in the Isis waterfall
to launch TargetPro and create a
Target.
• See the TargetPro section in
SAS processing for more details
NOTE: The accuracy of the
position in TargetPro depends on
the navigation and heading, if
the navigation or heading are
poor the results in TargetPro will
not be accurate, we can process
the nav both for Targets and for
the Mosaic.
Isis data review and TargetPro Practical
Mosaic creation - view navigation
• Isis: Tools>Coverage Map and Mosaic
• Check Full Triton Map mosaic
• Play the file(s) back one time in Isis to see the
navigation track in the coverage map window:
3
1
2
Coverage map
Mosaic creation – Navigation Processing
• Use the Coverage Map display to process the navigation.
• Coverage Map displays both the track and the “beam lines”
• Click “Smooth Now” more than once to see the effect of more smoothing.
• For a good mosaic and accurate Targets, beam lines must represent the true heading
of the sonar, AUV’s generally have good heading instrumentation, however towed
vehicles (and small AUVs?) may not. In this case Isis computes the heading from the
navigation (CMG)
Mosaic creation – save the processed navigation
• Save the processed navigation to a .txt file.
• TargetPro uses the processed navigation
• > Improved accuracy
Mosaic creation – Projection and resolution
•
•
•
•
•
Click “Set Projection and Bounding Box”
Check the coverage and set the resolution of the mosaic image > OK
Check “Build Sidescan Mosaic”
Click “Start Mosaic”
Select a name and location for the mosaic File (.DDS_VIF) > Save
Mosaic creation – Playback in Isis and create mosaic
The white line follows
unprocessed nav.
•
•
•
•
•
•
•
Message “Successfully started mosaic”
Data scrolled in the Isis waterfall window will be mosaiced.
Return the focus to the Isis waterfall window, go to the start of the first line to mosaic
Unpause <spacebar> or click play and select a file.
A white line is drawn in the coverage map window showing progress.
When the lines have been run Click “Done”
All windows must remain open.
Mosaic creation – view in Triton Map
•
•
•
•
Quickly view a mosaic (.DDS_VIF) file created in Isis.
Project > Insert Layer(s) > Select .DDS_VIF mosaic file.
Click the “View Extents” Icon to center the image.
Window, Zoom, Pan, Measure etc. (see Triton Map guide)
Real-time Review
Isis
Klein .XTF files
SSS Data review and Targeting
Isis
HTI
ext.
Target
Pro
SSS
mosaics
Triton
Map
Review
SITAR
CAD/ATR
ATR
.con
Overview of processing operations – Klein 5000 SSS
*Items covered in this document in Yellow
Hist.
.con
Klein 5000 real-time data review
•
•
•
•
•
Isis in record mode – the interface to the sonar is via the K5000 server.
Two scrolling windows can be configured if needed; one corrected for
speed and slant range.
Range can be 50m, 75m, 100m, 150m.
Navigation, Altitude, Speed, Pitch, Roll, Heading, are monitored.
Along track resolution 0.2m or 0.1m
Klein 5000 data review and processing
•
•
•
•
•
•
•
The same processing steps are used as for the REMUS system.
No file conversion necessary, data are logged as .XTF files.
Also possible to convert Klein SonarPro (.SDF) files to XTF.
Towed sonar system with acoustic positioning of the towed fish.
The navigation may need more careful processing.
For accurate Targets you MUST use the processed navigation file in TargetPro.
SITAR/ CAD and ATR may be used in addition to the Triton processing.
REMUS and Klein 5000 data review
and processing Practical
Non-SAS data Review
Isis
EM3002 .ALL files
HISAS files
EM Update
.ALL nav-corrected
NEXUS
Prescan
NavLab
Corrected nav
.ALL to .XTF
SAS Data review and Targeting
Isis
HTI
ext.
HISAS
mosaics
Focus
Spot
Triton
Map
Focus SAS
Processing
BathyPro
Target
Pro
Review
DTM
Contours
XYZ
SITAR
CAD/ATR
ATR
.con
Overview of processing operations – HUGIN 1000 AUV
*Items covered in this document in Yellow
Hist.
.con
.ALL to .XTF conversion
Add files: Opens a browser window to select .ALL files,
multiple files may be selected.
Remove files: Select (highlight) files, and click to remove
from the list.
Convert All files: Convert the files to .XTF format.
Processed (XYZA): For HUGIN PMA check.
Raw (Range and Angle): For HUGIN PMA uncheck
Network Optimize: Copies the files from a network drive to a
local drive before conversion, speeds processing.
Beam Time Series Data: For HUGIN PMA Exclude
Output: XTF files containing bathy data and a .log file
showing which datagrams from each .ALL file were
processed.
NOTES
• The .ALL file format is complex, not all datagrams are
converted.
• If the conversion fails send a sample .ALL to Triton for
analysis.
BathyPro - Initialization
1. Reset
2. Set Working Folder
3. Add XTF files (right – click)
NOTE
• Reset advisable for new project.
• Must choose correct .XTF type (Submetrix/Simrad)
• Error message: “No Bathy Channels in file” =
incorrect choice of XTF file type or corrupt .XTF file.
4. Initialization Successful
BathyPro – Map and Projection settings
•
•
•
•
•
Resolution. Typical 1m – 5m. Higher values
give smaller files less detail but more “hits”
per cell. Lower values give better resolution
fewer “hits” larger files slower processing.
If navigation is in Lat/Long BathyPro
automatically chooses the correct UTM grid
zone, use “Change” in Output Projection to
check.
Check that E-W size, N-S size are as expected,
also check coordinates of North-West corner.
Datum Height Offset should be 0.
Uncheck “Set Default Limit” to define a
specific area to be processed.
BathyPro – Vessel Geometry
•
•
•
•
•
•
Set Default Values (from XTF Header File):
uncheck for Hugin PMA
Tow Fish or ROV System Configuration
check for Hugin PMA
Add Depth from XTF File: check for Hugin
PMA
Transducer offsets are read from XTF file,
should be close to the values shown here.
Save these settings to a .geo offset file for
them to be used in processing. Save as…
Can also use Open… to load offsets from a
previous session.
BathyPro – Bathy Corrections
•
•
•
•
•
•
•
• Suppress Ping using Check Sum : N/A
• Suppress on Low Variance: Experimental
• Input Beam Edit File: N/A:
Suppress Beam Using Beam Quality: use the
Beam Quality flags set by the sonar.
Suppress beams outside angle from nadir: flag
beams near the edge of the swath.
Suppress beams inside angle from nadir: flag
beams close to nadir. (not used with this sonar).
Suppress Beam using Depth Range: Flag beams
that exceed a Minimum / Maximum depth for the
survey area.
Suppress Beam using Slant Range: Flag beams
that have a range greater than the entered
number.
Suppress Beam using gradient: Flag beams based
on the maximum allowable difference between
adjacent cells in the Bathymetry grid.
Suppress beam using beam number: Flag all
beams from a specific transducer.
BathyPro – Importing Tide Data
2 34
6
^
ASCII import routine
looks for nonnumeric characters
and treats them as
field separators.
• h
Numeric:
1234567890. -
BathyPro – Importing Sound Velocity (SVP) Data
1
2
^
ASCII import
routine looks for
non-numeric
characters and
treats them as
field separators.
Numeric:
1234567890. -
BathyPro – Select Processing
•
•
•
•
•
•
•
Navigation processing: uncheck if EMUpdate
was run on original .ALL files.
Gridding Soundings: check to generate a DTM,
click Settings… to choose file name for DTM
and set Average in Geoencoding Type.
Generate Grid Chart: check to enable XYZ
ASCII output of gridded data.
Generate Soundings Chart: check “Export in
ASCII and .DXF format”
Select XY unit Lat/Lon dd.ddddddd
Select Z Unit to meters.
Isocurve extraction generates contour lines in
.DXF format - set Z interval (e.g. 5m)
BathyPro – Process
Save a project (.DTM) file to preserve all processing settings.
Output files:
The digital terrain model:
grid0000.DDS_*
Bathy contour (IsoBath)file: Iso0000.dxf
ASCII XYZ data:
SoundRaw0000.txt and
SoundRaw0000.dxf
.DDS_* and .dxf are imported to Triton Map
BathyPro – View DTM in Triton Map
•
•
•
•
Quickly view a bathy DTM (.DDS_VIF) file created in BathyPro.
Project > Insert Layer(s) > Select .DDS_VIF grid file.
Click the “View Extents” Icon to center the image.
Window, Zoom, Pan, Measure etc. (see Triton Map guide)
BathyPro Multi-Beam Processing,
Practical
Playback and review of SAS data Isis - Initialization
• Isis default display.
• Minimum screen resolution 1280 x 1024.
• Reset recommended for new project or data type.
Triton Isis – Basic Playback of SSS data
Reset Isis windows
Faster playback
Slower playback
Stop, (exit playback mode)
Right click
Load XTF, (\post\SAS\sasi) > start playback
Navigation
Status:
Range
Pitch, Roll,
Heading, Speed,
Depth, Altitude
File, Date, Time,
Ping number
• Channel on/off
• Slant-range correct
• Speed correct
• Threshold / Weight
PAUSE, Use <spacebar>
AT END
Triton Isis – Slant range and speed corrected SAS data
• Same data
• Slant-range corrected
• Speed corrected
• Threshold adjusted
With these adjustments the image is improved.
Use the TVG settings to correct the grayscale in the
across-track direction, improving imagery at nadir and at
maximum range.
Triton Isis – TVG corrected SAS data
• Auto-TVG on
• Threshold adjusted
• Further improvements to the imagery
• Manual (Custom) TVG v Auto TVG?
• The image in the Isis waterfall is used to create the Mosaic.
Triton Isis – Zoom to single channel, delay and duration
•
•
•
•
Display single channel (Channel 1 OFF)
Use the Depth Delay and Duration tools to expand the display
Return these settings before loading a new file!
Cursor readout and logfile.
Triton Isis SAS data playback and
review Practical
Triton Isis – Mosaic Creation setup - SAS data
(Ignore
for SAS)
•
•
•
•
•
Map and Projection Settings
Resolution. The size of each pixel in the mosaic (m)
Check the correct UTM zone. (Use Change…)
Check E-W N-S size.
Check Latitude and Longitude of North-West origin.
OK
Triton Isis – Mosaic Creation
1
5
2
3
•
•
•
•
•
•
4
“Successfully started mosaic”
> Go back to Isis and playback the .XTF files
Be sure to leave all windows OPEN, inc Isis, TVG etc.
The Isis waterfall imagery is transferred to a Geo-corrected Mosaic Image
When file playback is complete click “Done” to close the mosaic file.
Use the “Next file in time” option in Isis to playback multiple files
Triton Isis / Triton Map – View Mosaic
•
•
•
•
Quickly view a mosaic (.DDS_VIF) file created in Isis.
Project > Insert Layer(s) > Select .DDS_VIF mosaic file.
Click the “View Extents” Icon to center the image.
Window, Zoom, Pan, Measure etc. (see Triton Map guide)
Triton Isis Mosaic Creation with SAS
data practical
Triton Map - Import SSS Mosaic, Bathy DTM and contours
• Set the working folder (post\Triton)
• Create and save a project.
SSS Mosaic in Triton Map
•
•
•
•
•
Project > Insert Layer(s)
Select .DDS_VIF file to import the mosaic, choose the .DDS_VOB for the navigation track.
Option to re-name the layer.
Click the “View Extents” toolbar icon to center the image.
Insert bathy DTM (gridxxxx.DDS_VIF) as new layer.
Bathy and Contours in Triton Map
• Click OK to import the DTM
• Use the + signs to open the layers
Import the contour file:
•
•
•
•
Project > Insert Layer(s)
Select .DXF file iso00000.DXF follow defaults.
The .DXF file is converted to a .DDS_VOB file, same projection and zone.
The contours are displayed initially as a red line.
Bathy and Contours in Triton Map
• Follow all defaults
• .DDS_VOB file to post\Triton
Bathy and Contours in Triton Map
• Contours are red by default when first imported
• Right-Click on the Vector layer and choose properties.
• Set color and label size for contours.
Changing the layer order in Triton Map
•
•
•
•
•
•
Use the Layer Manager
Change the layer order.
Show /Hide layers.
Vector layers are lines.
Image layers are raster.
Save the project.
Advanced:
• Multiple views.
• 3D Images.
Importing Targets to Triton Map
Right
-Click
•
•
•
•
•
Project > Import > Contact
OR Project > Import > Historical (separate layer)
Target marker and image will load in TritonMap
Right click > Target Info Viewer
Load Target to re-load in TargetPro
Triton Map, loading and displaying
layers. Mosaic, Bathy, Contours and
Targets - Practical
Target creation and analysis
•
•
•
•
•
TargetPro reads and processes the XTF file.
Launch by double-clicking in the Isis waterfall.
OR Click Tools>Target in the Isis toolbar.
Click Tools >Target Setup… to set contact size (Suggest: Height and Width 20m)
For accurate Targets we need good navigation, heading and an accurate altitude.
•
•
•
•
Launch TargetPro
Set Working Directory (post\Report)
Target Destination set to TargetPro
Or choose FOCUS Spot.
Target Pro Configuration and set contact number
•
•
•
•
TargetPro default Configuration
For improved image choose “Replicate and Smooth”
Navigation from File – not used for HISAS .XTF files with processed nav.
For accurate Targets with REMUS and K5000 process navigation in Coverage Map
TargetPro - Contact Measurement
• Length, Width, Shadow Icons
•
•
•
•
•
•
Measuring a Contact:
Length, Width, Shadow
Order is automatically chosen:
Length (along track)
Width (across track)
Shadow (height)
Order is automatically chosen only when Target is first created,
Use the Length, Width, Shadow Icons to re-measure later,
right-click > cancel to clear all measurements.
Choosing FOCUS spot or TargetPro
•
•
•
•
•
Choosing FOCUS spot in Target Setup
Sends information to FOCUS instead of TP
TargetPro Tools> FOCUS spot (or F4)
Sends current TargetPro image to FOCUS spot.
Spot request shows up in the list of Nexus jobs
Saving contacts in TargetPro
• Hit F9 or File>Save
• Ensure all boxes are checked
• For each Target click Yes to Save or No to discard.
•
•
•
•
•
•
Setting the confidence level for Targets in TritonMap
Setting confidence to 100 generates a green symbol.
Setting confidence to < 70 generates a yellow symbol.
Setting confidence to < 30 generates a red symbol.
Setting confidence to < 10 generates a black symbol.
Confidence setting only available for TargetPro contacts.
Target Pro - Practical
Historical Target Processing
•
•
•
•
Display of Historical targets from previous surveys in the Isis waterfall.
Distinguish between old and new targets in the Isis waterfall.
Import of Historical targets to TritonMap.
Three programs: Triton HTI Extractor, Triton Isis, Triton Map
Operational procedure:
HTI Extractor:
• Select the existing contacts folder (.CON or GeoTIFFs) for the area
• Select the folder with the .XTF files to be analyzed.
• Create the .CCD file. (cue box file)
Isis:
• Playback the .XTF files to display cue boxes around the location of Historical Targets
Triton Map:
• Import and identify Historical Targets as a unique georeferenced layer as part of a
project.
Historical Target Processing
Original survey (red lines)
New survey in the same area (yellow)
Several targets were identified during the original (red) survey. Some of these Targets
should also be seen in the XTF files of the later (yellow) survey.
Historical Target Processing shows the location of the original Targets in the Isis waterfall
during playback of the XTF files from the later survey.
Historical Target Processing
HTI Extractor: Converts the contact positions into .CCD files that Isis can read and display
• Select the folder with the
contacts from the first survey
• Select the folder with the XTF
files from the new survey
• Click “Create CCD file”
Specify either Contacts. GeoTIFS
or both.
Contact Hot Spot determines what
type of icon is drawn in the Isis
waterfall.
Heading source will be Sensor for
Hugin data.
• Contact positions that lie within the coverage of the new XTF
files appear in the left hand column.
• Contact positions that lie outside the coverage of the new XTF
files appear in the right column.
Historical Target Processing
• In Isis Click Configure > Cue boxes…
• In the Cue Box dialog Browse to the folder containing the .CCD
files created by HTI Extractor (same folder as the XTF files)
• Select the confidence level to display (TargetPro setting)
• Click OK
NOTE: The accuracy of the position is dependent on navigation
accuracy, heading accuracy, navigation update rate. Results from
the more sophisticated navigation processing in the Hugin SAS data
will be better than from the REMUS or Klein 5000 towed systems.
Historical Target Processing
• Historical Targets imported to Triton Map
have a separate layer
• Also different default symbol to
differentiate from normal contacts.
• Turn layers on and off using CTRL+ Click
on the green check mark.
Historical Targets Practical

similar documents