Chapter 8: Plotting
After completing this Chapter, you will be able to use the following
•Planning the Plot Sheet
•Plotting Environments
•Plotting from Model Space
•Plotting from Paper Space (Layout)
Planning the Plotted Sheet
There are four variables that control the relationship between the
size of objects in the AutoCAD drawing and their sizes on a sheet
of paper produced by an AutoCAD plot:
Size of the object in AutoCAD (ACAD_size)
Size of the object on the plotted sheet (ACAD_plot)
Maximum available plot area for a given sheet of paper
Plot scale (ACAD_scale)
The relationship between the variables can be described
by the following three algebraic formulas:
ACAD_scale = ACAD_plot / ACAD_size
ACAD_plot = ACAD_size x ACAD_scale
ACAD_size = ACAD_plot / ACAD_scale
In addition, following relationship exists:
LTSCALE = 1/ACAD_scale
size of the plotted dimvars_value =
dimvars_value x ACAD_scale x DIMSCALE
Plotting Environments
One of the useful features of AutoCAD is the option to work in
two different environments:
Model space is used to create design work in the 3D
environment, even though objects may have been drawn
only in a 2D plane.
Paper space (also referred as Layout) is used to compose and
annotate model drawing for plotting.
AutoCAD plots drawing from model space as well as paper space.
Plotting from Model Space
Most of the drafting and design work is created in the 3D
environment of model space, even though objects may have
been drawn only in a 2D plane.
The drawing can be plotted from model space to any scale by
specifying the plot scale in the plot dialog box.
Plot dialog box, not expanded
Expanded Plot dialog box with additional options
Plot preview
Plot Stamp dialog box
Plotting from Paper Space (Layout)
A layout is used to compose or layout model drawing for plotting.
Multiple layouts can be setup in the paper space environment. Each
one can be set up for a different type of output.
A layout may consist of a title block, one or more viewports, and
Different scales can be applied to each view within the viewport,
and specify different visibility for layers in the viewport.
Layouts are accessible by choosing the Layout tab at the bottom of
the drawing area.
Drawing layout for plotting
By default, AutoCAD creates two layouts, called Layout1
and Layout2 whenever a new drawing is created.
Setting up a Layout
Creating and Modifying a Layout
Working with Floating Viewports
Clipping Viewports
Scaling Views Relative to Paper Space
Controlling the Visibility of Layers within Viewports
Plotting from Layout
Reconfiguring the Layout with Page Setup
Annotative Scaling
Creating and Modifying Plot Style Tables
Setting Up a Layout
To set up a layout, first select the Layout tab located at the
bottom of the drawing area.
Basic parts of the default layout with only one viewport and
nothing drawn in paper space.
Layout with the objects
Creating and Modifying a Layout
The LAYOUT command creates a new layout. Up to 255
layouts can be created in a single drawing.
Choosing Layout from Template creates a new layout tab based on
an existing layout in a template (.dwt), drawing (.dwg), or drawing
interchange (.dxf ) file.
Working with Floating Viewports
AutoCAD lets you to create multiple, overlapping, contiguous,
or separated untiled viewports in a Layout.
By default, AutoCAD sets up one floating viewport in each layout.
Viewports are objects with a view into model space that can be moved
and resized. AutoCAD treats viewports in a layout like any other
object, such as a line, arc, or text object. You can use any of the
standard AutoCAD modify commands, such as MOVE, COPY,
STRETCH, SCALE, and ERASE to manipulate the floating viewports.
A viewport can be of any size and can be located anywhere in the
Floating Viewports can be created or manipulated when paper space is
Floating viewports in a layout
You can create a single floating viewport that fits the entire layout
or create multiple floating viewports in the layout. Once you create
a viewport, you can change its size and properties, and move it as
To create a single rectangular floating viewport, choose 1Viewport
from the Viewports submenu of the View menu in the Menu
To create an irregularly shaped floating viewport, choose
Polygonal Viewport from the Viewports panel.
To create a floating viewport from a closed polyline, ellipse,
spline, region, or circle, choose Convert Object to Viewport
from the Viewports panel.
Choose Display Viewports from the Viewports panel to create
multiple floating viewports. This opens the Viewports dialog box.
AutoCAD lists standard viewport configurations. Choose the name of
the configuration you want to use from the Standard viewports list.
Two vertical viewports with the objects
Resizing and rearranging the two viewports
Clipping Floating Viewports
The VPCLIP command allows you to clip a floating viewport to a
user-drawn boundary. AutoCAD reshapes the viewport border to
conform to a user-drawn boundary. To clip a viewport, you can select
an existing closed object, or specify the points of a new boundary.
To edit the model you must switch to model space using
one of the following methods:
Choose the Model tab.
Double-click over the floating viewport. On the status bar,
Paper changes to Model.
Click Paper on the status bar to return to the floating
viewport that was last current.
Scaling Views Relative to Paper Space
AutoCAD allows to scale views relative to paper space.
The scale factor represents a ratio between the actual size of the
model displayed in the viewport and the size of the layout.
The ratio is determined by dividing the paper space units by the
model space units.
The scale factor can be set with the ZOOM XP command.
You can also change the plot scale of the viewport using the
Viewport Scale Control on the Viewports toolbar.
Usually the layout is plotted at a 1:1 ratio.
Objects that are valid as clipping boundaries include closed
polylines, circles, ellipses, closed splines, and regions.
Available options include:
Polygonal selection allows you to create a clipping boundary.
Delete selection deletes the clipping boundary of a selected
Controlling the Visibility of Layers within Viewports
The Layer Properties Manager dialog box controls the visibility of
layers in a single viewport or in a set of viewports. This enables you
to select a viewport and freeze a layer in it while still allowing the
contents of that layer to appear in another viewport.
Plotting from layout
Invoke the PLOT command to plot the drawing from the
selected Layout. Before you plot the drawing from the layout,
make sure you complete the following:
• Create the model drawing.
• Create or activate a layout.
• Open the page setup dialog box and set settings such as
plotting device (if necessary configure plotting device),
paper size, plot area, plot scale, and drawing orientation.
• Create floating viewports and position them in the layout.
• Set the view scale of the floating viewports
• Annotate or create geometry in the layout as needed.
• If necessary, insert a title block or attach title block as a
reference file.
• In necessary, create or attach an existing plot style table.
• Plot the layout by invoking the PLOT command.
Reconfiguring the Layout with Page Setup
By default, every initialized layout has an unnamed page setup
associated with it. You can modify the settings for the layout’s page
setup with the help of the Page Setup Manager dialog box. Choose
Page Setup Manager from the Layouts toolbar and AutoCAD
displays the Page Setup Manager dialog box.
Page Setup Manager dialog box.
Annotative Scaling
Objects that are commonly used to annotate drawings have a property
called Annotative. With this property, you can automate the process of
scaling annotations so that they plot at the correct size on paper.
When annotative objects are created, they are scaled based on the
current annotation scale setting (can be set from the status bar) and
automatically displayed at the correct size.
Annotation scale setting is saved with model space, layout viewports,
and model views.
Before you add annotative objects to your model, set the annotation
scale to the same scale as the viewports in which you want those
objects to display. The annotation scale automatically displays the
objects in your model at the correct size.
Annotative property is turned on (set to YES) for the following objects
that are commonly used to annotate drawings:
Many of the dialog boxes used to create these objects now have an
Annotative check box, where you can specify to make the object
You can also change existing objects to be annotative by changing the
annotative property on the Properties palette.
Annotative objects display a special icon when you hover the mouse
over them in a drawing.
The Annotation Visibility button on the status bar sets the display for
annotative objects.
All the annotative objects, or only those that support the current
annotation scale, can be displayed. This reduces the need to use
multiple layers to manage the visibility of annotations for model space
and layout viewports.
When you create an annotative object in your drawing, it supports one
annotation scale: the annotation scale that is current when you create
the object. The object can be updated to support additional annotation
When you select an object that supports more than one scale, the scale
representation that supports the current scale is highlighted. The other
scale representations of the object display in a dimmed state.
Creating and Modifying Plot Style Tables
Plot style tables are settings that give control over how objects in a
drawing are plotted.
By modifying an object’s plot style, AutoCAD overrides the selected
object’s color, linetype, and lineweight.
You can also specify end, join, and fill styles, as well as output effects
such as dithering, gray scale, pen assignment, and screening.
You can use plot styles if you need to plot the same drawing in
different ways.
The actual characteristics of plot styles are defined in plot style tables
that can be attached to a specific model and layout.
AutoCAD provides two plot style modes:
Color-dependent plot styles are based on object color.
There are 255 color-dependent plot styles. You cannot add, delete,
or rename color-dependent plot styles.
You can control the way all objects of the same color plot in
color-dependent mode by adjusting the plot style that corresponds
to that object color. Color-dependent plot style tables are stored in
files with the extension .CTB.
Named plot styles work independently of object color. You
can create any number of named plot style, modify the available
properties and save it as plot style table. You can assign any plot
style to any object regardless of that object’s color. Named plot
style tables are stored in files with the extension .STB.
The default plot style mode is set in the Plot Style Table Settings
dialog box which can be opened by choosing Plot Style Table
settings in the Plot and Publish tab of the Options dialog box.
Anytime the plot style mode is changed, it is applied only for the
new drawings or an open drawing that has not yet been saved in
AutoCAD. The plot style mode can not be changed for the current
The Add Plot Style Table Wizard allows to create a plot
style from scratch, modify an existing plot style table, import style
properties from an acadr14.cfg file, or import style properties from
an existing PCP or PC2 file.
Tools menu
Choose Wizards > Add Plot Style Tables
AutoCAD also allows to modify plot styles in a plot style table by
using the Plot Style Table Editor.
Open the Plot Style Table Editor using any of the following
Choose Plot Style Table Editor button from the Finish
screen in the Add Plot Style Table Wizard.
Open the Plot Style Manager (File menu), right-click a CTB or
STB file, and then choose Open from the shortcut menu.
On the Plot Device tab of the Plot dialog box or Page Setup
dialog box, select the plot style table you want to edit from the
Plot Style Table list, and then choose the Edit button.
Plot Style Table Editor color-dependent plot style
Plot Style Table Editor for a for a named plot style
To change the plot style for one or more objects, first select the
objects (system variable PICKFIRST set to ON), and select the
plot style from the Plot Style control from the Properties toolbar.
If the plot style does not list the one you want to select, then
choose Other…, and AutoCAD displays the Select Plot Styles
dialog box. Choose one of the available plot styles.
To change the plot style for a layer, open the Layer Properties
Manager dialog box. Select the layer you want to change and
select a plot style for the selected layer similar to changing color
or linetype.

similar documents