บทที่ 11 การเชื่อมต่อ WAN และ Teleworker

Report
บทที่ 11
WAN and Teleworker
Connections
1
Agenda
อธิบายเทคโนโลยี สายเคเบิล ( HFC )
อธิบายเทคโนโลยี xDSL
การกาหนดค่า ADSL ( PPoE หรื อ PPPoA )
ตรวจสอบการกาหนดค่า Teleworker
อธิบายส่ วนประกอบและการทางานของ Frame-Mode MPLS
การกาหนดค่าและการตรวจสอบ Frame-Mode MPLS
2
บทนาเกี่ยวกับ Campus Edge
การทางานจริ งใน enterprise edge จะต้องทาความเข้าใจในหัวข้อย่อย
ดังต่อไปนี้
 Enterprise branch
 WAN
 Teleworker
3
สานักงานสาขาย่อย
 สานักงานสาขาย่อยถูกสร้างขึ้นมาเพื่อรองรับโปรแกรมประยุกต์ดา้ น
ธุรกิจ การจัดเก็บข้อมูลและการบริ การ โดยสานักงานสาขาย่อย
สามารถที่จะรี โมทเข้ามาจากสถานที่ใด ๆ ก็ได้
 การเชื่อมต่อสานักงานสาขาย่อยสามารถใช้เทคโนโลยีการเชื่อมดังนี้
• Digital Subscriber Line
• Broadband Cable
4
Enterprise WAN
 Enterprise WAN สามารถเชื่อมต่อสานักงานได้ทุกขนาดและมีการ
ให้บริ การได้มากว่าเครื อข่ายเดียว
 ตัวเลือกสาหรับการเชื่อมต่อแบบรี โมทสาหรับ Enterprise WAN
• Private WAN Layer 2 technologies
• Service Provider MPLS-Based IP virtual private networks (VPNs)
• Site-to-site and remote-access with IPSec VPNs
5
การทางานจากที่บา้ น
การทางานจากที่บา้ นมีวตั ถุประสงค์เพื่อติดต่อง่าย ปลอดภัย และการ
จัดการบริ หารส่ วนกลาง โดยปกติจะมีการสร้างลิงค์สาหรับโฮมเพจของ
ผูใ้ ช้เชื่อมต่อกลับไปยังเครื อข่ายของบริ ษทั
6
การทางานจากที่บา้ น
รู ปแบบการบริ การพื้นฐานและตัวเลือกความปลอดภัยของเครื อข่าย
สาหรับองค์กรในการทางานจากที่บา้ น ได้แก่
 IPSec VPN
 Security
 Authentication
 QoS
 Management
7
เทคโนโลยีสายเคเบิล
คาที่ใช้อธิบายเทคโนโลยีสายเคเบิล
 Broadband
 Community Antenna Television (CATV)
 Coaxial Cable
 Tap
8
เทคโนโลยีสายเคเบิล(ต่อ)
 Amplifier
 Hybrid Fiber-Coax (HFC)
 Downstream
 Upstream
9
มาตรฐาน Cable
มาตรฐานทัว่ ไปที่ใช้ในระบบเคเบิล
 National Television Standards Committee (NTSC)
 Phase Alternating Line (PAL)
 Sequential Couleur avec Memoire (SECAM)
10
ส่ วนประกอบระบบเคเบิล
ระบบเคเบิลมีส่วนประกอบหลักดังนี้
 Antenna site
 Headend
 Transportation network
 Distribution network
 Subscriber drop
11
DOCSIS
 Data Over Cable Service Interface Specification (DOCSIS) เป็ น
มาตรฐานสากลที่พฒั นาโดย CableLabs สมาคมวิจยั และพัฒนาที่ไม่
แสวงหากาไรสาหรับเทคโนโลยีเคเบิล
 DOCSIS ได้กาหนดการสื่ อสารและการทางานที่ตอ้ งการติดต่อเชื่อมต่อ
ข้อมูลผ่านระบบเคเบิลและอนุญาตให้มีการเพิ่มความเร็ วในการถ่ายโอน
ข้อมูลที่มีอยูร่ ะบบ CATV
12
DOCSIS
 DOCSIS ได้ระบุตามแบบจาลองเครื อข่ายมาตรฐานสากล (OSI) ใน
เลเยอร์ต่อไปนี้
• Physical Layer
• MAC Layer
 ช่องสัญญาณเคเบิลยุโรปสอดคล้องมาตรฐาน PAL และใช้ความกว้าง 7
MHz และ 8 MHz ส่ วนช่องสัญญาณอเมริ กาเหนือสอดคล้องมาตรฐาน
NTSC ใช้ความกว้างช่องสัญญาณ 6 MHz
13
การใช้ความถี่คลื่นวิทยุสาหรับข้อมูล
 การส่ งสัญญาณเครื อข่ายเคเบิลเป็ นไปในทิศทางเดียวกันในเวลาเดียวกัน
ความแตกต่างของสัญญาณแล้วแต่การไหลของข้อมูล
 อัตราการดาวน์โหลด ความถี่จะอยูใ่ นช่วง 50 MHz ถึง 860 MHz
 อัตราการอัพโหลด การส่ งข้อมูลจากอุปกรณ์เชื่อมต่อกลับไปยังศูนย์บริ การ
เคเบิล อยูใ่ นช่วง 5 MHz ถึง 42 MHz
14
การใช้ความถี่คลื่นวิทยุสาหรับข้อมูล
รู ปที่ 11.1 สเปกตรัม RF
15
การใช้ความถี่คลื่นวิทยุสาหรับข้อมูล
 การส่ งสัญญาณทีวีออกอากาศ จะมีการการกาหนดย่านความถี่ 2 ช่วง คือ
• Very High Frequency (VHF) ช่องสัญญาณทีวีช่วงช่อง 2 ถึง 13 , 30
MHz ถึง 300 MHz
• Ultra High Frequency (UHF) ช่องสัญญาณทีวีช่วงช่อง 14 ถึง 83 ,
300 MHz ถึง 3000 MHz
16
การใช้ความถี่คลื่นวิทยุสาหรับข้อมูล
ตารางที่ 11.1 มาตรฐานสเปกตรัมสายเคเบิลทีวีสาหรับการดาวน์โหลด
ระดับ
Sub CATV
Low band
Mid band
High band
Super band
Hyper band
Ultra band
การใช้
T7–T13
VHF TV ช่อง 2–6
UHF TV ช่อง 95–99
UHF TV ช่อง 14–22
VHF TV ช่อง 7–13
CATV ช่อง 23–36
CATV ช่อง37–62
CATV ช่อง 63–158
ย่านความถี่ (MHz)
7–58
54–88
91–120
121–174
175–216
216–300
300–456
457–1002
17
ระบบเคเบิลพื้นฐาน
 ระบบเคเบิลพื้นฐานเป็ นการแชร์สญ
ั ญาณทางอากาศ (ตอนหลังใช้การ
ส่ งผ่านจานดาวเทียมแทน) ใช้หวั ต่อแบบหลายทางไปยังทีวีดว้ ยสาย
โคแอ็กเชียล
 ตอนแรกเครื อข่าย CATV เป็ นการส่ งทางเดียวถูกรวมไปด้วยตัวขยาย
สัญญาณเพื่อชดเชยสัญญาณที่สูญเสี ยไปในสายโคแอ็กเชียล
 ระบบเคเบิลจะประกอบด้วย Headend, Trunk Cable, Amplifier,
Distribution Cable และ Subscriber Drop Cable ดังรู ปที่ 11.2
18
ระบบเคเบิลพื้นฐาน
รู ปที่ 11.2 ระบบเคเบิลพื้นฐาน
19
ประโยชน์ของสายไฟเบอร์
ใช้พ้นื ที่นอ้ ย มีขนาดบาง น้ าหนักเบาและง่ายต่อการจัดการ
สัญญาณรบกวนไม่สามารถทางานได้
มีการสูญเสี ยสัญญาณน้อย
ป้ องกันผลกระทบจากภายนอก เช่น สัญญาณรบกวนจากฟ้ าร้องหรื อ
สัญญาณวิทยุ
 ไม่ตอ้ งเพิม่ ตัวขยายสัญญาณ สามารถใช้งานได้ต้ งั แต่ระยะ 600 เมตร ถึง
5 กิโลเมตร หรื อ 40 กิโลเมตร




20
สถาปัตยกรรม HFC
โครงสร้างหลัก ๆ ประกอบด้วยเคเบิลแบบเดิม ๆ จะจ่ายเครื อข่ายไป
ตามโครงสร้างโดยใช้ท้ งั สายไฟเบอร์และสายโคแอกเชียล โดยสร้าง
เส้นทางการเชื่อมต่อเน็ตเวิร์ก การอัพเกรดโครงสร้าง HFC ต้องให้ผทู ้ ี่
สามารถจัดการที่มีทกั ษะและสามารถแปลข้อมูลเน็ตเวิร์กได้บนระบบ
HFC ระบบเคเบิลเน็ตเวิร์กยังคงเป็ นระบบที่มีพ้นื ที่เล็ก ๆ กับยูเซอร์ไม่กี่
คนในแต่ละส่ วน
21
การรับส่ งข้อมูลผ่าน cable
 การเพิ่มอุปกรณ์ในความต้องการของระบบ จะต้องมีการส่ งและรับของ
สัญญาณดิจิตอลและอนาล็อก โดต้องมีอุปกรณ์ดงั นี้
 โมเด็มเคเบิลที่ปลายสายและโมเด็มเคเบิลที่หวั สาย
 ที่ส่วนหัว การเชื่อมต่อแบบ cmts จะเชื่อมต่อทางฟิ สิ กคอล การเพิม่ cmts
ในส่ วนหัวนั้น provider จะต้องดูแลคอมพิวเตอร์ในระบบให้รองรับกับ
ฐานข้อมูลให้ได้
22
การรับส่ งข้อมูลผ่าน cable
 ที่ส่วนหัวสัญญาณถูกรับเข้ามา นี่คือที่ที่เป็ นจุดเริ่ มของสัญญาณ TV และ
จะถูกส่ งต่อไปยังลูกค้าที่อยูในระบบถัดไป
 Cmts ได้รวมสัญญาณดิจิตอลเข้าไปในสัญาณ rf
 สัญญาณ rf ถูกรวมเข้าไปในสายโคแอ็กเชียลและส่ งไปยังสายไฟเบอร์
 สายไฟเบอร์จะส่ งโดยสถานะเป็ นแสง
 สายไฟเบอร์จะส่ งสัญญาณไปยังโหนดไฟเบอร์
23
การรับส่ งข้อมูลผ่าน cable
 ที่โหนดไฟเบอร์ 2-3 วินาทีหลังการเปลี่ยนแปลงจากแสงก็จะกลับเป็ น
สัญญาณ rf
 สัญญาณ rf จะถูกส่ งไปตามสายสัญญาณพร้อมกับการขยาย เทป และ
การลดทอน
 ที่ปลายทาง จะมีการรวมสัญญาณอีกครั้ง ทั้งภาพและข้อมูล
 โมเด็มเคเบิลจะถูกจูนเข้ากับข้อมูล rf และรวมเข้าไปในข้อมูลดิจิตอล
 ข้อมูลจะถูกส่ งไปยังคอมพิวเตอร์หรื อระบบเครื อข่ายอื่น ๆ
24
Upstream Data Transfers
ขณะนี้เราจะแสดงให้ดูวา่ เกิดอะไรขึ้นในการส่ งข้อมูล
 เริ่ มที่ลูกค้า โมเด็มจะแปลงสัญญาณจากดิจิตอลเป็ นสัญญาณ rf
 จากนั้นก็จะส่ งไปที่ rf และระดับพลังงาน
 เครื อข่ายโคแอกจะเอาสัญญาณไปขยายและปรับระดับ
 เมื่อสัญญาณค้นหาไฟเบอร์โหนด จะเริ่ มเปลี่ยนเป็ นแสง
 แล้วทาการส่ งไปยังส่ วนหัวของโหนดเพื่อเตรี ยมความพร้อมก่อนส่ ง
 จะใช้เวลาซักพักแล้วส่ งไปยัง cmts
 Cmts จะจูนข้อมูล rf แล้วรวมเข้ากับข้อมูลสัญญาณ rf ต่อไป
25
การจัดเตรี ยมเคเบิลโมเด็ม
กระบวนการการกาหนดของโมเด็มเคเบิลในการรวมลาดับคาสัง่ เพือ่ การ
รับคาสัง่ ของระบบ โดยทัว่ ไปข้อมูลที่คุณจะมีจะมาจากลูกค้าปลายทาง
ทาให้ระบบดีและไม่ผดิ พลาด อย่างไรก็ตาม cmts จะต้องมีคาสัง่ เพื่อ
จัดการ server เช่น DHCP และ TFTP ดังนี้ติดตั้ง downstrrem
 เมื่อโมเด็มถูกเพิ่มพลัง มันจะสแกนและล็อก ส่ วนที่เป็ นเส้นทางของ
สัญญาณ rf
 ติดตั้ง upstream
 มันจะจัดการกับคาสัง่ ที่รับมา
 สร้างเลเยอร์ 1 และ 2
 โมเด็มจะเชื่อมต่อกับ cmts และสร้างเลเยอร์ลิงค์ข้ ึนมา
26
การจัดเตรี ยมเคเบิลโมเด็ม
 รับ IP Address
 หลังสร้างแล้วโมเด็มจะร้องขอ ip เพื่อคอนฟิ กค่าจาก DHCP server
 ได้รับ Docsis คอนฟิ ก
 โมเด็มจะขอ Docsis ไฟล์จาก server
 บันทึก Qos ใน CMTS
 โมเด็มจะบันทึกและเซ็ตค่าของ Qos ลงใน cmts
 ใส่ ค่า IP network
 เมื่อใส่ ค่าแล้ว PC base network จะเชื่อมต่อเข้า Dhcp server
27
เทคโนโลยีของ DSL
ความเร็ วในการเชื่อมต่อจะขึ้นอยูก่ บั แอพพริ เคชัน่ และข้อมูลที่ทุก ๆ คน
ต้องเข้าถึง การตัดสิ นใจของจานวนครั้งที่แบนวิดยังเหลืออยูป่ ระมาณ 3
kHz แต่ในแต่ละปี จะเหลือประมาณ 3 kHz และ 1 kHz ที่ไม่ได้ใช้โดยเรา
สามารถเพิม่ ได้ถึง 1 MHz เลยทีเดียว
28
ประเภทของ DSL
คือการส่ ง DSL สามารถแบ่งทิศทางได้ เช่น การส่ ง CATV
• Symmetrical DSL คือสื่ อที่ใช้สื่อสารระหว่างแหล่งที่มา จากต้นทางและ
ปลายทาง มีค่ารับส่ งที่เท่ากัน
• Asymmetrical DSL คือสื่ อที่ใช้สื่อสารระหว่างต้นทางและปลายทางของ
เครื อข่ายโดยปกติมีค่ารับจะสูงกว่าการส่ ง
29
การเปรี ยบเทียบความเร็ วกับระยะทาง
ประเภท DSL จะถูกจากัดด้วยระยะทางและความเร็ ว ระยะใกล้ไกลของ
เครื อข่ายท้องถิ่นหมายถึงการลดความเร็ วสูงสุ ด ที่เชื่อมต่อ DSL อยู่ และ
การเชื่อมต่อ DSL บางยังได้รับอิทธิพลจากปัจจัยต่างๆ ในเครื อข่าย
ท้องถิ่น ที่เจือจาง หรื อ เกิดจากการบิดเบือนของสัญญาณ
30
ปัญหาเกี่ยวกับ DSL
ความสาคัญที่จะทางานกับ DSL ควรประกอบด้วย 3 อย่าง คือ
 อัตราการส่ งข้อมูล สูงสุ ด ต่าสุ ด จากต้นทางและปลายทาง
 การเข้าถึงการดาเนินงาน หรื ออัตราการรับส่ งข้อมูล
 แบนด์วิธและระยะทางที่เกี่ยวข้อง
31
ปัญหา xDSL
ปัญหาการดาเนินงานกับ xDSL ควรตรวจสอบขั้นตอนต่อไปนี้
1.ตรวจสอบสถานะของ coils ในระบบ Coils Load ต้องออกจากสาย
สาหรับงาน xDSL เท่านั้น
2.ตรวจสอบการจับคู่ impedance
3. ตรวจสอบสถานะของ Taps Bridge
4.ตรวจสอบสายสาหรับ Crosstalk จากสายอื่นๆ
5.ตรวจสอบสายสาหรับการบกวนจากภายนอก เช่น การรบกวนจากวิทยุ
AM
32
รายละเอียดใน ADSL
 ADSL จะมีลกั ษณะพิเศษโดยประมาณอัตราความเร็ วข้อมูลในการรับ
หรื อส่ งข้อมูล ADSL สามารถ ทางานอยูร่ ่ วมกันกับ POTS ได้ดีกว่าเดิม
มีการเพิ่มการใช้งานอีก 3 ช่องทางคือ
 ช่อง POTS สาหรับอนาล็อก
 ช่องทางคู่ความเร็ ว
33
รายละเอียดใน ADSL
 ช่องทางที่มีความเร็ วสูง
 ในระบบ นี้ ลูกค้าสามารถใช้สายโทรศัพท์ และการเชื่อมต่อ ADSL
พร้อมกันโดยไม่มีผลใดๆทั้งสิ้ น ระยะ ห่างระหว่างผูใ้ ช้ และผูใ้ ห้บริ การ
จะมีแนวทางความเร็ วที่เพิม่ มากขึ้น ADSL สามารถสนับสนุนความเร็ ว
ได้ถึง 8 Mbps. สาหรับความเร็ วในการรับข้อมูล 1 Mbps. สาหรับ
ความเร็ วในการส่ งข้อมูล สามารถใช้ได้ใน ระยะทางถึง 18,000 ฟุต
(5,486 m) มากกว่าหนึ่งคู่สายโดยไม่ตอ้ ง repeaters ในการเพิ่ม
ประสิ ทธิภาพ
34
ADSL Equipment
บริ การ ADSL มีการใช้งานระหว่างสองโมเด็มADSL มีหนึ่งใน
สมาชิกและหนึ่งใน COโมเด็มADSL CPE เป็ นที่รู้จกั กันเป็ นหน่วย terminal
ADSL-รี โมท (ATU-R) โมเด็ม CO เรี ยกว่าหน่วย terminal ADSL สานักงาน
กลาง (ATU-C) ที่ CO เป็ นอุปกรณ์พิเศษที่เรี ยกว่า DSLAM ซึ่งเป็ นพื้นฐานมี
หลายATU-Cs มีการใช้งานบ่อย
35
Benefits of ADSL
บริ การหนึ่งที่น่าจะเป็ นประโยชน์มากที่สุดของ ADSL สามารถ
ให้ขอ้ มูลและบริ การเสี ยงในบรรทัดเดียวกัน เมื่อเสี ยงอนาล็อกรวมกับ
ADSLกรองหรื อ Splitter isolatesโมเด็ม ADSL
36
Modulating ADSL
เทคนิคการ Modulation ที่เกี่ยวข้องกับ ADSL มี
Carrierless Amplitude and Phase (CAP)
multicarrier standardized Discrete Multitone (DMT)
37
Placing Data on ADSL
เป็ นการขอดูขอ้ มูลเฉพาะที่วา่ ข้อมูลถูกขนส่ งจากโมเด็ม
DSL ของลูกค้าได้ผา่ นเครื อข่ายผูใ้ ห้บริ การ
ส่ วนที่อธิบายแต่ละขั้นตอนในกระบวนการการส่ งผ่านเครื อข่าย
1. The DSL Layer1 เชื่อมต่อจาก CPE จะสิ้ นสุ ดใน DSLAM
2. DSLAM สิ้ นสุ ดการเชื่อมต่อ ADSL แล้วสวิทช์เข้าผ่านเครื อข่าย ATM ให้
เร้าเตอร์รวบรวมข้อมูลลิงค์ โปรโตคอลชั้นที่ใช้มกั จะผ่าน DSL เป็ น ATM
DSLAM จะเป็ นพื้นสลับกับ ATM
38
Placing Data on ADSL (ต่อ)
3.เราเตอร์รวบรวมข้อมูลกันเป็ น Layer 3 และอุปกรณ์ที่เชื่อมต่อ IP จาก
client จะสิ้ นสุ ดลง
ATM และ DSL การเชื่อมต่อทางกายภาพมี 3 วิธี
 RFC 1483/2684 Bridged
 PPP over Ethernet (PPPoE)
 PPP over ATM (PPPoA)
39
PPP over ATM
PPP OVER ATMแตกต่างจาก RFC 1483 และ PPPoE ซึ่ง CPEจะตั้ง
ค่าการเชื่อมโยงให้แก้Ethernetภาพจากคอมพิวเตอร์ของผูใ้ ช้ไปที่เร้า
เตอร์ aggregator, PPPoA คือ การกาหนดเส้นทางแก้กบั PPPoA, เส้นทาง
CPE แพ็คเก็ตจากเครื่ องคอมพิวเตอร์ของผูใ้ ช้ผา่ น ATM ไปเร้าเตอร์ และ
รวบรวม PPP ขึ้นระหว่าง CPE และสรุ ปรวมเร้าเตอร์ที่แตกต่างของ
PPPoE PPPoA ไม่ตอ้ งการโฮสต์ที่ใช้ (client PPPoE) ซอฟต์แวร์เร้า
เตอร์จะรวบรวมและสิ้ นสุ ดเซสชัน PPP จาก CPE
40
วิธีการสาหรับการทางาน PPPoE มี 3 วิธี
 Router with Internal Modem and PPPoE Client
 External Modem and Router with PPPoE Client
 External Modem with End User PC and PPPoE Client Software
41
Configuring the Outside Ethernet Interface
ขั้นตอนแรกในกระบวนการนี้คือ การกาหนดอินเตอร์เฟสภายนอก
ในตัวอย่างนี้จะเป็ นแบบ Fast Ethernet 0 / 1 (Fa0 / 1)
RmtWrkRtr1(config)# interface fa 0/1
RmtWrkRtr1(config-if)# pppoe enable
42
Configuring the Dialer Interface
RmtWrkRtr1(config)# interface dialer 1
คาสัง่ Dialer Dialer interface สร้าง interface virtual
คาสัง่ นี้มาจากวันที่และเส้นทางการเชื่องโยง วิศวกรมีการวิธีเพื่อให้
การเชื่อมต่อไปยังสถานที่แตกต่างกันกับการกาหนดค่าต่างๆที่ใช้
ฮาร์ดแวร์เดียวกัน
43
Configuring NAT Overload (PAT)
RmtWrkRtr1(config)#interface fa0/0
เป็ นคาสัง่ อินเตอร์เฟส เคลื่อนย้ายแบบง่ายโดยไปที่โหมดปรับแต่ง
และกาหนดค่าสาหรับระบุการติดต่อ
RmtWrkRtr1(config-if)#ip nat inside
คาสัง่ ภายใน NAT ip จะเป็ นการบอกกระบวนการอินเตอร์เฟส
ภายในของ NAT โดยจาใช้คาสัง่ NAT ip เพื่อเป็ นการระบุทิศทางการส่ ง
RmtWrkRtr1(config-if)#interface dialer 1
การย้ายการติดต่ออินเตอร์เฟสอีกครั้งโดยการระบุ
44
Configuring NAT Overload (PAT)
RmtWrkRtr1(config-if)#ip nat outside
คาสัง่ NAT ip ติดต่อภายนอกบอกถึง กระบวนการติดต่อที่อยู่
ภายนอกอินเตอร์เฟส เช่น เดียวกับคาสัง่ ติดต่อภายใน NAT ip โดยจะใช้
คาสัง่ NAT ip เพื่อการระบุทิศทางการติดต่อของการส่ ง
45
Configuring an Inside Ethernet Interface
ใช้ IOS คุณสามารถกาหนดค่าเราเตอร์ที่เป็ นเซิฟเวอร์ DHCP
ทางานได้เต็มฟังก์ชนั เร้าเตอร์สามารถกาหนดและจัดการ IP Address ที่
อยูส่ าหรับเครื่ อง Clients โครงสร้างของตัว DHCP จะมีการคอนฟิ กูเรชัน่
(boottp options,DNS หรื อ เซิร์ฟเวอร์ WINS, DHCP )
46
Configuring an Inside Ethernet Interface
RmtWrkRtr1(config)#ip dhcp pool RmtWrk_dhcp
คาสัง่ ip DHCP คือคาสัง่ สร้าง DHCP ซึ่งสมารถกาหนดค่าใน
ฐานข้อมูลและ RmtWrk_dhcp เป็ นคาสัง่ ที่ได้รับมอบหมายในการสร้าง
pool ใหม่
RmtWrkRtr1(dhcp-config)#import all
คาสัง่ นาเข้าที่อนุญาตให้ DHCP ดึง optionจาก DHCP server เป็ น
คาสัง่ เสริ มที่ดีของ DHCP sever
47
Configuring an Inside Ethernet Interface
RmtWrkRtr1(dhcp-config)#network 192.168.10.0 255.255.255.
คาสัง่ เครื อข่ายที่ช่วยกาหนด subnet(range of addresses)ที่จะ
กาหนดให้เครื่ อง clients
RmtWrkRtr1(dhcp-config)#default-router 192.168.10.1
เริ่ มต้นคาสัง่ แจ้ง DHCP ของเราเตอร์ให้ติดต่อกับ address คุณ
ต้องการให้เครื่ อง clients มีค่าเป็ น Default geteway ช่วยให้Clients ที่เข้า
ติดต่อกับเราเตอร์โดยตรง
48
Configure Static Default Route
RmtWrkRtr1(config)#ip route 0.0.0.0 0.0.0.0 dialer 1
คาสัง่ ip router การทางานโดยการเริ่ มต้นหาเส้นทางของ Static
router ในกรณี น้ ีจะเพียงบอกว่าการติดต่อกับเร้าเตอร์เพื่อเชื่อต่อภายนอก
ในการใช้งานนี้จะทาให้เราทราบเส้นทางติดต่อทราบข้อมูลเส้นทางการ
ติดต่อกับภายนอก
49
Entire PPPoE Configuration
ตัวอย่างการตั้งค่าทั้งหมดแบบง่ายๆ
host RmtWrkRtr1
!
ip dhcp pool RmtWrk_dhcp
import all
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
50
ตัวอย่างการตั้งค่าทั้งหมดแบบง่ายๆ(ต่อ)
ip dhcp excluded-address 192.168.10.1
!
interface fa0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
!
interface fa0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
51
ตัวอย่างการตั้งค่าทั้งหมดแบบง่ายๆ(ต่อ)
interface dialer 1
ip address negotiated
encapsulation ppp
no cdp enable
dialer pool 1
ip mtu 1492
ip nat outside
ppp authentication chap callin
ppp chap password abcd1234
52
ตัวอย่างการตั้งค่าทั้งหมดแบบง่ายๆ(ต่อ)
!
access-list 110 permit ip 192.168.10.0 0.0.0.255 any
ip nat inside source list 110 interface dialer 1 overload
!
ip route 0.0.0.0 0.0.0.0 dialer 1
53
Configuring the CPE with PPPoE and an ATM
สามารถตั้งค่า เร้าเตอร์เพื่อทาหน้าที่กาหนด PPPoE client แต่ไม่ได้
ใช้โมเด็ม คุณสามารถใช้ PPPoE ในการติดต่อกับ ATM interface และจะ
เข้าสู่เครื อข่าย หมายความว่าสายโทรศัพท์จะเชื่อมต่อเร้าเตอร์ของลูกค้า
54
Configuring the CPE with PPPoE and an ATM
ความแตกต่างที่ใหญ่ที่สุดของการ configuration และการ
configuration อินเตอร์เน็ตภายในและภายนอกคือ ส่ วนที่ติดต่อภายนอก
จะเป็ น ATM interface ดั้งนั้นการตรวจสอบค่าคุณจะต้องกาหนด ATM
interface
55
การใช้ATM อย่างง่ายในการติดต่อและตั้งค่าหน้าจอ
RmtWrkRtr1(config)#interface atm 0
RmtWrkRtr1(config-if)#dsl operating-mode auto
RmtWrkRtr1(config-if)#pvc 8/35
RmtWrkRtr1(config-if)#pppoe-client dial-pool-number 1
56
การกาหนด PPPoE กับ ATM อื่นๆและการ interface
RmtWrkRtr1(config)#interface atm 0
RmtWrkRtr1(config-if)#bundle-enable
RmtWrkRtr1(config-if)#dsl operating-mode auto
RmtWrkRtr1(config-if)#interface atm0.1 point-to-point
RmtWrkRtr1(config-if)#no ip directed-broadcast
RmtWrkRtr1(config-if)#no atm ilmi-keepalive
RmtWrkRtr1(config-if)#pvc 0/35
RmtWrkRtr1(config-if)#pppoe-client dial-pool-number 1
57
Configuring the CPE as a PPPoA Client
อุปกรณ์ PPPoAกับ CPE encapsulates ในPPP session ของ
transport สาหรับการส่ งข้ามเครื อข่ายไปยัง DSLAM PPPoA ใช้บ่อย
ใน SOHO และส่ วนย่อยของมันสามารถให้ความยืดหยุน่ มากขึ้น
สาหรับการใช้ PPPoE
58
การกาหนดค่าสาหรับการกาหนดค่าอินเตอร์เฟส ATM สาหรับ PPPoA
RmtWrkRtr1(config)#interface atm 0
RmtWrkRtr1(config-if)#dsl operating-mode auto
RmtWrkRtr1(config-if)#pvc vpi/vci
59
คาสัง่ encapsulation สาหรับ DSL
คาสัง่ encapsulationสาหรับ DSL ใช้ PPPoA encapsulation เป็ น AAL5
ในโหมดMUX
RmtWrkRtr1(config-atm-vc)#encapsulation aa15mux ppp dialer
ขณะนี้การกาหนดอินเตอร์เฟสที่เหมาะสมจะ dialer pool สาหรับ
ตัวอย่างนี้ออกแบบนี้ทาให้ได้สมาชิก 1 dialer pool
RmtWrkRtr1(config-atm-vc)#dialer pool-member 1
60
ตัวอย่างการ คอนฟิ กกูเรชัน่ อย่างง่าย
host RmtWrkRtr1
!
ip dhcp pool RmtWrk_dhcp
import all
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
61
ตัวอย่างการ คอนฟิ กกูเรชัน่ อย่างง่าย(ต่อ)
!
interface ATM 0
no ip address
dsl operating-mode auto
pvc 8/35
encapsulation aa15mux ppp dialer
dialer pool-member 1
!
62
ตัวอย่างการ คอนฟิ กกูเรชัน่ อย่างง่าย(ต่อ)
interface fa0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
!
interface dialer 1
ip address negotiated
encapsulation ppp
no cdp enable
63
ตัวอย่างการ คอนฟิ กกูเรชัน่ อย่างง่าย(ต่อ)
access-list 110 permit ip 192.168.10.0 0.0.0.255 any
ip nat inside source list 110 interface dialer 1 overload
!
ip route 0.0.0.0 0.0.0.0 dialer 1
64
Minimizing Dropped Packets
ตอนนี้จะทราบว่าคุณกาหนดค่า MTUใน Dialer ในพื้นที่จาเป็ น
สาหรับเพิ่มเติม encapsulation PPPoE แต่กเ็ ป็ นไปได้ที่การจราจรจะ
ลดลงแม้คุณกาหรดค่า MTU
เมื่อโฮสต์เริ่ มเซสซัน TCPกับ อุปกรณ์ปลายทางจะ negotiates กลุ่ม
IP โดยใช้ขนาดของ (ช่อง MSS) แพ็คเก็ต TCP SYN ค่าของฟิ ลด์ MSS
จะพิจารณาหน่วยสูงสุ ด(MTU) การกาหนดค่าบนโฮสต์เริ่ มต้น MSS
สาหรับ PC เป็ น 1500 bytes
65
กาหนดค่า IP คาสัง่ MTU บนหน้าจอเดียวกับ TCP IP
กาหนดค่า IP คาสัง่ MTU บนหน้าจอเดียวกับ TCP IP ปรับสัง่ MSS จะ
ใช้คาสัง่ ต่อไปนี้
RmtWrkRtr1(config-if)#ip tcp adjust-mss 1452
RmtWrkRtr1(config-if)#ip mtu 1492
66
ขั้นตอนการดาเนินการเพื่อเปลี่ยนขนาดของ MTU
1. ดาวน์โหลดรุ่ นล่าสุ ดของ TCP จาก http://www.dslreports.com/drtcp
2. รี เฟรชหน้าเว็บเบราว์เซอร์ของคุณเพื่อให้เพจนี้ปัจจุบนั
3. เรี ยกใช้ TCP utility
4. จากเมนูเลือกอะแด็ปเตอร์ อินเทอร์เน็ตของคุณ
5. เลือก1,492 ชนิด ในช่อง MTU.
6. ใช้คลิกเพื่อบันทึกการเปลี่ยนแปลงแล้วคลิกออก
7. Reboot PC PPPoE client เปลี่ยนรี จิสทรี จะถูกบันทึกเมื่อเสร็ จสิ้ นขั้นตอน
ดังนั้นคุณต้องใช้โปรแกรม utility
67
Enterprise WAN
เมื่อคุณเริ่ มคิดเกี่ยวกับการเชื่อมต่อ sites ระยะไกล ของคุณ
จาเป็ นต้องพิจารณาต่างๆ Topologies ที่สามารถใช้ Topology ที่ดีที่สุด
คือ mesh Topology ให้วงจรเสมือนเฉพาะระหว่างของของลูกค้า
(CE)เราเตอร์ในเครื อข่ายปัญหาใหญ่ที่สุด คือ mesh โซลูชนั่ ที่มีจานวน
มากของค่าใช้จ่ายการเชื่อมโยงเสมือนได้สูง
68
Enterprise WAN(ต่อ)
สาหรับโซลูชนั่ ลูกค้าอาจเลือกที่จะใช้ mesh Topology หรื อ huband-spoke topology ปัญหาจะกลายเป็ นเส้นทางมันไม่ดีที่สุด mesh
บางส่ วนช่วยลดจานวนของวงจรเสมือนนั้นโดนปกติจานวนต่าสุ ด
เพียงพอจะให้บริ การการขนส่ งที่ดีที่สุดระหว่าง sites ที่สาคัญ
69
MPLS
MPLS ช่วยลดจานวนเส้นทาง look และสามารถใช้ส่งเกณฑ์
นอกเหนื อจากเครื อข่ายปลายทางเริ่ มต้นความสามารถนี้ ไม่จาเป็ นต้อง
เรี ยกใช้โปรโตคอล ค้นหาเส้นทางเฉพาะบนอุปกรณ์ ท้ งั หมดเพื่อบรรลุ
MPLS เก็บแต่ละแพ็คเก็ตได้รับเพิ่มเติมเลขที่ส่วนหัวที่ใช้ตดั สิ นใจได้รับ
มอบหมายในขอบของ MPLS ของเครื อข่ายและส่ งต่อภายในเครื อข่ายจะ
ขึ้นอยูก่ บั solely labels
70
Switching Types
MPLS เป็ นกระบวนการเปลี่ยนความคิดทั้งหมดมีประสิ ทธิภาพ
กระบวนการเปลี่ยนเร็ วและ ค้นหาง่าย แต่มีความซับซ้อนของเส้นทาง
การส่ งต่อกระบวนการ
71
การเปลี่ยนประเภทต่างๆ ของเราเตอร์ CISCO
 Process switching
 NN Cache switching
 NN Cisco Express Forwarding (CEF)
72
Process Switching
เมื่อก่อน slowest switching เปลี่ยนกลไกที่มีอยูใ่ นเราเตอร์Cisco
เป็ นกระบวนการเปลี่ยน กระบวนการเปลี่ยนต้องดาเนินการค้นหา
เส้นทาง(อาจจะเป็ นการค้นหาแบบrecursive) และสร้าง frame header
ของ Layer 2 ใหม่ปกติมนั ทางานช้ามาและไม่ค่อยนามาใช้
73
Cache Switching
เนื่องจากมีการเปลี่ยนแปลงกระบวนการทางานที่ชา้ เช่นวิธีแก้ไข
โดยต้องการ Cisco IOS สนับสนุนกลไก การสลับหลายแคช โดยกาหนด
ปลายเส้นทางทางล่าสุ ด แคชใช้กลไกการค้นหาเร็ วขึ้น และ stores
Layer 2 เพื่อเพิม่ ประสิ ทธิภาพการ encapsulation ใ
74
Cache Switching (ต่อ)
ในกรณี ที่ปลายทางสาหรับ encapsulation ในช่วงที่ความเร็ ว fastswitching cache มันเป็ นกระบวนการเปลี่ยนและ รายการถูกสร้างขึ้นใน
แคชแพ็คเก็ต หลังจากมีการเปลี่ยนที่อินเตอร์เฟส และการอินเตอร์รัพ
แคชเพื่อเพิม่ ประสิ ทธิภาพเส้นทาง Dubbed การ encapsulation แรกคือ
การกาหนดเส้นทางผ่านเร้าเตอร์ของหน่วยประมวลผลกลางอละเส้นทาง
remaining packets ที่เหลืออยูใ่ นเซสชันเปลี่ยนฮาร์แวร์โดยใช้แคช
75
Cisco Express Forwarding




ประกอบด้วย
Per-packet load balancing
Per-source or per-destination load balancing
Fast destination lookup
Many other features not supported by other switching mechanisms
76
สถาปัตยกรรม Router
แบ่งองค์ประกอบออกเป็ น 2 ข้อ คือ
 Control plane
 Data plane
77
Control plane & Data plane
 Control plane ควบคุมดูแลการแลกเปลี่ยน routing information และ
แลกเปลี่ยนระหว่าง อุปกรณ์
 Data plane ดูแลการส่ งข้อมูลตามที่อยู่ ปลายทาง
78
Control plane & Data plane (ต่อ)
รู ปที่ 11.9 แสดง logical diagram ขององค์ประกอบใน router
79
Control plane
Control plane มีหน้าควบคุม เส้นทางของโปรโตคอลทั้งหมดต่างๆ
ที่คุณได้ศึกษาจนถึงขณะนี้รวมทั้ง OSPF, IIGRP, EIGRP, IS-IS, ฉีก
และ BGP สามารถใช้เป็ นพื้นฐานสาหรับโดเมนส่ งต่อ MPLS Control
plane ยังถือเป็ นตัวแลกเปลี่ยน โปรโตคอลสาหรับ MPLS ด้วย เช่น ลา
เบล ของ Protocol (LDP) มีการกระจายแท็ก Protocol (TDP) BGP (ใช้
MPLS VPN)
80
Data Plane
Data Plane ทาหน้าที่ เกี่ยวกับการ Forwarding Address และ Label
การแลกเปลี่ยน label โปโตคอล
ส่ งแพ็คเก็ตโดยใช้ Label ข้อความที่เป็ นชนิดเดียวกัน label information
จะต้องมีแล้วในตารางแพ็คเก็ตเพื่อจะส่ งเป็ นแพ็คเก็ต
81
การใช้ label กากับ ใน MPLS
หนึ่งในแนวคิดการออกแบบที่ยอดเยีย่ มหลัง MPLS ทาให้มนั เข้า
กันได้กบั สื่ อประเภทสายชนิดใดก็ได้ และ Layer 2 encapsulation ที่สุด
Layer 2 จะสร้างframe based ขึ้น (เช่นกับ Ethernet) และ MPLS เพียง
เก็บ label 32-bit ระหว่าง Layer 2 และ Layer 3 หัว Label กากับนี้มกั จะ
เรี ยกว่า Layer 2 header HF โดยเฉพาะอธิบายการทางานของ MPLS
โหมดกรอบใน
82
ATM & MPLS Label
ATM เป็ นกรณี พิเศษเพราะเทคโนโลยีตอ้ งfixed-length cell (เซลล์
จะคล้ายกันในกรอบความคิดเพื่อ) เนื่องจากเซลล์ได้รับการแก้ไข label
ไม่สามารถแทรกมัน MPLS ใช้ VPI / VCI ฟิ ลด์ ใน ส่ วนหัว ATM เป็ น
ป้ ายคุณติดต่อ MPLS โหมดเซลล์ นี้
MPLS Label ประกอบด้วย 4 ช่องทางและมีขนาดรวม 32 บิต
83
ตาราง 11.5 MPLS Label ฟิ ลด์
Field
Size (bits)
Label
20
EXP
3
Bottom-ofstack (S)
1
TTL
8
Description
20 บิต label field เป็ น label จริ ง ค่า 0 to15 สงวน ไว้
สาหรับ MPLS เฉพาะ
3-bit ฟิ ลด์ EXP ใช้ โดย Cisco เพื่อ กาหนด ระดับ
ของ บริ การ (cos) (IP precedence)).
When set (1), bit S แสดง ว่า label นี้label สุ ดท้าย
ใน แพ็คเก็ต ด้านล่างของสแต็กจาไว้วา่ MPLS ให้
หลายlabelที่ จะใส่
8 บิต ฟิ ลด์ TTL เป้ าหมาย วัตถุประสงค์ เดียว กับ
TTL ฟิ ลด์ ใน ส่ วน หัว IP
84
รู ป MPLS Label Placement
85
ตารางที่11.6 MPLS PID Values
Protocol
PID Value
Description
Unlabeled IP unicast
0x0800
ระบุ payload กรอบ เป็ น แพ็คเก็ต unicast IPเก่า
Labeled IP unicast
0x8847
ระบุวา่ payload กรอบเป็ นunicastแพ็คเก็ต IP อย่างน้อยหนึ่ง
Label ก่อน head IP แสดง ว่า ส่ วน IP จริ ง เริ่ ม
Labeled IP multicast
0x8848
ระบุวา่ frame payload เป็ น multicastแพ็คเก็ต IP อย่าง น้อย
หนึ่ง Label ก่อน หัว IP bit แสดงว่าส่ วน IP จริ ง starts
86
การจัดสรรและการกระจาย Label MPLS
1. บุคคล มีอิสระในการเรี ยนรู ้ เครื อข่ายการโอนข้อมูล LSRs โดย ตาม
มาตรฐานหรื อของผู ้ ผลิต เฉพาะ IGP เช่น OSPF, IS-IS หรื อ EIGRP
2. LSR แต่ละ Local จะสร้างLabel ภายใน Label มีการกาหนดเฉพาะให้
แต่ละ IP ปลายทาง ในตาราง routing Label กากับ local จะ ถูก เก็บไว้
ในตาราง LIB
3. จากนั้น LSR จะเผยแพร่ local Label กากับเร้าเตอร์แต่ละตัว Label
เหล่านี้อาจใช้ กระโดดไป กากับที่ Label ถัดไป พวกเขาจะถูกจัดเก็บ
ไว้ ในตาราง FIB และ LFIB เพื่อให้เปลี่ยนLabel
4. และทุกๆครั้ง LSR จะสร้าง LIB, LFIB, และ FIB ลงไปในตาราง
87
Basic MPLS Network
88
การสร้างตาราง LIB
89
Forwarding a Packet through MPLS
90
Summary
สาหรับบทนี้อาจจะยาว จะกล่าวถึงการเชื่อมต่อระยะไกลและ
WAN การเชื่อมต่อผ่านทางสายความเร็ ว และบอกเรื่ องช่วงความถี่ที่ใช้
และวิธีการให้บริ การ และการใช้ที่แบนด์วิธ และความรู ้ วิธี topology
ของเครื อข่ายเคเบิล มีการเปลี่ยนแปลงเพื่อให้บริ การแบนด์วิธที่ดีกว่า
และสูงให้กบั ลูกค้า
91
Summary
ส่ วน DSL เป็ นวิธีการกาหนดค่าที่อุปกรณ์ CPE ประเภทของการ
เชื่อมต่อ DSL covered PPPoE ประเภทที่พบบ่อยที่สุดและ อธิบายว่าการ
จัดตาแหน่งของค่าที่ข้ ึนอยูก่ บั location ของ PPP
ส่ วนสุ ดท้ายที่ covered ในบทนี้คือพื้นฐาน MPLS ตรวจสอบขั้น
พื้นฐานและการเปลี่ยนเส้นทางการทางานที่จาเป็ นสาหรับการดาเนินการ
MPLS
92
สมาชิกในกลุ่ม
1.นายกฤษฎา กระชัน
2.นายจักราวุธ ซุน้ สุ วรรณ
3. นายวัฒนกร คงบัว
4. นายพิสุทธิ์ นาสวน
5. นายสุ ธน เสริ ฐกระโทก
รหัส 115030462043-0
รหัส 115030462021-6
รหัส 115030462042-2
รหัส 115030462045-5
รหัส 115030462049-7
SEC 50346CPE
93

similar documents