Document

Report
อัพเดทเส
้นทางด
้วยโปรโตคอลมาตรฐาน
Open Shortest
Path First
OSPF





กลไกการอัพเดทเส้ นทาง
การหา Router ID
การอัพเดทบนการเชื่อมต่อแบบ Point-to-Point
การอัพเดทบนการเชื่อมต่อแบบ Multiaccess
การตังค่
้ าแบบ Single-Area
11-1
ลักษณะเด
้นกว
้า RIP
ลักษณะเด
้น:
 เป็ นโปรโตคอลมาตรฐานของ IETF (OSPF version 2)
เป็ นแบบ Link State: ใช้ อลั กอริ ทมึ Dijkstra คานวณหา SPT
 ไม่มี Loop เพราะคานวณแล้ วจะได้ SPT ตัวเดียวกันทุกเราท์เตอร์
 รองรับเครื อข่ายขนาดใหญ่ ด้ วยการยุบรวมแยกเป็ นลาดับชัน้
(Hierarchy)
 Convergence เร็วกว่า เพราะติดต่อกับเพื่อนบ้ านตลอด (10 วินาที)
 ใช้ แบนด์วิธเป็ น Metric จึงยืดหยุ่นกว่า Hop Count
 มีการ Authentication ที่เข้ ารหัส MD5 ได้
11-2
้งข
ส้อมูลสภาพลิ้ระหว
งค ้างกัน
Link State
Link State = ข้ อมูลสภาพลิงค์ระหว่างตนเองกับเพื่อนบ้ าน
= Router ID Neighbor ID Cost
Shortage
Path Tree
R1  R2 = 1
R1  R3 = 1
R1  R4 = 48
R1  R5
= R1  R3  R5
= 66
Neighbor/DB
Table
Dijkstra
Algorithm
R1,R2,1
R1,R3,1
R1,R4,48
R2,R3,65
R3,R4,48
R3,R5,65
R4,R5,48
R2,R1,1
1
R2
R3,R2,65
R3,R4,48
65 R3,R1,1
1
R5,R3,65
65
R3
R5
48
R1
R5,R4,48
48
48
R4
R4,R1,48
 ทุกเราท์เตอร์ ส่ง Link State Advertisment (LSA) ของตนเองไปทัว่ ทังกลุ
้ ม่
เราท์เตอร์ เดียวกัน ส่วนหน้ าที่การคานวณเส้ นทางจะอยู่ในเราท์เตอร์ ตวั เอง
11-3
้งข
ส้อมูลสภาพลิ้ระหว
งค ้างกัน
Link State
Shortage
Path Tree
R1  R2 = 1
R1  R3 = 1
R1  R4 = 48
R1  R5
= R1  R3  R5
= 66
Neighbor/DB
Table
Dijkstra
Algorithm
R1,R2,1
R1,R3,1
R1,R4,48
R2,R3,65
R3,R4,48
R3,R5,65
R4,R5,48
R2,R1,1
1
R2
R3,R2,65
R3,R4,48
65 R3,R1,1
1
R5,R3,65
65
R3
R5
48
R1
R5,R4,48
48
48
R4
R4,R1,48
 จากกลไกด้ านบน สิ่งที่เราท์เตอร์ ต้องทาจึงได้ แก่
 หา Router ID ของตนเอง
 หาเราท์เตอร์ เพื่อนบ้ านของตนเอง
 หาค่า Metric หรื อ Cost ของลิงค์กบั เพื่อนบ้ าน
 ส่งข้ อมูล Link State (LSA) ไปให้ เราท์เตอร์ อื่นๆ ในกลุม่
11-4
ไอดีประจ
้าเราท
้เตอร
้
Router ID
Router# show ip interface brief
Interface
IP Address
OK? Method Status
Protocol
Ethernet0
190.172.32.10 YES NVRAM
up
up
Loopback0
208.149.23.162 YES NVRAM
up
up
Loopback1
208.149.23.194 YES NVRAM
up
up
Serial0
220.173.149.10 YES NVRAM
down
down
Serial1
unassigned
YES NVRAM administratively down down
 เนื่องจากแต่ละเราท์เตอร์ ต้ องมีชื่อ (RouterID) ของตนเอง จึงจะอ้ างอิงกับ
เราท์เตอร์ อื่นๆ ในกลุม่ ได้
 เราท์เตอร์ จะตัง้ Router ID ของตนเอง ตามตัวแปรเหล่านี ้ ตามลาดับ:
 ตามการตังค่
้ าเอง เช่น Router(config-router)# router-id 1.1.1.1
 ตามไอพีของอินเตอร์ เฟสที่เสถียรมากสุด และเปิ ดใช้ งาน ณ เวลาเปิ ด OSPF
ที่มีค่ามากที่สุด!!
 ยึดตามกลุม่ อินเตอร์ เฟส Loopback ก่ อน (เสถียรที่สดุ )
11-5
 ยึดตามกลุม่ อินเตอร์ เฟสปกติ
ลงทะเบียนเราท
้เตอร
้เพื่อ้าน
นบ
Adjacency
Hello
Packet
Router A แลกเปลี่ยน Hello
Packet เพื่อติดต่อกับเพื่อนบ้ าน
Hello
B
Router ID
Hello and Dead intervals *
Neighbor ID
Router Priority
DR IP Address
BDR IP Address
Hello
A
C
Hello
Hello
LSA
LSA
Neighbor Table Router A
A
B
- Loading : Full -
 ช่ วงเวลา Hello และ Dead Interval ต้ องเท่ ากันทัง้ ตัวเอง
และเพื่อนบ้ าน ถึงจะติดต่ อเป็ นเพื่อนบ้ านกันได้
 โดยดีฟอลท์ Hello time = 10 sec, Dead Interval = 30 sec
 สร้ าง Adjacency แล้ ว จึงซิงโครไนซ์ LSDB ให้ ตรงกัน (Loading)
“Adjacency State: Loading to Full”
11-6
C
เมตริ้ของ
กซ OSPF
้วนกลั
ส
บ Bandwidth
Metric (Cost)
Link Type
= ส่วนกลับของแบนด์วิธ
= 108 / {Bandwidth บนอินเตอร์ เฟส (หน่วย bit)}
= 100 Mbps / Bandwidth (Mbps)
Bandwidth
OSPF Cost
(โดยดีฟอลท์ )
Serial
1,544,000
65
E1
2,048,000
48
Ethernet
10,000,000
10
Fast Ethernet
100,000,000
1
Gigabit Ethernet
1,000,000,000
1
 สามารถตังค่
้ า Cost
ได้ เองตามต้ องการ
(Manual)
11-7
การส
้งต
้อ Link State
Link State Advertisment
Neighbor Table
NT: R1
NT: R2
1
1
R2
R3
R3,R4,48
1
R1
R1
R4
NT: R3
R2 48 R3
NT: R5
R3
65
R5
R4
48
+
R3
R1
R5
R5,R4,48
48
48
R4
R4,R1,48
1
R5
65
48
R3 48 R4
R2 65 R3 48 R4
R5,R3,65
65 R3,R1,1
1
NT: R4
R1
R2
1
48
R3,R2,65
R2,R1,1
R1
R1
48
1
R2
1
48
R3 48 R4
65
65
R5
1
R2
1
R3 48 R4
65
48
R5
11-8
Shortage Path Tree (SPT)
Database Table
OSPF บนเครื้ายแบบ
อข
R1,R2,65
Point-to-Point
R2,R1,65
 เป็ น Network Type ดีฟอลต์ ของอินเทอร์ เฟซ Serial
 ตัวอย่างเครื อข่าย Point-to-Point ที่จะให้ OSPF ทางาน เช่น
 Leased Line ที่เชื่อมต่อด้ วยโปรโตคอล HDLC หรื อ PPP
 Frame-Relay ที่ตงค่
ั ้ าให้ ใช้ Subinterface แบบ Point-to-Point
 ไม่ มีปัญหาการส่ ง LSA ซา้ ทับกัน จึงไม่จาเป็ นต้ องเลือกตัวแทนเราท์เตอร์ ที่
คอยรวบรวม LSA (Designate Router; DR)
 ส่ง LSA แบบ Multicast 224.0.0.5
11-9
OSPF บนเครื้ายแบบ
อข
Multiaccess
RX,RX,XX
RX,RX,XX
RX,RX,XX
RX,RX,XX
RX,RX,XX
 ตัวอย่างเครื อข่าย Broadcast Multiaccess ที่จะให้ OSPF ทางาน ได้ แก่
Ethernet LAN ที่เชื่อมต่อเราท์เตอร์ หลายตัวผ่าน LAN Switch
 มีปัญหาการส่ ง LSA ซา้ ทับกัน (เพราะต่ างมีจานวนเพื่อนบ้ านเท่ ากัน เห็น
กันหมดผ่ าน LAN)! จาเป็ นต้ องเลือกตัวแทนเราท์เตอร์ ที่คอยรวบรวม LSA
(Designate Router; DR) และ DR สารอง (Backup DR; BDR)
11-10
OSPF บนเครื้ายแบบ
อข
Multiaccess
DR
RX,RX,XX
DROTHER




RX,RX,XX
BDR
RX,RX,XX
DROTHER
RX,RX,XX
RX,RX,XX
DROTHER
เลือกเราท์เตอร์ ที่เป็ นตัวแทนรวบรวม LSA (DR) และตัวสารอง (BDR)
เราท์เตอร์ ตวั อื่นเรี ยกชื่อเป็ น DROTHER (ลูกน้ องของ DR)
DROTHER ส่ง LSA ไปรวมยัง DR และ BDR (ผ่านมัลติคาสต์ 224.0.0.6)
แล้ ว DR และ BDR ส่ง LSA ที่สรุปรวมแล้ ว ให้ DROTHER ทุกตัว (ผ่านมัลติ
คาสต์ 224.0.0.5)
11-11
 เป็ น Network Type ดีฟอลต์ ของอินเทอร์ เฟซ Ethernet
การเลือกตัวแทนเราท
้เตอร
้
DR และ BDR
 เลือกตามลาดับความสาคัญก่อนหลัง ดังนี ้
 ตามค่า Priority ที่ตงค่
ั ้ าไว้ บนเราท์เตอร์ ด้ วยคาสัง่
 Router(config-if)# ip ospf priority (เลข Priority)
 ถ้ าไม่ได้ ตงค่
ั ้ า Priority บนเราท์เตอร์ ตวั ใด Priority ตัวนันจะเท่
้
ากับ 1
 ถ้ าค่า Priority = 0 อินเทอร์ เฟซนันต้
้ องเป็ น Drother เท่านัน้
 ถ้ า Priority เท่ากันทังหมด
้
จะเลือกจาก Router ID ที่มีคา่ มากที่สดุ
 ตัวรองลงมา จะเลือกเป็ น BDR
11-12
การเลือกตัวแทนเราท
้เตอร
้
DR และ BDR
OSPF Network Types:
Multiaccess Broadcast Network Group1
OSPF Network Types:
Multiaccess Broadcast Network Group2
RID: 2.2.2.2
RID: 4.4.4.4
R4
R2
Fa0/0
Pri:1
10.1.1.2/24
Fa0/0
Pri:1
10.1.1.4/24
Router ID:
R3(config)#interface Loopback0
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R3(config)#router ospf 100
R3(config-router)#router-id 3.3.3.3
Interface Priority:
R3(config)#interface fa0/0
R3(config-if)#ip add 10.1.1.3 255.255.255.0
R3(config-if)#ip ospf priority 5
RID: 5.5.5.5
SW1
RID: 1.1.1.1
Fa0/0
Pri:10
10.1.1.1/24
Fa0/0
Pri:5
10.1.1.3/24
R3
RID: 3.3.3.3
DR: RID 1.1.1.1
BDR: RID 3.3.3.3
R1
R5
Fa0/0
Pri:1
20.1.1.5/24
BDR RID: 6.6.6.6
Fa0/1
SW2
Pri:1
20.1.1.1/24
Fa0/0
Pri:1
20.1.1.6/24
R6
Fa0/0
Pri:1 DR
20.1.1.7/24
R7
RID: 7.7.7.7
11-13DR: RID 7.7.7.7
BDR: RID 6.6.6.6
OSPF กับเฟรมรีเ้แบบ
ลย
DR
NBMA
Frame Relay
Network
 ปกติ NBMA ไม่รองรับการใช้ เราท์ติ ้งโปรโตคอล ซึง่ ต้ องใช้
มัลติคาสต์หรื อบรอดคาสต์ เพราะข้ อจากัดเรื่ อง Split Horizon
 เนื่องจาก DR/BDR สามารถส่ง LSA ที่สรุปแล้ วให้ แก่ DROTHER
อื่นได้ ทางอินเตอร์ เฟสเดียวกับที่รับมา
 ดังนัน้ จึงสามารถใช้ OSPF บนเครื อข่ ายแบบ NBMA ได้
11-14
(แต่ตอ้ งตัง้ ค่าเพือ่ นบ้านให้มนั เอง)
สรุปเครื้ายที
อข ้องใช
่ต ้ตัวแทน
DR/BDR
40.3
40.2
40.4
NBMA
DR
s0
BMA
50.2
40.1
20.2
10.3
BDR
10.4
10.1
P2P
DR
10.2
30.1
50.3
50.4
s0
s0.1 MP 50.1 DR
P2P
20.1
NBMA
Frame Relay
Network
30.2
s0.2 P2P 60.1
s0.3 P2P 70.1
s0.4 P2P 80.1
60.2
Frame Relay
Network
70.2
80.2
11-15
การแยกพื้น้าหรั
ที่ส บ OSPF
แบบ Hierarchy
 เพื่อให้ คานวณได้ ในวงจากัด และเกิดเส้ นทางที่เสถียรในกลุม่ เราท์เตอร์ ขนาด
ใหญ่ จึงต้ องแบ่งกลุม่ ออกเป็ นพื ้นที่ (Area) โดยกลุม่ พื ้นที่ย่อยจะต้ อง
11-16
เชื่อมต่อกับกลุม่ พื ้นที่หลัก หรื อ Area 0
 ระหว่าง Area จะสรุปเส้ นทางรวมไว้ สื่อสารระหว่างกัน
การตั้า
้งค OSPF พื้นที่เดียว
Single Area (0)
 ตังค่
้ าเปิ ดใช้ OSPF เป็ นเราท์ติ ้งโปรโตคอลของเราท์เตอร์ นี ้
Router(config)# router ospf (รหัสโปรเซส
ตัง้ อย่าให้ซ้ ากันถ้าจะแยกโปรเซส)
 ตังค่
้ าอินเตอร์ เฟสที่อนุญาตการทางาน (ทังการรั
้
บส่งอัพเดต และการอัพเดตเครื อข่ายบนอินเตอร์ เฟส)
Router(config-router)# network (network ID) (wildcard-mask) area 0
10.1.1.0/30
router ospf 1
network 10.1.1.0 0.0.0.3 area 0
network 10.2.2.0 0.0.0.7 area 0
10.2.2.0/29
หรื อเขียนเป็ น “network 10.0.0.0
0.255.255.255 area 0” ก็ได้
11-17
การเป
้ดใช
้บนอินเตอร
้เฟส
้วยค
ด ้าสั่ง Network
 คาสัง่ Network (สาหรับ IGP) คือการสัง่ เปิ ดการทางานของเราท์ติ ้งโปรโตคอลนันๆ
้ บน
อินเตอร์ เฟสที่ “ค่ าที่อยู่ไอพี” อยู่ในซับเซ็ตของกลุ่มไอพีในคาสั่งนี ้
 ดังนัน้ ด้ วยความสามารถของ Wildcard Mask ที่ระบุกลุม่ เลขไอพีที่สนใจได้ ละเอียด (Arbitrary Bit)
จึงสามารถใช้ คาสัง่ network ไล่เปิ ดทีละอินเตอร์ เฟสด้ วยการใช้ Wildcard 0.0.0.0 ดังนี ้
Router(config-router)# network (ทีอ่ ยูไ่ อพีบนอินเตอร์เฟสนัน
้ ) 0.0.0.0 area 0
แปลว่ า สนใจไอพีทงั ้ 32 บิต
10.1.1.0/30
router ospf 1
network 10.1.1.2 0.0.0.0 area 0
network 10.2.2.2 0.0.0.0 area 0
10.2.2.0/29
อินเตอร์ เฟส S2
อินเตอร์ เฟส S3
11-18
การทวนสอบการตั้า
้งค
 ตรวจดูว่าเราท์เตอร์ ใช้ OSPF เป็ นเราท์ติ ้งโปรโตคอลตามที่ตงค่
ั ้ าไว้ หรื อไม่
Router# show ip protocol
 คาสัง่ แสดงเส้ นทางที่เรี ยนรู้มาได้
Router# show ip route
Codes: I - IGRP derived, R - RIP derived, O - OSPF derived,
Gateway of last resort is 10.119.254.240 to network 10.140.0.0
O 10.110.0.0 [110/5] via 10.119.254.6, 0:01:00, Ethernet2
O 10.68.132.0 [110/5] via 10.119.254.6, 0:00:59, Ethernet2
O 10.130.0.0 [110/5] via 10.119.254.6, 0:00:59, Ethernet2
11-19
การทวนสอบการตั้า
้งค
 ตรวจสอบ Router ID และเลขโปรเซส
Router# show ip ospf
Routing Process "ospf 50" with ID 10.64.0.2
 ตรวจสอบเราท์เตอร์ เพื่อนบ้ านที่ร้ ูจกั
Router# show ip ospf neighbor
ID
10.199.199.137
172.16.48.1
172.16.48.200
10.199.199.137
Pri State
Dead Time
1
FULL/DR
0:00:31
1
FULL/DROTHER 0:00:33
1
FULL/DROTHER 0:00:33
5
FULL/DR
0:00:33
Address
Interface
192.168.80.37 FastEthernet0/0
172.16.48.1
FastEthernet0/1
172.16.48.200 FastEthernet0/1
172.16.48.189 FastEthernet0/1
 ถ้ าการเชื่อมต่อเป็ นแบบ Point-to-Point เราท์เตอร์ แต่ละฝั่ งจะ
ให้ เพื่อนบ้ านอีกฝั่ งหนึง่ เป็ น DR ของตนเอง โดยไม่มี BDR
11-20
 ทาให้ ต่างฝ่ ายต่างใช้ 224.0.0.5 ในการสื่อสารระหว่างกัน
การแบ
้งโหลด Cost้า
เท
Equal-Cost Load Balance
ดีฟอลต์บน Routing Table อนุญาตให้ เส้ นทาง
ที่ Cost เท่ากันมาแบ่งโหลดกันได้ 4 เส้ นทาง
แต่เราแก้ ไขการตั ้งค่าบนเราท์ติ ้งโปรโตคอลได้ :
 OSPF สามารถตังค่
้ าให้ เราท์แพ๊ กเก็ตแบ่งกันระหว่างเส้ นทางได้
11-21
 แต่ ต้องเป็ นเส้ นทางที่มีค่า Cost (Metric) เท่ ากันเท่ านัน้
 บน OSPF ใช้ คาสั่งตัง้ ค่ า Cost บนแต่ ละอินเตอร์ เฟสเองให้ เท่ ากันได้ !

similar documents