Supplemental PowerPoint

Molecular Mechanics and Dynamics
Characterization of an In Silico Mutated
Protein: A Stand-Alone Lab Module or
Support Activity for In Vivo and In Vitro
Analyses of Targeted Proteins
This week
• Learn about the software for modeling
– Use the software to create representations of your
protein highlighting features of interest
– Make a mutant form of your protein
– Solvate your mutant protein
– Start your mutant protein “shaking” to find
configuration that gives you the energy minimum
• Measure the ATP-binding pocket in wild type
Your lab report
• In your growing lab report, you’ll
– Make revisions
– Report the modeling you set up this week (not in
– Report the size of the ATP-binding pocket in the
wild type CK1 (probably in table form)
• If you don’t get these measurements finished this
week, you can come in and use the computers next
week to finish. Lab report due in two weeks.
Downloading the CK1 Structure
• Set up a folder to do your work in
– C:/Users/Student/My Documents/CK1-modeling
• We are going to use a crystal structure for a
CK1 from Schizosaccharomyces pombe
• Go to the Protein Data Bank (
• Search for 1CSN
– 1CSN is the pdb identifier for casein kinase - 1
Downloading the CK1 Structure
“Download Files”
and select
“PDB File (Text)”
Dowloading CK1 structure
• The file is downloaded into the “Downloads”
• Pull up the Downloads window and drag the
1CSN.pdb file into the CK1-modeling folder
you created.
Viewing the PDB File Text
• Right click on the 1CSN.pdb file and choose “Open
• Click the radio button for “Select the program from a
– Double click “Word”
– You may want to adjust
the margins to “narrow”
under Page Layout to
allow the file to be
displayed well.
Anatomy of the PDB File
• The Header
Anatomy of the PDB File
• The amino acid sequence and secondary structure
Anatomy of the PDB File
• The atoms, their
amino acid, and their
Anatomy of the PDB File
• Non-protein atoms like
Mg, ATP, SO4, H2O, etc.
Anatomy of the PDB File
• Connection table and
end of file
Viewing Casein Kinase - 1
• Open the program VMD
Viewing Casein Kinase - 1
• You will see three windows
Viewing Casein Kinase - 1
• In the VMD Main window select
“File → New Molecule…”
Viewing Casein Kinase - 1
• In the Molecule File Browser window that
opens click “Browse” and find your pdb file
Viewing Casein Kinase - 1
• The “Filename” region should now have the
path to your pdb file, and “Determine file
type:” should have PDB
• Click “Load”
Viewing Casein Kinase - 1
• The enzyme will
appear in the
OpenGL Display
• Notice the
various colors.
What do they
• Left click on the
black region and
move your mouse
Viewing Casein Kinase - 1
• In the “VMD Main” window, click
“Graphics → Representations”.
• This will open a new window
Viewing Casein Kinase - 1
• Try changing the Drawing Method
to see various representations
like, CDW, CPK, Ribbons, new
Ribbons, Cartoon, etc.
• Now, set it to Ribbons
Viewing Casein Kinase - 1
• You’re now going to highlight
some of the interesting features
of CK1s
• Click on Create Rep
• In the Selected Atoms box, type “resname
• Under the Draw style tab, set the Drawing
Method to “Lines” and select “Color ID”
under “Coloring Method”. This should
highlight the ATP in a different color than the
whole protein.
Viewing Casein Kinase - 1
• Highlight the ATP-binding pocket
• Create Rep
• Use the CPK drawing method and the
Color ID coloring method to highlight
residue 13 (this is Gly 83 in Yck2)
• Create Rep
• Use the CPK drawing method and the
Color ID coloring method to highlight
residue 15 (this is Gly 85 in Yck2). Keep
the color the same for these amino acids
because they’re both part of the ATPbinding pocket.
• Repeat these steps for residue 18, 35,
148, 149, and 150.
Viewing Casein Kinase - 1
• Highlight the RD pocket
• Create Rep
• Use the CPK drawing method and the
Color ID coloring method to highlight
residue 124 (this is Arg194 in Yck2). Use a
different color for the RD pocket than you
used for the ATP-binding pocket.
• Create Rep
• Use the CPK drawing method and the
Color ID coloring method to highlight
residue 153 (this is Lys223 in Yck2). Keep
the color the same for the amino acids
that make up the RD pocket.
• Repeat these steps for residue 170.
Viewing Casein Kinase - 1
• Highlight the activation loop
• Click Create Rep
• In the “Selected Atoms” box, type “residue
151 to 181”
• This is the activation loop
• Click “Create Rep”
• On the “Draw style” tab select “ColorID”
under “Coloring Method”. Choose a different
color than you used for the RD pocket or the
ATP-binding pocket.
Creating Representation
• Here is a representation showing some important residues.
Measuring Distances
• You can select atoms by changing the mouse behavior in
the Mouse menu to “Label → Bonds”
• Click on two atoms, and the distance between them will be
Measuring the ATP-binding pocket
• You’ll use this feature to measure the
distance between atoms that make up the
ATP-binding pocket.
Saving Protein for Simulation
• Open the Tk Console under the Extensions menu
Saving Protein for Simulation
• In TkConsole, change directory to your modeling folder
• It will depend on your computer folder hierarchy, but the
command is something like
• cd ../../../Users/Student/Documents/CK1-modeling
• If you close VMD for any reason, you will need to re-enter this command to put
yourself back in the proper working directory.
• The default directory for VMD on Windows is C:/Program Files (x86)/University
of Illinois/VMD if you mistakenly save work without changing directory first.
Saving Protein for Simulation
• In TkConsole, set a variable “csn” that stores only the
• set csn [atomselect top protein]
• Write a new pdb file storing only the protein (no ATP, Mg,
SO4, H2O will be saved)
• $csn writepdb csnp.pdb
Saving Protein for Simulation
• You can select anything and everything you want rather
than just the protein just like when you created
representations. Some other options
• all
• protein
• residue
• resname
• E.g., if you wanted to keep the ATP, you’d use the boolean
operator OR
• set csnatp [atomselect top protein OR resname ATP]
Check Your New csnp.pdb
• Open with Word and make sure only amino acids 6-298 are
in the file
Beginning of file
End of file
Open Your New pdb File
• First, delete 1CSN by selecting it in the VMD Main window.
• Next, select Delete Molecule from the Molecule menu.
• Then, File → New Molecule…
Generate a psf file
• The simulation software (namd ) requires a .psf
• psf stands for protein structure file
• Tells namd about
• Charges and ionization state of histidine
• The nature (stiffness) of bonds (C-C, C-N, C-O, etc.)
• Non-bonded interactions
• Angles (e.g., dihedral)
• NAMD stands for NAnoscale Molecular Dynamics
• It is pronounced NAM-DEE
Generate a psf file
• Open the automatic psf builder
• VMD Main
• Extensions → Modeling → Automatic PSF Builder
Generate a psf file
1. Change the Output basename to csn
2. Leave the default topology
3. Click Load input files
Just do this once! Don’t be impatient—you
won’t see anything happen unless you can
see the console window.
4. Click Guess and split…
5. Click Create chains. A message may
pop up. This is fine. Click OK.
Check the TkConsole Output
1. You should see some warnings. These are OK as long as you see the two Info
sections saying the psf and pdb were written. Wait until you see “Updating
structures” and you are returned to a blinking cursor.
Check the Output Files
Your modeling folder should have two files named csn. One is a .psf, and one is a
You can open the pdb in Word to make sure it is still amino acids 6-298 again.
Open Your New Files in VMD
• First, delete csnp.pdb and csn.psf by selecting them in the
VMD Main window.
• Next, select Delete Molecule from the Molecule menu.
• Then, File → New Molecule…
• Load csn.psf first, then
load csn.pdb
Look at your New Files in VMD Display
• When the psf was generated, VMD added hydrogen to all of the amino acids (white
• Hydrogens are not present in x-ray crystal structures because they are smaller (0.5
Å) than x-ray wavelengths (≥1 Å), and the single electron does not interact with xrays
Make Your Mutation
• Open the Mutator
• VMD Main
• Extensions → Modeling → Mutate Residue
Make Your Mutation
If you correctly loaded psf and pdb files,
these will be correctly filled in for you.
Change the output name to csn_mutation.
Enter the mutation target residue number.
Enter the mutation you want.
Remember, the numbering is different for this file:
S. pombe CK1
Mutated aa code
Arg194 Arg130
Lys223 Lys159
Lys240 Lys176
Ser243 Ser179
Run mutator
Check Your Mutation
• Open Tk Console and check that it completed successfully.
• The mutation should have created a pdb and psf file.
• Open the pdb file and make sure your mutation was successfully
introduced. The file should be in your working directory (see slide
Double mutations
If you are doing a double mutation (e.g., R194Q/S243D), repeat the mutator steps to
generate your second mutation, but use the mutated files with the single mutation as
the starting point.
Again, check your pdb file to make sure that both mutations you want are generated.
Solvating Your Protein
• NAMD is an explicit solvent molecular dynamics simulator. This means it has water
molecules surrounding the protein. Some simulators use implicit solvent that
mimics water dielectric without the molecules being present in the calculations.
Implicit solvents are faster to simulate but typically cause proteins to adopt more
closed configurations.
• Open the Solvator
• VMD Main
• Extensions → Modeling → Add Solvation Box
Solvating Your Protein
If you correctly loaded psf and pdb files,
these will be correctly filled in for you.
Change Output: csn_mutation_wb
Use Molecule Dimensions
Click Solvate
Solvating Your Protein
• VMD creates psf and pdb files with the water box (_wb).
• Your new solvated protein should have appeared.
• Delete the unsolvated molecule in VMD and create a nice
representation of your solvated one.
Coordinates of Your Protein
• We need to know where your protein in its water box sits in 3D
space. Use TkConsole.
• set everyone [atomselect top all]
• measure minmax $everyone
• Returns {xmin, ymin, zmin}{xmax, ymax, zmax}
• Store these somewhere (in a lab notebook or in a file)
• See image below for what the output looks like
Equilibrating Your Protein
• Calculate the center of your water box.
xc 
xmin  xmax
yc 
y min  y max
zc 
z min  z max
• Calculate the size of your water box
xsize  xmax  xmin
ysize  ymax  ymin
z size  zmax  zmin
Equilibrating Your Protein
• We need to get the protein to adjust itself because the mutation and water
introduce new forces. In physics, forces have the potential to push things around.
This is potential energy. NAMD will attempt to rearrange the protein to minimize
the potential energy. This is the same as trying to find where all the forces exactly
cancel one another.
• Delete all open molecules using VMD Main.
• Open your mutated .psf that has the water box, and without closing the open
window, browse to and open your mutated .pdb that has the water box in the same
• You can make a nice representation
if you wish.
Equilibrating Your Protein
• Open the NAMD Graphical Interface
• Extensions → Simulation → NAMD Graphical Interface
Equilibrating Your Protein
• If your directory is already set in
TkConsole, Working dir will be
• You will want to add “_min” to
Simulation basename
• The input files should be correct.
They were guessed based on what
you have open.
• The parameter files should be
okay too.
• Make sure Minimization is
checked, and the number of steps
is 10,000 (not 1000)
Equilibrating Your Protein
• Next we need to tell NAMD the
type of simulation we want.
• Open the Ensemble panel
• Edit → Ensemble
Equilibrating Your Protein
• Next we need to tell NAMD the
type of simulation we want.
• Open the Ensemble panel
• Edit → Ensemble
• We will use NVT
• Constant number of objects
• Constant volume of the water
• Constant temperature of 310K
• Select Periodic boundary
• You will get an error about
not finding and xsc file. Click
OK, and reopen the Ensemble
Equilibrating Your Protein
• Click Edit to open a panel for
entering the periodic boundary
• In this panel you enter the values
calculated earlier
• The values should be separated by
a space
• Close these two windows by
clicking Ok.
xsize  xmax  xmin
ysize  ymax  ymin
z size  zmax  zmin
xcenter 
xmin  xmax
ycenter 
y min  y max
zcenter 
z min  z max
Dr. Brame says:
If the NAMDgui gives you an error message about -1, close the
NAMDgui and go to VMD Main.
Set the box on the bottom lefthand corner to zero and press the
arrow at the bottom right. Then repeat the NAMDgui work.
Equilibrating Your Protein
• Finally, select Particle Mesh Ewald
• This speeds up the calculation of electrostatic (charge) interactions.
• Close the window.
Equilibrating Your Protein
• Open the Other Simulation
Parameters panel
• Edit → Other Simulation
Equilibrating Your Protein
• Open the Other Simulation Parameters panel
• Edit → Other Simulation Parameters
• Check that all of the values are as shown.
• Close the window
Equilibrating Your Protein
• Click Run NAMD
Equilibrating Your Protein
• The minimization will take
30 – 60 minutes.
• It will say Status: Running
until it completes
Equilibrating Your Protein
• You should have a bunch of new files with “_min”.
Simulating Your Protein
• Now, we’re ready to run a simulation.
• Go back to the NAMDgui panel.
• Change the basename to have “MD”
• Use the .coor or restart.coor file for
the pdb input
• Use the restart.xsc for the xsc input
• Number of steps = 1,000,000 = 1 ns
• Select Molecular dynamics
• Select Continue simulation
Simulating Your Protein
• The molecular dynamics simulation
attempts to make the enzyme
behave as it would in a cell.
• When it is finished you will be able to
watch the enzyme “jiggle”.
• You will also be able to make
measurements to see if the mutation
had an effect on the average distance
between the activation loop and the
RD pocket
• 1,000,000 steps will take from one
day to one week to complete,
depending on the speed of the
computer. It can be broken into
multiple runs of fewer steps using the
Continue simulation feature.
Simulating Your Protein
• Double-check that nothing has
happened to your ensemble values.
• Edit → Ensemble
Simulating Your Protein
• Click “Run NAMD”
and wait…
Measuring Distances
After your simulation completes, you can load the .psf (same …wb.psf you have been using.
csn_r130a_wb.psf in this tutorial) and the new .dcd file (csn_r130a_wb_MD.dcd).
• The psf file stores charge and other information for all of the atoms but nothing related
to position. Therefore, nothing will appear in the VMD modeling window when a psf file
is loaded. The dcd file is essentially a stack of pdb files that are snapshots of the atom
positions through the simulation. As it loads in VMD, you will see it step through all of
the snapshots.
Select two atoms of interest (e.g., atoms within residues on different sides of the ATPbinding pocket).
Measuring Distances
• You can step through your simulation, and the distance
between your selected atoms show you how the distance
changes as the simulation ran.
Measuring Distances
• The root mean square distance can be calculated. This
value tells you how far apart two things are. Will compare
the distance between your mutation and
• We will use a script called distance.tcl to calculate the
distance at each saved timestep. In the TkConsole enter the
following two commands
• source distance.tcl
• distance “resid 243” “resid 130” 50
distance.csv histogram.csv
• Open the file histogram.csv in Excel
Measuring Distances
• You should have two columns of
data corresponding to the distance
between the center of mass of the
two selections (residue 243 and
130) and the number of
occurrences where the simulation
has that distance
• Plot these as x = distance (Å) and y
= occurences
Distance Occurrences
Measuring Distances
• Plotting data from a wild type and a mutated
(Yck2:S243D and 1CSN:S179D) simulation gives the
following graph.
Number of Occurences
Wild Type
Distance (Å)

similar documents