Slides - Módulo III

Report
TRT 14ª 2011
FCC
BR.OFFICE CALC E MICROSOFT
OFFICE EXCEL 2003
Disciplina: Informática
Facilitador: Alisson Cleiton
[email protected]
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel 2003
O que é o Microsoft Excel 2003
O Microsoft Excel é um programa
gerenciador de planilhas eletrônicas de
cálculos. Uma planilha é uma tabela que
o usuário pode criar fórmulas (por
exemplo, uma soma), inserir gráficos e
preparar projetos dos mais variados
tipos.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Área de Trabalho
 Pasta de Trabalho - um arquivo que reúne várias
planilhas, gráficos, tabelas , etc.. Uma pasta de
trabalho pode ter no máximo 255 planilhas.
Linha – dentro da janela da planilha as linhas são
identificadas por números no canto esquerdo da tela
que vai de 1 a 65536.
 Coluna – as colunas são identificadas com letras
de A a Z e combinações de letras até totalizarem 256
colunas.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Área de Trabalho
Célula – é a unidade de uma planilha na qual se
insere e armazena os dados. A interseção de cada
linha e coluna em uma planilha forma uma célula.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Área de Trabalho
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Selecionando-se as linhas 3 e 4 de uma planilha MS Excel existente e
clicando-se na opção Linhas do menu Inserir, ocorrerá a inserção de
(A) uma linha em branco, na posição de linha 3, sobrepondo a linha 3
existente.
(B) uma linha em branco, na posição de linha 5, sobrepondo a linha 5
existente.
(C) uma linha em branco, na posição de linha 5, deslocando as linhas
existentes em uma linha para baixo.
(D) duas linhas em branco, nas posições de linha 3 e 4, sobrepondo as
linhas 3 e 4 existentes.
(E) duas linhas em branco, nas posições de linha 3 e 4, deslocando as
linhas existentes em duas linhas para baixo.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Selecionar Células
 Um Intervalo – Com o mouse clicar na célula inicial
superior à esquerda e arrastar até a célula inferior à
direita, marcando assim uma região mais escura
selecionada.
 Um intervalo não adjacente - Para selecionar
células não adjacentes, selecionar a primeira região e
com a tecla CTRL pressionada, selecione a região
seguinte.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel - Barras
Barra de Ferramenta Padrão
As diferenças estão a partir do botão de Inserir
hiperlink. No Excel temos o botão Autosoma,
os botões de classificação de dados em ordem
crescente e decrescente e o Assistente de
gráfico
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel - Barras
Barra de Ferramenta Formatação
A diferença na barra do Excel é a presença
dos botões de formatação de valores e do
botão “Mesclar e centralizar”:
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel - Importante
Além das barras comuns já conhecidas por
nós (Padrão, Formatação...), o Excel
apresenta ainda: CAIXA DE NOMES e
BARRA DE FÓRMULAS
A Caixa de Nome exibe a localização da célula
ativa, o nome da célula ou objetos
selecionados e o tamanho de uma seleção.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
No que concerne ao Microsoft Excel, considere:
I. Quando criamos uma ou mais planilhas no Excel, estas são salvas em
um arquivo com extensão .xls. Ao abrirmos uma nova pasta de trabalho,
esta é criada, por padrão, com três planilhas.
II. Os nomes das planilhas aparecem nas guias localizadas na parte inferior
da janela da pasta de trabalho e poderão ser renomeadas desde que
não estejam vazias.
III. Dentro de uma pasta de trabalho as planilhas podem ser renomeadas
ou excluídas, mas não podem ser movidas para não comprometer as
referências circulares de cálculos. Se necessário, novas planilhas
podem ser incluídas na seqüência de guias.
IV. As fórmulas calculam valores em uma ordem específica conhecida
como sintaxe. A sintaxe da fórmula descreve o processo do cálculo.
Uma fórmula no Microsoft Excel sempre será precedida por um dos
operadores matemáticos, tais como, +, -, * e /.
É correto o que consta APENAS em
(A) II.
(B) I.
(C) IV.
(D) I, II e III.
(E) II, III e IV.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Cálculos
Para fazer cálculos, basta escrever uma
equação aritmética com o operador desejado.
Verifique a lista dos operadores aritméticos e
suas funções:
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Fazendo Referências
Na própria
planilha
=B1 + B2
Em outra planilha, mas
dentro da mesma pasta
Planilha!Célula
=Plan2!C5
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Fazendo Referências
Em uma outra pasta (arquivo)
‘[Arquivo]Planilha!’Célula
=‘[Paulo.xls]Plan1’!D9
Para um arquivo que está em
outro diretório
=‘Caminho\[Arquivo]Planilha’!Célula
=‘C:\Arquivos\Paulo\[Aula.xls]Plan1’!A3
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Referências
Além dos cálculos já mostrados, o Excel pode fazer
referência a valores já incluídos na planilha
• Referência Relativa
• Referência Mista
• Referência Absoluta
Observação: operações de recortar e colar
uma célula que contenha uma referência,
não produzem resultados de adequação
como nas operações de copiar e colar.
Ao recortar e colar uma célula com
referência, o conteúdo colado será
sempre idêntico ao que foi recortado.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Se a fórmula =$E1+D$2, contida na célula A3 de uma
planilha eletrônica do programa MS Excel, versão em
português, for copiada para a célula D7, a fórmula
resultante na célula D7 é
(A) = $E1 + G$2
(B) = $E7 + D$9
(C) = $E5 + G$2
(D) = $E5 + D$2
(E) =$E1 + D$2
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Alça de Preenchimento
Para facilitar o trabalho de preencher a planilha com
dados diversos, podemos usar um recurso do Excel
chamado alça de preenchimento.
Em alguns casos específicos, a alça traz resultados
muito mais “inteligentes” como o preenchimento
automático de uma seqüência de valores prédefinidos.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Alça de Preenchimento
As seqüências (listas de valores) mais conhecidas no Excel
são os nomes dos meses e os nomes dos dias da semana
(ambos podem ser abreviados e por extenso, o Excel entende
todos).
Exemplo: Quando se arrasta pela alça para baixo
ou para a direita, os valores das seqüências são
incrementados a cada célula (ou seja, Jan vira Fev,
que vira Mar, que vira Abr e assim por diante).
Porém, quando a alça é arrastada para cima ou
para a esquerda, os valores são decrementados
(diminuídos) a cada célula, o que significa que Jan
vira Dez, que depois vira Nov, e assim
sucessivamente.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Considere a planilha:
Ao arrastar a célula B2 para B3 pela alça de
preenchimento, B3 apresentará o resultado
(A) 6.
(B) 10.
(C) 12.
(D) 14.
(E) 16.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Em uma planilha Excel foram colocados os seguintes dados
nas células A1 até A4, respectivamente e nessa ordem:
josé+1
catavento
catavento+3
José
Selecionando-se essas quatro células e arrastando-as pela
alça de preenchimento (na borda da célula A4) até a célula
A8, o resultado em A5 e A7 será, respectivamente,
(A) José+1 e catavento.
(B) josé+2 e catavento+4.
(C) josé e catavento+3.
(D) josé+3 e catavento+4.
(E) josé+1 e catavento+3.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Funções
; ARGUMENTO2)
=NOME(ARGUMENTO1:ARGUMENTO2)
=NOME(ARGUMENTO1
Ex.: =Soma(A1:B2)
Ex.: =Média(C1;C9)
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Funções
SOMA
=SOMA(B2;B3;B4;B5) ou =SOMA(B2:B5)
Retorna a soma das células e intervalos apresentados nos
argumentos.
MÉDIA
=MÉDIA(C1;C4) ou =MÉDIA(C1:C4)
Retorna a média aritmética das células.
MÁXIMO
=MÁXIMO(B2;C2;D2;E2) ou =MÁXIMO(B2:E2)
Retorna o maior valor numérico que encontrar nas células.
MÍNIMO
=MÍNIMO(F1;F2;F3) ou =MÍNIMO(F1:F3)
Retorna o menor valor numérico que encontrar nas células.
MULT
=MULT(B1;B3;B6;B9) ou =MULT(B1:B9)
Retorna o produto (multiplicação) das células.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Dada a fórmula =(A1+B1+C1+D1)/4 contida na célula
E1 de uma planilha Excel, para manter o mesmo
resultado final a fórmula poderá ser substituída pela
função
(A) =MÉDIA(A1:D1)
(B) =MÉDIA(A1;D1)
(C) =MÉDIA(A1+B1+C1+D1)
(D) =SOMA(A1;D1)/4
(E) =SOMA(A1+B1+C1+D1)
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Funções
CONT.VALORES
Esta função retorna quantas células, em um intervalo, não
estão vazias.
Exemplo: =CONT.VALORES(C2:C9)
CONT.NÚM
Esta função conta quantas células, em um intervalo, são
formadas por Números.
Exemplo: =CONT.NÚM(B2:B15)
CONT.SE
Esta função conta quantas vezes aparece um determinado
valor (número ou texto) em um intervalo de células.
Exemplo: =CONT.SE(B2:B15;”Teste”)
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Em relação à planilha eletrônica Excel, considere os
valores e células abaixo.
célula A1=40
célula C5=30
célula E6=4030
A função/fórmula utilizada na célula E6 que resultou
no valor 4030 foi
(A) =soma(“A1”+”C5”).
(B) =unir(A1+C5).
(C) =concatenar(A1;C5).
(D) =unir(“A1”+”C5”).
(E) =soma(A1:C5).
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Funções Condicionais
SOMASE
Esta função realiza uma soma condicional em que o
usuário deverá informar segundo que critério, em
outro intervalo paralelo, deve ser encontrado para que
se proceda com a soma dos valores em um
determinado intervalo.
Exemplo: =SOMASE(A3:A10;”Pedro”;B3:B10)
Nesse exemplo, o Excel irá procurar, nas células
A3 a A10, a palavra “Pedro”. Nas células
encontradas, somará os valores contidos na
respectiva célula B.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
O resultado da célula que
contém a fórmula
=SOMASE(A1:A5;"< 0";B1:B5)
é:
(A) -5.
(B) 35.
(C) - 40.
(D) -25.
(E) 25.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Funções Condicionais
Funções
SE
A Função SE permite que o usuário especifique uma condição
para que o Excel escolha entre dois valores de resposta
possíveis.
=SE(Condição;Valor Verdadeiro;Valor Falso)
A condição do Excel sempre deve ser uma pergunta SIM/NÃO
(ou booleana, como costumamos chamar), portanto, ela exige
um operador de comparação entre dois valores.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
No Excel ou Calc, uma planilha apresenta os
seguintes dados: A1 = 2, B1 = 3, C1 = 4. A célula D1
tem a seguinte fórmula:
=SE (B1*A1 – 5 > 0;C1 – B1*A1; (C1 – A1)^A1 + B1*C1 + A1)
O valor da célula D1 é:
(A) negativo.
(B) positivo, par e menor que 10.
(C) positivo, par e maior que 10.
(D) positivo, ímpar e menor que 10.
(E) positivo, ímpar e maior que 10.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Excel – Criando um gráfico
Existem no Excel 14 tipos de gráficos diferentes. Você
poderá experimentar cada um deles, bastando para isso,
ativar o gráfico, e clicar no botão “tipos de Gráfico”
Para criação de gráficos são 4 etapas:
Etapa 1: Escolher o tipo de
gráfico.
Etapa
2:
Escolher
intervalo dos dados.
Etapa 3: Outras opções,
como: legendas, título do
gráfico, linhas de grade, etc.
Etapa 4: Pronto! Terminou!
Agora, é só escolher onde
colocar o seu gráfico.
o
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Os títulos das colunas, na primeira linha de uma planilha
eletrônica Excel 2003, para serem congelados na tela
deve-se selecionar
(A) a primeira célula da primeira linha, apenas.
(B) a primeira célula da segunda linha, apenas.
(C) a primeira célula da primeira linha ou a primeira
linha.
(D) a primeira célula da segunda linha ou a segunda
linha.
(E) somente as células com conteúdos de título, apenas.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Em uma planilha MS-Excel, um
Agente digitou o conteúdo abaixo:
O valor da célula C1 e os valores
da célula C2 e C3, após arrastar a
célula C1 pela alça de
preenchimento para C2 e C3,
serão
(A) 7, 9 e 11
(B) 7, 8 e 9
(C) 7, 10 e 11
(D) 9, 10 e 11
(E) 9, 9 e 9
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Área de Trabalho
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
O aplicativo equivalente ao MS-Excel é o BrOffice.org
(A) Math.
(B) Writer.
(C) Calc.
(D) Base.
(E) Draw.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Barras
Barra de Título
Barra de Ferramenta Menu
Barra de Ferramenta Padrão / Função
Barra de Ferramenta Formação
Caixa de Nomes e Fórmula
Barra de Status
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
No Calc, a célula A1 contém a fórmula =30+B1 e a
célula B1 contém o valor 8. Todas as demais
células estão vazias. Ao arrastar a alça de
preenchimento da célula A1 para A2, o valor de A2
será igual a
(A) 38
(B) 30
(C) 22
(D) 18
(E) 0
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Fórmulas
Operadores de Fórmulas
Matemáticos
Comparativos:
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Fórmulas
Operadores de Fórmulas
Texto:
Referência:
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Funções
FUNÇÃO: ABS - Retorna o valor absoluto de um
número.
Sintaxe: =ABS(Número)
Número é o valor cujo valor absoluto deverá ser
calculado. O valor absoluto de um número é seu
valor sem o sinal de + ou -.
Exemplo: =ABS(-56) retorna 56. / =ABS(12)
retorna 12. / =ABS(0) retorna 0.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Dadas as células de uma planilha do
BrOffice.org Calc, com os conteúdos
correspondentes: A1=1, B1=2, C1=3, D1=4 e
E1=5, a função =SOMA(A1:D1!B1:E1)
apresentará como resultado o valor
(A) 6.
(B) 9.
(C) 10.
(D) 14.
(E) 15.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Funções
AGORA - Retorna a data e a hora do sistema do
computador.
Sintaxe: =AGORA()
ANO - Retorna o ano como um número de acordo
com as regras internas de cálculo. Sintaxe: =ANO(número)
Número mostra o valor interno de data para o qual
o ano deverá ser retornado.
Exemplos =ANO(1) retorna 1899 / =ANO(2) retorna
1900
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
No BrOffice.org calc (planilha), a recomendação de
em todos os documentos produzidos (textos,
planilhas e outras) constar, na primeira linha, a data e
hora atuais (obtidas do computador) da produção do
documento é possibilitada pelo uso da função
(A) Diasnomês ().
(B) Diaútil ().
(C) Dias360 ().
(D) Agora ().
(E) Diatrabalhototal ().
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Funções
ARREDONDAR.PARA.BAIXO - Arredonda um número para
baixo, conforme a casa decimal especificada.
Sintaxe: ARREDONDAR.PARA.BAIXO(Número; Contagem)
Retorna Número arredondado para baixo (em direção ao
zero) para determinada Contagem de casas decimais. Se
Contagem é omitida ou é zero, a função arredonda para
baixo até o inteiro inferior.
Exemplo: =ARREDONDAR.PARA.BAIXO(1,234; 2) retorna
1,23.
=ARREDONDAR.PARA.BAIXO(45,67; 0) retorna 45.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Funções
ARREDONDAR.PARA.CIMA - Arredonda um número para
cima, conforme a casa decimal especificada.
Sintaxe: ARREDONDAR.PARA.CIMA(Número; Contagem)
Retorna Número arredondado para cima (acima de zero)
para determinada Contagem de casas decimais. Se
Contagem é omitida ou é zero, a função arredonda para
cima até o inteiro superior.
Exemplo: =ARREDONDAR.PARA.CIMA(1,1111; 2) retorna
1,12.
=ARREDONDAR.PARA.CIMA(1,2345; 1) retorna 1,3.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Funções
CONCATENAR - Combina várias seqüências de caracteres
de texto em ape-nas uma seqüência de caracteres.
Sintaxe: =CONCATENAR(Texto 1;...;Texto 30)
Texto 1; texto 2; ... representam até 30 passagens de texto
as quais deverão ser combinadas em apenas uma
seqüência de caracteres.
Exemplo =CONCATENAR("Bom ";"Dia ";"Sra. ";"Maria")
retornará Bom Dia Sra. Maria.
Também podemos unir textos de duas células utilizando o
“&. Ex: A1= 7 B1= 4
C1= A1&B1=74
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
Em relação à planilha eletrônica Excel, considere os
valores e células abaixo.
célula A1=40
célula C5=30
célula E6=4030
A função/fórmula utilizada na célula E6 que resultou
no valor 4030 foi
(A) =soma(“A1”+”C5”).
(B) =unir(A1+C5).
(C) =concatenar(A1;C5).
(D) =unir(“A1”+”C5”).
(E) =soma(A1:C5).
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Alça de Preenchimento
CONTEÚDO: TEXTO - Então, se uma célula apresentasse o
conteúdo CAIXA e fosse arrastada, pela alça, para baixo,
resultaria em várias células abaixo com o conteúdo CAIXA.
CONTEÚDO: TEXTO TERMINADO EM UM NÚMERO Quando o conteúdo de uma célula é um texto seguido de
um número (como “CAIXA 1”), e utiliza a alça de
preenchimento serão criados CAIXA 2, CAIXA 3, e assim por
diante.
Obs: quando se arrasta para cima, ou para a esquerda (é o
que se considera “voltar”) o BrOffice.org Calc faria CAIXA 1
virar CAIXA 0, CAIXA -1, CAIXA -2 e continuaria nos
números negativos. Diferente do Excel 2003 que não utiliza
valores negativos com a alça de preenchimento.
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Alça de Preenchimento
CONTEÚDO: QUALQUER ITEM DE UMA LISTA
CONHECIDA - Preencher a seqüência. Isto é, se for
colocado o termo ABRIL numa célula e esta for arrastada
para baixo pela Alça de preenchimento, os dois programas
criarão: MAIO, JUNHO, JULHO e assim por diante...
CONTEÚDO: DATA e HORA - Quando se escreve 16:30, O
Calc apenas repetirá o 16:30 (ele entende o valor como
sendo um valor de hora, mas não o incrementa, apenas o
repete). Quando se escreve uma data do tipo Jan/07 O
Calc, por sua vez, nem chega a entender esse valor como
uma data, mas apenas como um texto (seguido de um
número) e, como foi visto, o comportamento dele para com
esse tipo de dado é incrementar o número (ou seja, ele
viraria Jan/08, Jan/09, Jan/10 e assim vai...)
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Alça de Preenchimento
CONTEÚDO: NÚMERO - Caso se queira que o Calc faça uma P.A.
(progressão aritmética) com a alça de preenchimento, é necessário
escrever, no mínimo, dois valores (um em cada célula), e selecionar as
duas células simultaneamente para, depois disso, usar a alça na direção
em que as células estão relacionadas..
A diferença é quando se escreve apenas um único número numa
célula:
No Excel, qualquer número colocado numa célula é repetido quando
arrastado para qualquer direção. Isto é, se é inserido o número 1 em
qualquer célula e este é arrastado pela alça de preenchimento para
baixo (ou qualquer outra direção), será criado 1, 1, 1, 1 etc. nas demais
células!
No Calc, ao escrever um número 1 numa célula e arrastá-lo para baixo
(sem selecionar nenhuma outra célula), o Calc fará uma P.A. de razão 1.
Ou seja, as demais células serão 2, 3, 4, 5, etc. (como se tivéssemos
escrito 1 e 2 e arrastado).
Módulo III – Br.Office Calc e Microsoft Office Excel 2003
Exercício:
No Excel ou Calc, em planilhas grandes e com muitas
fórmulas pode ser interessante desligar o cálculo
automático das fórmulas. Tendo desligado o cálculo
automático, podemos recalcular todas as fórmulas de
uma planilha manualmente teclando
(A) CTRL + F5.
(B) F6.
(C) CTRL + F7.
(D) ALT + F8.
(E) F9.
TRT 2011
FIM DO MÓDULO III
PRÓXIMO ENCONTRO:
Módulo IV – Apresentações

similar documents