lens data editor

Report
Obliczenia optyczne
2013/2014
Semestr zimowy
2 X – zajęcia 1h: potrzeba jeszcze 7 zajęć po 2h (14h)
Wg planu: 16h nieparzystych
12h parzystych
Warunki zaliczenia
 obecność na zajęciach
 2 (3?) projekty indywidualne
wykonać
oddać raport
obronić
 Osoby, których wiedza wykracza poza ramy
kursu, mogą uzyskać zaliczenie w trybie
indywidualnym
Konsultacje ze studentami:
środy 9-11, pok. 18/4 A1
czwartki 17-19, pok. 18/4 A1
Sprawy „prostsze”:
[email protected]
Zemax 13 IE (licencja sieciowa)
oprogramowanie do projektowania, modelowania i analizy układów optycznych.
Samouczek
„Getting Started Using Zemax 12”
- w postaci książeczki
- w wersji elektronicznej (PDF)
www.radiantzemax.com/kb-en/Knowledgebase.aspx
Menu File→Open…
Znaleźć następujący plik:
..\Samples\Sequential\Objectives\Double Gauss 28 degree field.zmx
Okno programu
Okno edycyjne
Okna analizy
Okno programu
Pasek tytułowy
Pasek menu
Pasek narzędzi
Pasek statusu
Okno edycyjne
LENS DATA EDITOR to najważniejsze okno w programie, ponieważ prawie wszystkie parametry
układu optycznego wprowadzane są z poziomu edytora.
To tutaj definiuje się rodzaj powierzchni (w Zemaxie 13 są aż 75 typów powierzchni!), jej dane
geometryczne, wybiera się rodzaj ośrodka, w którym rozchodzi się światło.
Zemax posiada jeszcze 5 innych okien edycyjnych, m.in. MERIT FUNCTION EDITOR, MULTICONFIGURATION EDITOR, TOLERANCE DATA EDITOR, EXTRA DATA EDITOR.
Okna analizy
Są to graficzne lub tekstowe okna zawierające wyniki obliczeń przeprowadzanych przez ZEMAX.
W tym przypadku:
• LAYOUT, czyli dwuwymiarowy wygląd układu optycznego;
• RMS vs. FIELD, czyli RMS frontu falowego w zależności od kąta polowego;
• MATRIX SPOT DIAGRAM, czyli wygląd diagramów śladowych dla różnych kątów polowych.
LENS DATA EDITOR
W domyślnym trybie sekwencyjnego biegu promieni (sequential ray-tracing) promień świetlny
biegnie ze źródła/powierzchni przedmiotowej (ang.: Object Surface, OBJ),
w kierunku powierzchni oznaczonej numerem „1”, na niej ulega odbiciu/załamaniu, później
biegnie w kierunku powierzchni „2”, „3” itd., aż do osiągnięcia powierzchni obrazowej (ang.:
Image Surface, IMA).
Należy zwrócić uwagę, że IMA znajduje się w miejscu zdefiniowanym przez użytkownika, wcale
niekoniecznie w miejscu, w którym obraz jest tworzony przez układ optyczny (w sensie optyki
geometrycznej).
LENS DATA EDITOR
Edytor parametrów soczewki podzielony jest na kolumny, z których każda odpowiada innemu
parametrowi danej powierzchni:
Surf:Type to rodzaj powierzchni. Zemax pozwala wybrać spośród 74 różnych typów powierzchni
w zależności od rodzaju danych za pomocą których je opisujemy i od roli tej powierzchni w
układzie optycznym. Najpopularniejszy i najczęściej używany rodzaj powierzchni to Standard:
LENS DATA EDITOR
Comment może zawierać krótki opis danej powierzchni.
Radius to promień krzywizny danej powierzchni.
Thickness to grubość, osiowa odległość od bieżącej powierzchni do następnej z kolei.
Glass to materiał (szkło), znajdujący się w przestrzeni pomiędzy bieżącą powierzchnią a
następną z kolei.
Semi-Diameter to połowa średnicy apertury soczewki. Domyślnie, dla każdej soczewki wartość
ta jest liczona automatycznie w ten sposób, by wszystkie promienie dotarły do IMA i by uniknąć
winietowania.
Conic to wartość stałej stożkowej dla tej powierzchni (k>-1 dla hiperboli, k=-1 dla paraboli,
-1>k>0 dla poziomej elipsy, k=0 dla sfery, k>0 dla pionowej elipsy)
LENS DATA EDITOR
Powierzchnie można:
wstawiać
- Edit→Insert Surface (Insert z klawiatury)
- Edit→Insert After (ctrl+Insert z klawiatury)
usuwać
- Edit→Delete Surface (Del z klawiatury)
kopiować
- Edit→Copy Surfaces (ctrl+c po zazn. całego wiersza)
wycinać
- Edit→Cut Surfaces (ctrl+x po zazn. całego wiersza)
wklejać
- Edit→Paste Surfaces (ctrl+v)
W przypadku kopiowania i wycinania, jeśli nie zaznaczymy całego wiersza odpowiadającego
danej powierzchni, będziemy kopiować/wycinać wartości pojedynczych komórek.
LENS DATA EDITOR
Kliknięcie prawym przyciskiem myszy (lub podwójne kliknięcie lewym) n-tej powierzchni w
obszarze kolumny opisanej jako Surf:Type powoduje pokazanie się okna dialogowego
Surface n Properties
z zakładkami Type, Draw, Aperture, Scattering, Tilt/Decenter, Physical Optics i Coating,
które umożliwia m.in. wybór rodzaju powierzchni, ustanowienie przysłony aperturowej na danej
powierzchni itp…
PASEK MENU
SYSTEM→GENERAL
Definiowanie parametrów dotyczących CAŁEGO układu optycznego.
PASEK MENU
SYSTEM→FIELDS
Definiowanie ilości wiązek świetlnych, ich kątów padania (kątów polowych),
parametry winietowania.
PASEK MENU
SYSTEM→WAVELENGTHS
Definiowanie długość fal używanych do analizy (zawsze w μm!!).
PASEK MENU
ANALYSIS→…
Najciekawsza z właściwości ZEMAXa:
całe mnóstwo narzędzi do analizy układu optycznego...
… których rezultaty można obejrzeć w…
Okna analizy
Są wywoływane z poziomu paska menu i paska narzędzi, a przedstawiają wyniki analizy i
symulacji numerycznych dla układu optycznego o parametrach zawartych w oknie edycyjnym.
Okna analizy nigdy nie zmieniają parametrów układu optycznego.
Ich wspólne właściwości to:
Update (lub podwójne kliknięcie) powoduje ponownie wykonanie i przeliczenie
wyników, szczególnie ważne, gdy zmienia się parametry układu optycznego;
Print, czyli wydruk;
Window umożliwia kopiowanie, exportowanie i zmianę opcji wyświetlania;
Text (nie zawsze dostępne) – dostęp do danych tekstowych, źródeł wykresów;
Zoom – powiększenie (przeciągnij i upuść lub klawisz Home/End).
Przycisk Settings wywołuje okno dialogowe z ustawieniami, które są różne w zależności od
rodzaju analizy.

similar documents