Presentación de PowerPoint - Universidad Manuela Beltrán

Report
RECONFIGURACIÓN DE UNA RED LAN
UNIVERSITARIA PARA EL MEJORAMIENTO DEL
ACCESO DE USUARIOS DESDE INTERNET EN
LA REALIZACIÓN DE PRÁCTICAS REMOTAS DE
CONTROLADORES LÓGICOS PROGRAMABLES
(PLC)
Presentado por: Ing. Álvaro Torres Amaya
Directora: Mg. María Aurora Gil Guerrero
Especialización en Servicios Telemáticos e Interconexión de Redes
Universidad Manuela Beltrán
2011
Planteamiento del problema
• El desarrollo de la asignatura Controladores
Lógicos Programables (PLC) en un programa
Tecnológico o profesional, requiere la
realización de prácticas configuración de
equipos, las cuales pueden realizarse de forma
local o de forma remota para los estudiantes
de lugares lejanos. Sin embargo la forma
remota se ve limitada por las condiciones de
trafico de la red interna de la institución.
Justificación
• La posibilidad de definir una estrategia de tipo
general sobre una red universitaria para
establecer parámetros de configuración para la
optimización del acceso remoto a estaciones de
laboratorio, mejoraría las condiciones de acceso
para estudiantes de algunas regiones apartadas o
con limitaciones de tiempo, produciendo como
consecuencia un mejoramiento de la calidad
académica de los programas que poseen con
componente práctico.
Objetivo General
• Elaborar una propuesta de reconfiguración de
una red de comunicaciones tipo LAN típica de
una institución universitaria en tecnología
CISCO, para mejorar las condiciones de acceso
de usuarios desde internet para el uso de un
laboratorio remoto.
Objetivos específicos
• Identificar una topología de red LAN - WAN típica de
una institución universitaria, caracterizando su
estructura física y lógica, así como los parámetros
típicos de configuración.
• Revisar y clasificar la documentación existente para la
definición de políticas de calidad de servicio en una red
LAN con equipos Cisco.
• Seleccionar los parámetros de reconfiguración más
adecuados y realizar la simulación de su aplicación y
del funcionamiento de la red utilizando un software de
simulación de redes Cisco.
Antecedentes de la investigación
• Denzer, López y González (2006), en su artículo
denominado Administración de Ancho de Banda
mediante un router cisco 3600, describen como usar la
tecnología existente para garantizar anchos de banda y
calidad de servicio en una red.
• En el artículo, se exponen los aspectos más relevantes
del desarrollo de una herramienta de software
implementado en software libre en un servidor, el cual
es conectado al router y desde allí permite modificar
los parámetros de configuración de calidad de servicio
de la red.
Bases teóricas
• Según Denzer et al (2006), Se produce
congestión en una interfaz cuando el tráfico
de salida por ésta excede cierto umbral del
buffer de a interfaz. Las características de
control de congestión permiten su
administración en el router, en específico en la
interfaz, determinando el orden en que los
paquetes son enviados a través de una
interfaz basándose en prioridades asignadas a
los paquetes
• El control de congestión involucra la creación de
colas, asignación de paquetes a dichas colas
basándose en la clasificación del paquete, y la
planificación de paquetes en la cola para su
transmisión. Para la creación de estas colas, se
utiliza Traffic Shaping” (Denzer et al, 2006, p. 2),
lo cual limita el tráfico y éste se va acumulando
en la interfaz cuando hay excesos transitorios. Por
esta acumulación el control de congestión
procesa los paquetes y aplica las reglas que se
han configurado
Tipos de colas
1.
2.
3.
4.
5.
Fifo (First In.First Out Queueing)
PQ (Priority Queueing)
CQ (Custom Queueing)
WFQ (Weighted Fair Queueing)
CBWFQ (Class based Weighted Fair
Queueing)
Administrando ancho de banda
Fuente: Denzer et al, 2006, p. 3
RSVP
• Kurose et al. (2002) hace referencia a RSVP como
el protocolo que permite a las aplicaciones
reservar ancho de banda para sus flujos de datos.
Es utilizado por un host, en representación del
flujo de datos de la aplicación, para pedir una
cantidad específica de ancho de banda de red.
También es utilizado por los routers para enviar
las peticiones de reserva de ancho de banda. Para
implementar RSVP, su software debe estar
presente en los receptores, emisores y routers.
Características de RSVP
1. Proporciona reserva de ancho de banda en
arboles multidifusión.
2. Es orientado al receptor; esto es, el receptor
del flujo de datos inicia y mantiene la reserva
de recursos utilizados por el flujo.
TeamViewer
• “TeamViewer permite establecer una conexión a
cualquier ordenador a través de internet y controlarlo
a distancia o simplemente presentar su propio
escritorio, sin tener que preocuparse por cortafuegos,
direcciones IP o NAT” (TeamView Brochure, 2010).
• Según (Valencia, 2010), la aplicación TeamViewer
utiliza el protocolo UDP, y concretamente la técnica
llamada UDP Hole Punching. El programa instalado en
el PC "destino", se comunica por UDP a distintos
servidores del programa donde se almacena
determinada información (IP publica, puerto por el que
sale, identificador/usuario), dejando abierta una
comunicación en el firewall/NAT (hole) (p. 4).
User Datagram Protocol (UDP)
• UDP toma los mensajes del proceso de aplicación, les
añade campos para los números de puerto de origen y
destino para el servicio de multiplexado y demultiplexado,
les suma otros dos pequeños campos, y pasa el segmento
resultante a la capa de red. La capa de red encapsula el
segmento en un datagrama IP, y entonces hace todo lo que
puede para entregar el segmento al host receptor.
• “Si el segmento llega al host receptor, UDP utiliza el número
de puerto destino para entregar los datos del segmento del
proceso de aplicación adecuado. Con UDP no existe un
acuerdo entre las entidades de la capa de transporte
emisora y las de la capa receptora previo al envió de un
segmento. Por este motivo se dice que UDP es sin
conexión” (Kurose, 2002, p.194)
Etapas del proyecto
Modelo de pruebas
Configuración del enrutador principal
Configuración del Switch central
Configuración del Switch de servicio
Prueba de conectividad hacia la WAN
Saturación de la red
Diseño de la estrategia
1. Definición de la clase
2. Definición de la política
3. Asociación de la política a la interface
Codificación de la estrategia
1. Se crea la lista de acceso con la IP del servidor PLC:
access-list 1 permit host 192.168.101.109
2. Se crea la clase PLC y se vincula el protocolo UDP y el grupo 1:
class-map match-all CLASE_PLC
match protocol udp
match access-group 1
3. Se crea la política POLI_PLC y se le asocia la clase CLASE_PLC, se
establece que los paquetes de esta clase son de tipo critico (5):
policy-map POLI_PLC
class CLASE_PLC
set precedence 5
4. Se asocia la política POLI_PLC a la interface FA 0/0, tanto de
entrada como de salida:
interface FastEthernet0/0
description CONEXION_LAN_FIREWALL
ip address 192.168.101.2 255.255.255.0
ip nat inside
service-policy input POLI_PLC
service-policy output POLI_PLC
duplex auto
speed auto
5. Se crea la clase CLASE_SAL y se vinculan a ella todas las
tramas de tipo crítico:
class-map match-all CLASE_SAL
match precedence 5
6. Se crea la política POLI_SAL, y se define el
tratamiento para los paquetes de la clase
CLASE_SAL, en este caso, se le asigna una garantía
de ancho de banda mínimo de 30 porciento,
también se define el tratamiento para los paquetes
de la clase default a la que se asigna prioridad cero,
que corresponde a trafico normal.
policy-map POLI_SAL
class CLASE_SAL
bandwidth percent 30
class class-default
set precedence 0
7. La asociación de la política POLI_SAL a la
interface WAN, se realiza sobre la interface FA 0/1.
interface FastEthernet0/1
description CONEXION_WAN_INTERNET
bandwidth 512
ip address 10.7.4.210 255.255.255.252
ip nat outside
service-policy output POLI_SAL
duplex auto
speed auto
Configuración de QoS en el enrutador
central
RESULTADOS
• Pruebas de trafico UDP
estado inicial de la política
Incremento de paquetes en la política
de CLASE_SAL
Estado inicial de la política para envió
de UDP desde PC8
Configuración de envió UDP desde el
PC8
Aumento de tráfico en la clase
DEFAULT originado en PC8
Configuración de la prueba HTTP
desde el PC10
Estado inicial de la política para la
prueba HTTP
Incremento de tráfico en la clase
DEFAULT debido al flujo de HTTP
Conclusiones
• La aplicación de nuevas herramientas de comunicación virtual a los
procesos de enseñanza en las instituciones universitarias, requiere
la implementación de políticas de calidad de servicio, que permitan
brindar privilegios a las aplicaciones directamente vinculadas con
procesos académicos, frente a aquellas aplicaciones que no
comprometen la calidad y la misión de la institución
• El proceso de definición de políticas de calidad de servicio en una
red con tecnología Cisco, puede ser desarrollado mediante un
proceso sistemático de creación de clases, definición de políticas y
aplicación de las mismas. Las características de la red y de las
aplicaciones que se quieren garantizar debe conducir a establecer
los parámetros de configuración en cada etapa
• La implementación de una política de calidad de
servicio, requiere de la realización de una etapa de
análisis y diseño, en la que se establezcan las
necesidades de funcionamiento de la red y se definan
los elementos físicos y lógicos a ser tenidos en cuenta
en el correspondiente diseño.
• Un aspecto determinante en el éxito de la creación y
aplicación de una política de calidad de servicio es
definir si la o las aplicaciones para las que se quiere
desarrollar el proceso, requieren de una reservación de
recursos o una garantía de ellos, esto debido a que la
reservación repetida puede llegar a limitar el normal
funcionamiento de la red y hacerla ineficiente
• El uso de herramientas de simulación de redes, permite anticipar
las dificultades que pueden llegar a encontrarse al momento de
implementar una política de calidad, con el fin de evitar
alteraciones en la normal operación de la red. No obstante las
condiciones reales de funcionamiento solo son observables al
momento de implementar físicamente el modelo, algunas de las
diferencias a encontrar estarán relacionadas con las versiones de
software de los dispositivos.
• La revisión de la documentación consultada tanto teórica como
técnica demuestra que los enrutadores son dispositivos que se usan
principalmente para interconectar redes y discriminar entre los
equipos que pueden o no tener acceso a una red. Sin embargo
existen importantes herramientas como las expuestas en este
trabajo, que le permiten a una organización optimizar el
funcionamiento de la red tanto a nivel WAN como a nivel LAN, pero
que desafortunadamente no son ampliamente conocidas ni
aplicadas
Recomendaciones
• Es recomendable que una institución que dese
implementar las políticas de calidad de servicio
para aplicaciones de laboratorio remoto,
establezca los recursos de hardware y software
requeridos por la aplicación, la identificación de
condiciones de operación, de servicio y del tipo
de protocolos requeridos conducirá a la
identificación de las necesidades de configuración
de las clases, bien sea por reconocimiento de
máquinas, de subredes conectadas a una
interface, de protocolos en la interface o una
combinación de todas ellas
• Aunque no es posible asegurar que el comportamiento
logrado en un simulador corresponda con el
funcionamiento real de un dispositivo, es importante
apoyarse en estas herramientas para lograr depurar
algunos errores antes de modificar parámetros de
configuración de redes cuyo buen funcionamiento es crítico
para cualquier organización
• Un aspecto que puede brindar mayores oportunidades de
éxito en la definición e implementación de políticas de
calidad de servicio en una red es una adecuada y
pormenorizada caracterización de la estructura física y
lógica de la red, la cooperación del personal de operación y
mantenimiento de la red con el de administración y
gestión, permitirá que el modelo de pruebas guarde una
alta correspondencia con el entorno real de
funcionamiento
Gracias !!!
Preguntas
¿?

similar documents