Estructuras de Control

Report
Estructuras de Control
Profesor Francisco Alejandro Medina A
Estructuras de control
Secuencia
Decisión
Repetición
Expresiones
que permiten
calcular valores
Si
Mientras Que
Si - SiNo
Hacer Mientras
Múltiples Casos
Para
Llamados a
funciones o
procedimientos
Estructuras de Secuencia
• La estructuras de secuencia son instrucciones que
se ejecutan una después de la otra, en el orden
en que están escritas, es decir, en secuencia. Este
proceso se conoce como ejecución secuencial.
Ejemplo:
a = 5;
leer (b);
s = a + b;
escribir (“La suma es “, s);
Estructuras de Secuencia
Ejemplo:
Elaborar un programa que capture la base y la altura de un triangulo y que calcule su
área
inicio
‘Entre la
Base’
b
‘Entre la
Altura’
h
a = (b*h)/2
‘El área del
triangulo es ’ , a
Fin
Pseudoalgoritmo:
Programa areaT;
Variables
real b, h, a;
Inicio
escribir(“entre la Base”);
leer(b);
escribir(“entre la Altura”);
leer(a);
a = ( b * h ) / 2;
escribir(“El área del triangulo es “, a);
fin
Estructuras de Secuencia
Ejemplo en C++
Elaborar un programa que capture la base y la altura de un triangulo y que calcule su
área
Operadores
• Operadores Aritméticos
• +, -, *, /, ^, %
• Operadores de Relacionales
• >, >=, <, <=, ==, <>
• Operadores Lógicos
• Y (And)(&&)
• O (Or)(||)
• No (Not)(~)
a
b
aYb
a
b
aOb
V
V
V
V
V
V
a
No (a)
V
F
F
V
F
V
V
F
F
V
F
F
V
V
F
V
F
F
F
F
F
F
Estructura Si ( If ):
Pasos:
1) Evalúa Expresión condicional, en caso de que sea
Verdadera va al paso #2; en caso de que la Expresión
Condicional sea Falsa va al paso #3.
2) Ejecuta las Sentencias de la Parte Verdadera y va al
paso #3.
3) Termina la estructura Condicional (Va al FinSi) y
continua secuencia del programa.
Sintaxis en Seudoalgoritmo:
Sintaxis en C++
Si (Expresión) Entonces
---------------------------------------------------FinSi
if (Expresión)
{
---------------------------------------------}
Estructura Si ( If ):
Ejemplo:
Elaborar un algoritmo que permita capturar un número y que calcule su valor
absoluto.
Inicio
Pseudoalgoritmo:
‘Entre el
Número ’
num
F
num<0
V
num <- num*(-1)
‘Su valor Absoluto es
’ , num
Fin
Programa ValorAbs;
Variables
entero num;
Inicio
escribir(“entre un numero”);
leer(num);
si (num<0) entonces
num=num*(-1);
finsi
escribir(“Su valor Absoluto es “, num);
fin
Estructura Si ( If ):
Ejemplo en C++
Elaborar un algoritmo que permita capturar un número y que calcule su valor
absoluto.
Estructura Si-SiNo ( If-else ):
Pasos:
1. Evalúa Expresión condicional, en caso de que sea
Verdadera va al paso #2; en caso de que la Expresión
Condicional sea Falsa va al paso #3.
2. Ejecuta las Sentencias de la Parte Verdadera y va al paso
#4
3. Ejecuta las Sentencias de la Parte Falsa y va al paso #4.
4. Termina la estructura Condicional (Va al FinSi) y
continua la secuencia del programa.
Sintaxis en Seudoalgoritmo:
Sintaxis en C++
Si (Expresión) Entonces
---------------------------------------------------SiNo
---------------------------------------------------FinSi
if (Expresión)
{
---------------------------------------------}
else
{
---------------------------------------------}
Estructura Si-SiNo ( If-else ):
Ejemplo:
Elaborar un algoritmo que permita capturar un número y que indique si el
número capturado es positivo o negativo.
inicio
Pseudoalgoritmo:
‘Entre un
Número’
num
F
num<>
=0
V
‘El número es
Positivo’
‘El número es
Negativo’
Fin
Programa signo;
Variables
entero num;
Inicio
escribir(“entre un numero”);
leer(num);
si ( num>=0 ) entonces
escribir(“El número es Positivo”);
sino
escribir (“El número es Negativo”);
finsi
fin
Estructura Si-SiNo ( If-else ):
Ejemplo en C++
Elaborar un algoritmo que permita capturar un número y que indique si el
número capturado es positivo o negativo.
Estructura Si-SiNo ( If-else ):
Ejemplo:
Elaborar un algoritmo que capture tres números y que indique cual de estos es el
mayor
1
inicio
‘Entre el
Numero 1’
a >= b
a
‘Entre el
Numero 2’
a >= c
b >= c
‘El Mayor
es ’, c
‘El Mayor
es ’, c
‘El Mayor
es ’, b
b
‘Entre el
Numero 3’
c
1
fin
‘El Mayor
es ’, a
Estructura Si-SiNo ( If-else ):
Ejemplo:
Elaborar un algoritmo que capture tres números y que indique cual de estos es el
mayor
Pseudoalgoritmo:
si ( a >= b ) entonces
si ( a >= c ) entonces
Programa mayor;
escribir (“El mayor es “ , a);
sino
Variables
escribir (“El mayor es “, c);
entero a, b, c;
finsi
Inicio
sino
escribir(“entre el número 1”);
si ( b >= c ) entonces
leer(a);
escribir (“El mayor es “ , b);
escribir(“entre el número 2”);
sino
leer(b);
escribir (“El mayor es “ , c);
escribir(“entre el número 3”);
finsi
leer(c);
finsi
fin
Estructura Si-SiNo ( If-else ):
Ejemplo en C++
Elaborar un algoritmo que capture tres números y que indique cual de estos es el
mayor
Estructura Mientras Que (While)
Pasos:
1. Evalúa Expresión condicional que existe dentro del
ciclo, en caso de que sea Verdadera va al paso #2;
en caso de que la Expresión Condicional sea Falsa
va al paso #3.
2. Ejecuta las Sentencias de la Parte Verdadera y
vuelve al paso #1.
3. Termina el Ciclo Mientras Que (Va al FinMientras) y
continua la secuencia del programa.
Sintaxis en Seudoalgoritmo:
Sintaxis en C++
Mientras (Expresión)
---------------------------------------FinMientras
While (Expresión)
{
---------------------------------------}
Estructura Mientras Que (While)
Ejemplo:
Elaborar un algoritmo que capture un número y que realice la tabla de multiplicar del
uno al diez de dicho número.
inicio
‘Entre un
Número’
n
i=1
MQ ( i <= 10 )
F
V
m=n*i
n,‘*‘,i,‘=‘,m
i=i+1
fin
Pseudoalgoritmo:
Programa tabla1;
Variables
entero n, i, m;
Inicio
escribir(“entre un numero”);
leer(n);
i=1;
Mientras ( i <= 10 )
m = n * i;
escribir ( n , “ * “ , i , “ = “ , m );
i = i + 1;
FinMientras
fin
Estructura Mientras Que (While)
Ejemplo en C++
Elaborar un algoritmo que capture un número y que realice la tabla de multiplicar del
uno al diez de dicho número.
Estructura Para (For)
Pasos:
1. Iniciativa de una variable declarada que permite
controlar el ciclo (Vlr_inicial)
2. Verifica que la variable que controla el ciclo sea
menor o igual al limite superior y si esto ocurre va
al paso #3, si el valor de la variable es mayor al del
limite superior va al paso #5
3. Ejecuta las Sentencias que hay dentro del ciclo
4. Incremente la variable que controla el ciclo y
retorna al paso #2
5. Termina el Ciclo Para (Va al FinPara) y continua la
secuencia del programa.
Sintaxis en Seudoalgoritmo:
Sintaxis en C++
Para(Vlr_inicial;Limite;Incremento)
------------------------------------------------FinPara
For(Vlr_inicial;Limite;Incremento)
{
------------------------------------------------}
Estructura Para (For)
Ejemplo:
Elaborar un algoritmo que capture un número y que realice la tabla de multiplicar del
uno al diez de dicho número.
inicio
‘Entre un
Número’
n
Para( i = 1 ; i <= 10 ; i++ )
F
V
m=n*i
n,‘*‘,i,‘=‘,m
fin
Pseudoalgoritmo:
Programa tabla2;
Variables
entero n, i, m;
Inicio
escribir(“entre un numero”);
leer(n);
Para( i = 1 ; i <= 10 ; i++ )
m = n * i;
escribir ( n , “ * “ , i , “ = “ , m );
FinPara
fin
Estructura Para (For)
Ejemplo en C++
Elaborar un algoritmo que capture un número y que realice la tabla de multiplicar del
uno al diez de dicho número.
Estructura Hacer-Mientras (Do-While)
Pasos:
1. Ejecuta las Sentencias que hay dentro del ciclo y va
al paso #2.
2. Evalúa Expresión condicional que existe dentro del
ciclo, en caso de que sea Verdadera retorna al paso
#1; en caso de que la Expresión Condicional sea
Falsa va al paso #3.
3. Termina el Ciclo Hacer-Mientras y continua la
secuencia del programa.
Sintaxis en Seudoalgoritmo:
Sintaxis en C++
Hacer
---------------------------------------Mientras(Expresión)
do
{
---------------------------------------}
while (Expresión);
Estructura Hacer-Mientras (Do-While)
Ejemplo:
Elaborar un algoritmo que capture un número y que realice la tabla de multiplicar del
uno al diez de dicho número.
inicio
‘Entre un
Número’
Pseudoalgoritmo:
n
i=1
m=n*i
n,‘*‘,i,‘=‘,m
i=i+1
MQ ( i <= 10 )
F
fin
V
Programa tabla3;
Variables
entero n, i, m;
Inicio
escribir(“entre un numero”);
leer(n);
i=1;
Hacer
m = n * i;
escribir ( n , “ * “ , i , “ = “ , m );
i = i + 1;
Mientras ( i <= 10 )
fin
Estructura Hacer-Mientras (Do-While)
Ejemplo en C++
Elaborar un algoritmo que capture un número y que realice la tabla de multiplicar del
uno al diez de dicho número.

similar documents