Using Ami Pro for OS/2

Report
Using Ami Pro for OS/2
Using Ami Pro 3 for OS/2
Facilities and Fire Regulations
• Note the location of the fire exits
• Note the fire assembly point
Course Assumptions
• It is assumed that:
– You are familiar with basic use of a PC, including the use of
the keyboard
– You should have a good working knowledge of OS/2
Yes, I’m on the right course!
Knowledge of DOS or the OS/2
command line is not essential,
but will be helpful
Course Objectives
• By the end of this course:
– You should have a good grasp of the day-to-day issues
involved in using Ami Pro for OS/2
– You will be able to format, proof and print documents
– You be able to use the Help available within Ami Pro
– You will be able to use advanced features including
merge, tables and columns
Structure of the Course
• The course is a structured mixture of theory
and practical hands-on sessions
• Anything that you are not sure about - ASK
• Anytime you want more information - ASK
• Anytime you get stuck in the exercises - ASK
REMEMBER. IT IS YOUR COURSE,
THE MORE YOU GET INVOLVED
THE MORE YOU WILL GET OUT OF IT
A First Look at Ami Pro
Using Ami Pro 3 for OS/2
Starting Ami Pro
• Start Ami Pro from the OS/2 Workplace Shell
in one of the following ways:
– Locate the OS/2 Workplace Shell and double
click on the Ami Pro program object icon
– Select Open from the Ami Pro program object
pop-up menu
– Double click on an Ami Pro datafile object and
then open the document required
– Drag and drop a datafile object onto the Ami Pro
program object icon
You can also start Ami Pro by typing AMIPRO and
pressing Enter at the OS/2 Command Prompt
The Ami Pro Screen
Could you correctly label
these arrows?
It is very important that you
are familiar with the
components that make up the
Ami Pro screen
Opening a File
• From the File drop down
menu select Open
• Or click on the ‘Open an
existing file’ SmartIcon
Entering Data
• Just start typing!
• Text is entered at the insertion point
• The insertion point is automatically
positioned at the top of the page in
new documents
• Ami Pro takes care of word
wrapping and page breaks
This is
Easy!
Saving Your Data as a File
• When you save data created
in Ami Pro, you copy it from
memory (ie RAM) to your
hard disk and give it a file name
• From the File drop down menu,
select the Save command
• Or click on the Save SmartIcon
MEMORY
SAVING
DISK
Saving Files With a Different File Name
• From the File drop down
menu, select Save As
• Allows you to keep the original
version of the file and store the
new version, in a different file
• Useful if the original file is a
‘read-only’ file
– i.e. a file you can read, but
not modify
IN MEMORY
FILE ONE
FILE ONE
ON DISK
FILE TWO
ON DISK
Closing a File
• Closing a file means removing the file from
memory
– If the file has been saved and no modifications
have been made since, the file will simply close
– If you try to save a file that has been modified
since the last time it was saved, or save a file
that has not previously been saved, then you
will be prompted to save your data as a
file on disk
Exiting Ami Pro
• Removes Ami Pro
from memory
• You will need to
restart Ami Pro
• You will be prompted
to save any unsaved
data!
So what is the
difference between
CLOSE and EXIT?
Creating a New Document
• By default, Ami Pro presents you
with a new, empty document which
allows you to start typing immediately
• To create another new document
– Select New from the File drop down menu
The Ami Pro Drop Down Menus
• Work in the same way as standard Windows
drop down menus
– Keyboard shortcuts use Alt+underlined letter
It’s not as hard as it looks!
SmartIcons
•
•
•
•
Used to aid productivity
Allow you to use shortcuts
Can be customized
Different sets of SmartIcons can be displayed
The Ruler
•
•
•
•
Display can be toggled on or off
Allows you to set tabs, margins and indents
Allows you to create hanging indents easily
Allows column margins to be changed
Status Bar
• Located across the bottom of the Ami Pro screen
Style Status Button
Face Button
Point Size Button
Document Path Button (Toggle)
Typing Mode Button
SmartIcons Button
Page Status and Page Arrows Button
View Preferences
• Select View from the Menu Bar
– Full Page, Custom, Standard,
Enlarged and Facing Pages
– Layout Mode, Outline Mode and Draft
Mode
Using Help
• Using Help can remind us of topics we have
forgotten or help us to learn a new function
• It can be invoked at any time by clicking on
Help on the menu bar
Wait!
I’ll Help
Canceling Actions
• This function is also known as Undo
– It can be set up in order to give you four levels of action
cancellation
OR
Select the desired level
of undo from the Undo
levels drop down list
Selection Techniques
• Select text when you want to apply changes to it
• You can select text using:
The Keyboard
The Mouse
OR
Tip: Using the keyboard to select text is often quicker than using the mouse!
Take care that you only select the text you want to change, particularly if you
are going to delete the selected text!
Selection Techniques Using the Mouse
• Use the following mouse shortcuts to select text:
Select a word
Select multiple words
Select a sentence
Select multiple sentences
Select a paragraph
Select multiple paragraphs
Select a block of text
Double click with the left mouse button
Double click then drag
Press Ctrl and click in the sentence
Press Ctrl double click on the first sentence
and drag
Press Ctrl and double click in the paragraph
Press Ctrl and double click in the paragraph
and drag
Place the mouse pointer at the beginning
of the text and click. Hold down Shift and click
at the end of the text block
Selection Techniques
Using the Keyboard
• Use the following keyboard shortcuts to select text:
Shift+right arrow
Shift+left arrow
Shift+up arrow
Shift+down arrow
Shift+End
Selects one character to the right of the insertion point
Selects one character to the left of the insertion point
Selects the line before and above the insertion point
Selects the line after and below the insertion point
Selects text from the insertion point to the end of the
line
Shift+Home
Shift+Ctrl+End
Shift+Crl+Home
Selects text from the insertion point ot the beginning of
the line
Selects text from the insertion point to the end of
the document
Selects text from the insertion point to the beginning of
the document
File Management
Using Ami Pro 3 for OS/2
Managing Files
• File Management can be used to:
–
–
–
–
–
Copy
Move
Rename
Delete
Change File Attributes
• Note: The Ami Pro File Manager only
operates at file level, directories cannot
be managed in this way
Listing Files
• From the File drop-down
menu select the File
Management command
Listing Files in Different Directories
• From the File drop-down menu, select the
Change Directory command
Selecting Files
• You can use mouse or keyboard techniques
to select files
Copying Files
• From the File drop-down menu, select the
Copy command
Moving Files
• From the File drop-down menu select the
Move command
Renaming Files
• From the File drop-down menu, select the Rename
command
Deleting Files
• From the File drop down menu, select the
Delete command
Note: Be very careful when deleting files
Be absolutely certain that neither you nor
anyone else needs them!
File Format Conversion
• Files come in different formats
• It is possible to use another
application, save your work in that
application and then use it in Ami
Pro using File Format Conversion
Formatting Text
Using Ami Pro 3 for OS/2
What is Text Formatting?
• Enables you to choose a look for your
text
– You can display your text in bold, italic or
underlined
– Change the color of text
– Change the font or typeface
Basic Text Formatting
• Basic text formatting
techniques include:
–
–
–
–
Bold
Italics
Underlining
Capitalization
• Use
– Keyboard shortcuts
– Toolbar icons
– Drop-down menus
Using the Font Dialog Box
• Allows you to
specify font type,
size and color
Applying Text Special Effects
• From the Text drop-down menu, select the
Special Effects command
• Special effects include:
–
–
–
–
–
Superscript
Subscript
Double underline
Strike through
Overstrike character
Using Fast Format
• Allows text formatting information to be
picked up from sample, selected text and
applied to other text
Text formatted like
this can be picked
up and the
formatting
transferred to other
text
FAST FORMAT
Text formatted like this can be
picked up and the formatting
transferred to other text
Formatting Paragraphs
Using Ami Pro 3 for OS/2
What is Paragraph Formatting?
• Determines how a paragraph will look
when printed or displayed on the screen
• Application of formatting attributes such
as alignment, indentation and line
spacing
Left or Right Alignment, Centering
and Justifying Text
• To align text you may use the drop-down menu
• Or keyboard shortcuts
• Or icons on the toolbar
Keyboard
shortcuts
To Center text - Ctrl+E
To align to left - Ctrl+L
To align to right - Ctrl+R
To justify - Ctrl+J
Left and Right Indenting
• Lines may be indented from the left or right
margins:
• Options include:
–
–
–
–
All
First
Rest
From right
Line Spacing
• Line spacing values may
be easily varied
• From the Text dropdown menu select the
Spacing command
• The default is a single
line space
Allows line spacing units to be set
Types of Tab Within Ami Pro
• You can specify five
types of tab options:
–
–
–
–
–
Left
Right
Numeric
Center
Leader tabs
Controlling Tabs Using the Ruler
• From the View drop down menu, select the
Show Ruler command
The Ruler contains many
controls to aid tab
manipulation
Controlling Tabs Using the Modify
Page Layout Dialog Box
• Select the required tab options
Formatting Pages
Using Ami Pro 3 for OS/2
What is Page Formatting?
• Page formatting includes formatting
information that affects the entire page
such as Headers and Footers
• Options on the Page drop-down menu
include:
–
–
–
–
–
–
–
Header/Footer
Insert Page Layout
Modify Page Layout
Ruler
Page Numbering
Line Numbering
Breaks
Margins
• The margin is the blank
area surrounding the
text on all four sides
– Each of the four margins
may be set to different
values
Columns
• By default an Ami Pro
document consists of a
single column, but you
easily format a document
to contain up to eight
columns of text
– When the first column is ‘full’
the text simply flows to the top
of the next column, in the same
sort of style used by most
newspapers
Page Dimensions and Orientation
• From the Page drop-down
menu select Modify Page
Layout
• Select the Pg. Settings tab
and set options as
required
Left and Right Pages
• From the Page drop-down menu select Modify Page
Layout to display the Modify Page Layout dialog box
Page Breaks
• From the Page dropdown menu select the
Breaks command and
from the sub-menu,
select Insert page break
Headers and Footers
• From the Page drop down menu, select
Header/Footer
The insertion point is automatically displayed in the header (or footer)
area. Enter the text required for the header or footer
Page Numbering
• From the Page drop down
menu, select the Page
Numbering command
Using the Ami Pro
Proofing Tools
Using Ami Pro 3 for OS/2
Using the Spell Checker
• Always use the Ami Pro Spell Checker prior to printing
documents
– Ami Pro hold a list of words that it understands, which it uses to check
against words in your document
– Words can be added to Ami Pro’s list of words
• If you do add words, be VERY careful that you spell the words correctly
– The context of a word will not be checked
• For instance, if you use FROM where you meant to use the word FORM, then the
spell checker will not see a problem
Using the Thesaurus
• You may use the
Thesaurus to
make Ami Pro
suggest
alternative words
of a similar
meaning
Using the Grammar Checker
• You may use the Ami
Pro Grammar
Checker to check
the grammar used
within your
document
Printing
Using Ami Pro 3 for OS/2
Ami Pro and Printer Drivers
• The printer driver provides the link between
the Application/OS/2 and the printer
Ami Pro
OS/2
Printer Driver
Printer
Each particular type of
printer requires it’s own
printer driver to be installed
Printing From Ami Pro
• Click on the Printer
icon
OR
• From the File drop
down menu, click on
the Print command to
open the Print dialog
box
Setting Up the Printer
• Normally the printer
will be set up and
customized by your
support department
– It is useful however to be
able to view, and on
occasions, to change
these options
‘Print Preview’ in Ami Pro
• Many word processors have a special Print
Preview command, normally located under the
File drop down menu
– These is no such command in Ami Pro, instead you can
view the page in Full Screen view
From the View drop-down menu select
Full Page
OR
Press Ctrl+D
Lists
Using Ami Pro 3 for OS/2
What are Lists?
• Lists normally consist of items arranged
one after the other, separated by a
carriage return at the end of each line
• Two different ways of emphasizing your
points i.e. by using bullets or numbers
• If you wish to show a list that has to be
referred back to in no particular order,
numbered lists are useful
• If you wish to show a process, such as a
list of instructions, which must be
performed in a particular order, then
bullets are more suitable
Bullets
• Click on the Style
button and select the
required bullet style
Numbering
• Click on the Style
button and select the
Number List style
Tables
Using Ami Pro 3 for OS/2
What are Tables?
• Older DOS-based word processors mainly used tab
spaces to align columns
– Many disadvantages, often items did not fit the tab space
• Tables are made up of individual cells in which you
can word wrap text, allowing all the text to be visually
aligned in columns
Creating a Table
• It is very easy to create tables within Ami Pro
• You can either use the drop down menus (by
selecting Tables from the Tools menu)
• Or simply click on the Tables icon from the
toolbar
Navigating and Selecting Within a Table
• It is important that you know how to move
from cell to cell within a table, as well as how
to select cells, rows, or columns
• Make sure that you know how:
–
–
–
–
–
–
–
To select a cell within a table
To move from one cell to the next
To move from one cell to the previous cell
To select a column within a table
To select a contiguous block of cells within a table
To select a row within a table
To select the entire table
Inserting Rows and Columns
• From the Table drop down menu, select the
Insert Row/Column command
Deleting Rows, Columns
and Entire Tables
• It is easy to delete rows and columns within a
table
– When doing this make very sure that the correct row or
column is selected prior to deleting it!
– You cannot ‘Undo’ a column or row deletion if the row(s)
or column(s) contains data!
Modifying the Table Layout
• You can modify the
appearance of a table, either
during the creation process
– By clicking on the Layout button
within the Create Table dialog box
• Or after the table has been
created
– By selecting the table and
modifying its appearance at any
time using the Modify Table Layout
command, located under the Table
drop down menu
Modifying the Lines and Colors Used
Within a Table
• From the Table
drop-down
menu, select
the Lines and
Colors
command
Modifying Paragraph Styles in Tables
• You can easily modify
the styles used within
the text inserted in a
cell
• Click once using the
right-hand mouse, to
display the Modify
Style pop-up window
Protecting Cells Within Tables
• If you protect selected cells within a table,
this means that these cells cannot be edited
or deleted, until this protection is removed
Adding up Numbers in a
Row or Column
• You can easily add together numbers
contained within a row or column
• It does not matter if some of the cells within
the column or row are empty
• From the Table drop-down menu, select
Quick Add and from the sub-menu displayed
select Row or Column
The Tables Toolbar
• Click on the Display
Toolbar tool located at the
bottom of the Ami Pro
screen, and select Tables
from the list displayed
Styles
Using Ami Pro 3 for OS/2
Style Sheet Concepts
• A file used as a template to format a
document so that text and pictures can be
inserted
• Determines the initial appearance of a
document
• Ami Pro provides style sheets for reports,
documents, tables, labels and envelopes
• Style sheets contain paragraph styles which
contain text formatting information for the
style
• You can modify style sheets and paragraph
styles to suit your requirements
Using Style Sheets
• Use style sheets to:
– Apply formatting such as indention, tabs, or
bullets using a single function key or mouse
click
– Assign individual paragraph styles to
different paragraphs within a document
– Ami Pro’s default style sheet is
_DEFAULT.STY
– The default is applied to each new
document
unless you specify another style sheet
• To assign a new style sheet:
– Select New from the File menu
– Select a Style sheet for the new document
– Select the OK button to close the dialog box
and display the new document
The Style list displays
the paragraph styles
available with the style
you have chosen, along
with a list of function
keys to access them
Assigning Paragraph Styles
Using the Style Status Button
• To assign a paragraph style:
– Place the insertion point in the paragraph
where you want to apply the style
– Click on the Style Status button to display
the Style list
– Select the style required
Hint: To apply styles
you use regularly, use
the function keys next to
the style name in the
Styles list. Simply
select the paragraph and
press the function key!
Note: The whole paragraph will be affected when you use the Styles list
to assign a paragraph style. To apply a style to part of a paragraph, use the
Text menu or SmartIcons to apply formatting
Creating and Modifying Paragraph
Styles
• To create a paragraph style based
on existing text:
– Select the text
– Select Style Create to display the Create
Style dialog box
– Enter a name for the style
– Choose the Selected Text option and
select Create
Note: The new paragraph style will be assigned to the next available
function key in the Style list. If a function key is not available it will be
assigned a bullet point and placed at the end of the list
Creating New Style Sheets
• Ami Pro saves new styles (or modified styles) with the
document in which they are created
• New or modified styles can be made available to other
documents
• To create a new style sheet:
– Choose Save as a Style Sheet from
the Style menu
– Complete the boxes and select
options as required
– Click OK to close the dialog box
Style sheet names can be
up to eight characters long
and should be followed by
.STY to identify them as an
Ami Pro style sheet
Warning: When you create or modify a style sheet it
is attached to the current document and will not affect
other documents. If you save a new style to a new or
current style sheet or to a new style sheet all
documents containing the style will be affected
Using Fast Format to Apply Formatting
• To change formatting without creating a new
style, use the Fast Format feature
– Position the insertion point in the paragraph with the
paragraph style you want to use
– Choose Fast Format from the Text menu
– Select the options required
– Select part of the paragraph where you want
to apply the paragraph style and release the
mouse button
– Switch off Fast Format by selecting the
command from the Text menu or pressing
CTRL+T again
Select Text Fast Format or press CTRL+T to reveal the Fast Format dialog
box
Creating a New Paragraph Style Based
on an Existing Style
• To create a paragraph style based on an existing style:
– From the Style menu select Create to
display the Create Style dialog box
– Enter a name for the style
– Click on the Style radio button
and choose the style you wish to
modify
– Choose Modify to display the
Modify Style dialog box
– Select the attributes required
– Select OK
Select from the tabs to modify other
areas of the paragraph style
Creating Automated Style Sheets
• Automated style sheets use a macro to
automatically insert information into appropriate
locations within a document
– Select File New and select a style sheet
– Modify the text in the Personal
Information dialog box if required
– Select OK to insert the information in an
untitled document
– Enter information specific to the
document you are creating in the
Optional Information dialog box
– Select OK to insert the personal and
options information into an untitled
document
Note: These dialog boxes will change
in appearance depending on the style
sheet you are using
Using Automated Style Sheets
• From the File menu, select New and choose
the style sheet you want from the New dialog
box
• Make sure that With contents and Run macro
are selected and choose OK
• The macro that is associated with the style
sheet will be displayed and any default
information you have supplied will be
displayed in the Personal Information dialog
box
Overriding Paragraph Styles
• Use Ami Pro’s special formatting features to
override paragraph styles
Non-breaking space
- Keeps two or more words on the same line
Press CTRL+Spacebar
Line breaks
- Starts a new line without starting a new
paragraph
Press CTRL+ENTER
Hyphenation
- Overrides hyphenation by switching it on
or off
OR
Forces Ami Pro to hyphenate words at
specific places
Select Edit Mark Text
No Hyphenation
OR
Press CTRL+-
Modifying an Existing Paragraph Style
• Use the Modify Style dialog box to modify an
existing paragraph style
– Select Style Modify Style to display the Modify Style dialog box
– Select from the following options:
Font
Change typeface, size, color and format
Alignment
Modify paragraph alignment
Spacing
Modify spacing attributes of the paragraph style
Breaks
Determine page breaks for the paragraph style
Bullets/Numbers
Add bullets and numbering
Lines
Determine the style, length, and color of lines
Table
Change the format of tables in the paragraph style
Shortcut: Click on the Modify Paragraph Style
SmartIcon to open the Modify Style dialog box
Finding and Replacing Text
Using Ami Pro 3 for OS/2
Finding Text
• From the Edit drop down menu, select the
Find & Replace command
Replacing Text
• From the Edit drop down menu, select the
Find & Replace command
• In the Replace with text box, enter the text
you want to use as a replacement
• Options include:
–
–
–
–
Exact case
Exact attributes
Replace and Find Next
Replace Remaining
Finding and Replacing Text Attributes
• Attributes that can be used in Find and
Replace include:
–
–
–
–
–
–
Normal
Underline
Word underline
Bold
Italic
Small caps
Fields
Using Ami Pro 3 for OS/2
Background Field Concepts
• Fields inserted into a
document are like
hidden codes
• What you see in the
document is the effect
of the code
• Insert a field
representing the
system date so that
each time you open a
document containing
the date field the date is
automatically updated
Hint: You can use fields to
automatically generate a table of
contents or index
What are Power Fields?
• Tools which allow you to automate tasks
• Ami Pro comes with several pre-defined power fields
to carry out everyday tasks
• Access Power Fields via the Insert Power Field dialog
box
• Some pre-defined instructions are macro commands,
whilst others offer a choice of format settings
• Create your own custom power fields
Note: Power Fields themselves are not displayed - only the
results of the Power Field instructions are displayed
Editing and Displaying Power Fields
• To display a Power Field:
– Select Show Power Fields from the View menu
– The Power Field instructions are displayed
in the document
– Use copy, move, drag and drop or delete
to edit the Power Field whilst it is displayed
in the document
• To edit a Power Field:
Note: Instructions for
each Power Field are
displayed between left and
right angle brackets (< >)
Remember: To display the new
results of the Power Field, save
the document or update the
power field!
– Select Edit Power Fields Insert to display
the Insert Power Fields dialog box
– Click on the Previous Field or Next Field
buttons to display the Power Field you want to edit
– Make any changes to the power field in the Insert
text box and select OK
Click on the Insert Power Fields icon to
open the Insert Power Fields dialog box!
Using Pre-defined Power Fields
• To insert a pre-defined Power Field:
– Select Edit Power Fields Insert to display
the Insert Power Fields dialog box
– Select a Power Field from the Fields
list box
– Specify a format for the Power Field in
the Options list box
– Select OK or press Enter to insert
the Power Field
Hint: To display Power Fields in a document select Show
Power Fields from the View menu
Inserting a New Power Field
• To insert a new Power Field:
– Select Edit Power Fields Insert to display the Power Fields dialog box
• To add an additional syntax
to the power field:
– Place the insertion point in the Insert text box
after the power field instruction and enter
the syntax
– Any further power field instructions must
be typed into the Insert text box
• To save the new Power Field:
– Select the Save button to display the
Save Power Field dialog box
– Enter a name for the New Power Field and
choose OK
Any text added to the
power field must be typed
within quotation marks
(“”)
Updating and Locking Fields
• To update Power Fields:
– Select Power Fields from the Edit menu and
select Update All to update all the fields, or
Update to update a single field
Beware: If a document
contains a large number of
power fields, updating them
can take a long time!
OR
– Click on the Update selected power fields
or the Update All power fields icon
• To lock Power Fields:
– Select Edit Power Fields Insert to display the Insert Power Fields
dialog box
– Click on the Lock check box
– Click on the Cancel button. Ami Pro does not allow you to select
the OK button when you choose to Lock a power field
Hint: Select Auto run in the Insert Power Fields dialog box to update all
fields each time a document is opened. This includes any Locked fields!
Time and Date Insertion
• Inserting a date or time field into a document
can be a useful way of keeping a document
up-to-date
• To insert a Date or Time field:
– Select Edit Insert Date/Time to display the
Insert Date/Time dialog box
– Select the date or time format you require
from the Insert options list
Select a date and time format from the
Style options list
– Select OK or press Enter
The Clipboard and
Dynamic Data Exchange
Using Ami Pro 3 for OS/2
The Clipboard
• To Copy
• To Cut
The Clipboard is a temporary storage area of disk or memory which is
used by OS/2 when you Cut, Copy and Paste data
You can use the Clipboard to easily move data from one location in a
document to another or transfer data, from one application program to
another.
You can paste data from the Clipboard as many times as you want,
until you decide to Cut or Copy new data to it
Use of the Paste Command
• Once stored on the Clipboard, information
can be repeatedly pasted into an application
until you use the Cut or Copy commands
again
• To use the Paste command:
– Highlight the text
– Choose Cut or Copy from the Edit menu
– Place the insertion point where you want to paste the
contents of the Clipboard
– Select Edit Paste
Dragging and Dropping
Text or Graphics
• When you select text and/or graphics within Ami
Pro, the selected item(s) can be dragged to
another part of the document and then dropped
to move it to a new location
NOTE: Depress the Ctrl key to copy as opposed to move
when using drag and drop
What is Dynamic Data Exchange
(DDE)?
• You can share information across
applications using DDE (Dynamic Data
Exchange)
• The files used to create a link are known as
the server and the client
– The server is the file which stores the original
information
– The client is the file that stores a copy of the information
Automatic vs. Manual Updating
of DDE Links
• To update the information contained within a
DDE link
– Click on the Link Options command, under the Edit drop
menu to open the Link Options dialog box
– Select the link you wish to update, and click on the
Update button
– The data will now be updated from the Client source file
Remember that both server and client applications
must both be open for DDE to work properly
Frames and Graphics
Using Ami Pro 3 for OS/2
Importing Pictures
• To import a picture into a frame:
– Select File Import Picture to display the
Import Picture dialog box
– Select the file type required from the Type
of file drop down list
– Click on the picture file you wish to import
from the Files list box and select OK
To hide pictures in a document click this:
To show pictures in a document click this:
Note: Select Copy Image
to save the picture as part
of the document. If Copy
image is not selected,
remember to copy or move
the document to another
directory using the File
Management command in
the File menu
Sizing and Cropping Graphics
• Change the size of graphics:
– By dragging the frame around the
picture to enlarge or reduce it
– By selecting options from the
Graphics Scaling dialog box
– By sizing the picture so that
changes to the frame will not
affect it
– By moving a picture in a frame
• You can crop a picture by
removing part of it from view
so that only a section of it
appears in the document
Note: When you crop graphics, the whole picture remains in the
document even though only a section of the picture is visible. This
does not necessarily mean it takes up less disk space!
What are Frames?
• Frames act as containers into which text,
pictures, graphics, tables or other documents
can be inserted
• Use frames to place text in a margin, insert
pictures in a document, or create titles which
cover multiple columns on a page
• Frames can be sized and positioned in a
document without affecting the main
document text
• Format frames by adding lines, background
colors and shadows
Inserting a Frame into a Document
• To create a frame manually:
– Select Frames Create Frame to display
the Create Frame dialog box
– Select the Create Manually button
– Click and drag the frame mouse
pointer to create a frame in the
document
OR
• To create a custom frame:
– Select Frames Create Frame to display
the Create Frame dialog box
– Enter measurements for the Width and
Height of the frame
– Enter measurements in the Position
section
– Click OK to create the custom frame
Shortcut: Click on the
Frame SmartIcon
Modifying Frames
Change frame type
• To modify a frame:
Change size and position
– Select Frame Modify Frame
Layout to display the
Modify Frame Layout
dialog box
– Select the options required
Shortcut: Place
the mouse pointer
anywhere on a
frame and press
the right-hand
mouse button to
open the Modify
Frame Layout
dialog box
Modify Lines
Specify column and tab
settings
Hint: To modify the frame layout of a frame with a macro assigned to it, press
Shift or Ctrl whilst clicking inside the frame to select it
Controlling How Text Wraps Around
Frames
• To select how text
wraps:
Text appears above and below the frame
but not on the left, right, or behind the frame
– Select Frame Modify
Frame Layout to display
the Modify Frame Layout
dialog box
– Select from the options
in the Text Wrap Around
section
Text appears above, below, and to one side of
the frame but not behind it. Text flows to the
right or left of the frame depending on space
Text flows behind the frame. If the frame is opaque
text behind the frame cannot be seen, if the frame is
transparent
text behind the frame is visible and appears to be inside the
frame
Modifying Frame Placement
• To modify frame placement:
– Select Frame Modify Frame Layout to display the Modify Frame Layout
dialog box
– Choose from the options in the Placement section
Remains where you place it
in the document
The frame appears as if it
were text and is anchored
to the character closest to
the top, left-hand corner
of the frame.
Anchors the frame to the text above it in
the document
The frame appears on
alternate pages in the
document
Appears in the same
location on each page of the document and become part of the page
layout
Changing the Appearance of a Frame
• To change the appearance of a frame:
– Select Modify Frame Layout from the Frame drop down menu to
display the Modify Frame Layout dialog box
– Select from the options in the Display section
Text or pictures behind the frame
will be visible in
the document
Any lines specified in
the Lines section will
be displayed with square corners
Text or pictures behind the frame will be
hidden behind the frame
in the document
Any lines specified
in
the Lines section
will
be displayed with
rounded corners.
Click on the up or
down arrows next to this option to determine
the amount of rounding applied to the corners
Changing the Size and Position of a
Frame
• To change the size and position of a frame:
– Select Modify Frame Layout to display the Modify Frame Layout dialog box
– Select the Size & Pos. tab
Enter a measurement in the Width and Height text boxes
to determine the size of
the frame
In the Margins section,
enter measurements in
the Left, Right, Top, and
Enter a
Bottom text boxes.
measurement
If you want to set the
in the Down from
frame margins to zero,
top
select the Clear Margins
and In from left text
option
boxes to determine
the location of the
frame on the page
Changing the Lines, Shadows, and
Color of Frames
• To change lines, shadows and colors of frames:
– Select Frame Modify Frame Layout from the to display the Modify Frame
Layout dialog box
– Select the Line tab Select a line from the Style section to
determine how the lines will look
Places a box around
the frame
Select a shadow style
for the frame
Places a line on the left
border of the frame only
Places a line on the right
border of the frame only
Places a line on the top
border of the frame only
Places a line on the bottom
border of the frame only
Click on the down
arrow to select options
Select colors
for the lines,
shadows and
background
color of the
frame
Inserting Columns and Tabs into
Frames
• To enter columns and tabs:
– Select Frame Modify Frame Layout to display the Modify Frame Layout
dialog box
– Click on the Col & Tabs tab
Select the type
of
tab required
Enter the
location
of the tab
Text will be aligned
horizontally in a
partially
filled frame
Select the Clear Tabs button to remove
all
tabs from a frame
Click on the Set Tab
button to display
the tab marker on
the ruler
Select the number of
columns you want in
the frame
Determine the amount of
space between columns.
Inserts a line between the columns.
Choose a style and color for the lines
Using Reverse Text in a Frame
• To use reverse text in
a frame:
– Select Frame Modify
Frame Layout and select
the Lines tab
– Make sure that no options
are selected in the Around
Frame section
– Select black from the
Background color palette
and choose OK
– Double click inside the
frame and choose Text
Font
Choose white from the
color palette and select
OK
– Enter the text required
Cancel all options
Select a background
color
Select a
text color
Enter the text required
Inserting Other Objects into Frames
• To insert text into a frame:
– Click on the frame to display handles and borders
around the edges
– Double click inside the frame and begin typing
• To insert another document into a frame:
– Select the frame and choose File Open to display
the Open dialog box
– Select the file you wish to insert from the Files list
box and choose the Insert button
• To insert a table into a frame:
– Select the frame and choose Tools Tables to
display the Create Table dialog box
– Select the options required and choose OK
Selecting and Moving Multiple Frames
• To select and move multiple frames:
– Select the first frame you wish to move so
that handles and borders are displayed
– Press the SHIFT key and select the
next frame
– Keeping the SHIFT key depressed, select
any other frames you want to move until
they are all displayed with handles and
borders
– To move the frames, click on one of the
selected frames with the right
mouse button and drag the frames to
the new location
– Release the mouse button
Press SHIFT and click on
multiple frames to select them
TIP: If you have several frames layered one on top of the other it may be
difficult
to select individual frames. Try pressing the CTRL key whilst clicking with
the
Bring to Front and Send to Back
• Change the order of layered frames by moving them to
the front or the back of the layer
Make sure the frame on the
top layer is transparent so
that text in the lower
frames is visible
Select Bring to Front
from the Frame menu or
click on the Bring frame
to front SmartIcon
Select Send to Back from
the Frame menu or click
on the Send frame to
back SmartIcon
TIP: Make the frames on the top layer transparent, rather than
opaque, otherwise text or pictures in the lower frames will be
hidden!
Merge, Labels, and Envelopes
Using Ami Pro 3 for OS/2
What is Mail Merge?
• Merge can be used to combine data such
as names and addresses with information
contained in an Ami Pro document, such as
a letter or report
• For example, Merge can be used to send a
standard letter to many people with the
added facility of personalizing each letter
with the individuals name and address
• To perform a Merge you require a merge
data file and a merge document file
Creating a Data File
• To create a data file:
– Select File Merge and choose
Option 1
– Select New and enter a name
for the file in the Name merge
data file dialog box
– In the Create Data File dialog
box enter field names
– Select Options to specify field
and record delimiters
Note: Field names should be specified so
that the data is easy to refer to. They do
not need to be entered in the order in
which they will appear in the merge
document
Creating a Merge File
• To create a merge file:
– Open the file you want to use
as the merge document file
– Select the merge data file
– Assign the data file to the
merge document file
– Insert the merge fields into the
merge document file
– Either print the new merged
document, or save the merged
document as a new file
New
Combined
File
Data File
Merge File
Merging Data and Document Files
• To merge data and document
files:
Merges the documents and prints a
copy of each resulting document
– Choose Option 3 in the
Welcome to Merge dialog box
– Select Options from the Merge
dialog box
– Select Print Options from the
Print Opts dialog box
– Select OK to print, display, or
save the documents
Merges and previews each
resulting document before printing
Merges the documents and saves the
results to a specified Ami Pro document
Using Merge With Labels
• To merge to labels:
– Select the labels style sheet required
– Select label type. You can select
standard Avery labels if required
– Assign a data file to the label document
– Insert merge fields into the labels
– Select the NextRec Power Field from
the Insert Power Fields dialog box
– Copy the fields including the Power
Field to all labels on the sheet
Select the NextRec power field
to indicate you wish to print the
next record on a new label
BEWARE: If using a laser printer make sure the labels are laser
certified, otherwise you may damage your printer
Using Merge With Envelopes
• To merge envelopes:
– Select File New and choose Envelope with return address area from the style
sheet list
– Enter details in the Personal Information
dialog box
– Assign the merge data file required
– Enter the merge fields required into the
envelope style sheet
– Select options from the Merge dialog
box and choose OK
Entering Information into a Data File
• To enter data:
– Place the cursor in the first text box
of the Data File dialog box
– Enter data for the first field and
press Tab
– Click on the Add button to create a
new, blank record
Moves back one record
Moves forward one record
Moves to the first record
in the data file
Moves to the last record
in the data file
Note: Each time you add a record, a new blank index card is
displayed. Information is displayed in the tab dividers at the top of
each index card to identify records
Conditional Mail Merging
• What is conditional mail merging?
– Allows you to include or exclude records in a merge data file
by applying certain conditions to them
– Specify conditions in the Merge Conditions dialog box
– Apply multiple conditions using the
Click on the Operator field to display
And or Or options
the following operators in the
&Operator list.
=
(equal to)
<
(less than)
>
(greater than)
!
(not equal to)
<=
(less than or equal to)
>=
(greater than or equal to)
Using External Data Files in a Merge
• Use data stored in any of the following
formats
to perform a merge in Ami Pro:
– 1-2-3 for DOS - releases 2.x and 3.x
(.WKS and .WK1)
– 1-2-3 for Windows and OS/2
(.WK3, .WK4, and .WG2)
– dBase III, III+, and IV
– Fixed length ASCII and comma
delimited formats
– DIF
– Excel for Windows and OS/2 - releases
2.x and 3.x (.XLS)
Select the application containing the
data from the Type of file list box in the
Select Merge Data File dialog box
Productivity and
Miscellaneous Tools
Using Ami Pro 3 for OS/2
Document Information
• From the File
drop down
menu, click on
Document Info
Notes
• By using the Notes feature
you can add a hidden note to a
document
– If you are reviewing a document this
can be very useful, for instance, you
may insert a note suggesting
changes or additions to the text
To toggle the display of these yellow markers on or off, first
click on the View drop down menu, and then click on the
View Preferences command
Customization and Security Tools
Using Ami Pro 3 for OS/2
What are Ami Pro
Customization Tools?
• Customizing Ami Pro to suit your
requirements helps you to be more efficient
• You can change Ami Pro’s screen to your
liking and you can also create your own
SmartIcon set or even your own icon
Customizing SmartIcons
• When you first start Ami Pro, the default set
of SmartIcons is displayed at the top of the
window
• You can customize SmartIcons in the
following ways:
– Choose whether or not SmartIcons are displayed
– Choose which set of SmartIcons is displayed
– Choose where the SmartIcons are displayed on the
screen
– Choose the size of the SmartIcons
– Select the order of the SmartIcons
– Modify SmartIcon sets
Modifying the SmartIcon Sets
• You may Add, Move, Group and Remove
SmartIcon sets
• From the Tools menu choose SmartIcons and
customize as you wish
View Preferences
• You can customize the appearance of the Ami
Pro window by using the View Preferences
option
• The options you select are automatically
loaded every time you start Ami Pro, but may
be changed at any time
• From the File drop-down menu, click on View
Preferences
User Setup
• Click on the Tools drop-down menu and
select the User Setup command
Some of the other options include:
• Options include:
–
–
–
–
–
–
–
Auto backup
Auto timed save
Disable one-line help
Disable drag & drop
Display initials in text
Program load
Program exit
• Hyphenation hot-zone
• Default unit of measurement
• Widow/orphan control
• Hyphenate last word in paragraph
• Hyphenate last word in column/page
• Automatically fill list box in File/Open
• Print in background
• Graphic display speed options
What is Password Protect?
• Allows you to protect your data from access
by unauthorized personnel
• You can also ensure the security of your
documents and templates by using the Cell
Protection and Text Protection features
Password Protection
• Password protection stops people from viewing or
changing your files without your permission
– It is advisable to use a password which does not relate to your
name or anything that anyone could easily guess
– Click on the Password protect check box
Protecting Cells
• Ami Pro also allows you to protect certain
elements in a table, rather than protecting the
entire table or document
• This means that you can select a cell in a
table and isolate it from the rest of the
document so that it cannot be edited
• From the Table menu, select Protect Cells
Macros
Using Ami Pro 3 for OS/2
What are Macros?
• A series of commands which are carried out
automatically
• Useful for automating frequently used tasks
• The first step is to Record the series of
commands
– Then whenever you Playback the macro, the series of
commands is repeated, carrying out the specific task for
you
• Different methods of accessing a macro
– Create an icon which plays the macro, or you can assign
a keyboard shortcut to it
– Run a macro when you open or close a document
Recording Macros
• From the Tools drop-down menu,
select Macros
• Click on Record to open the
Record Macro dialog box
Running Macros Manually
• From the Tools drop-down menu, select
Macros then click on Playback
Running Macros Automatically
• From the Tools drop-down menu, select
Macros
• Click on Edit to display the Edit Macro dialog
box
• Click on Assign to open the Assign Macro to
run Automatically dialog box
• Then select File open or File close as the
triggers to run the macro
Recording Quick Macros
• You can use Quick Macros to automate a task
you use only occasionally, or only in one
document
• Ami Pro records the Quick Macro in the file
UNTITLED.SMM
• Each time you record a new Quick Macro, the
contents of this file are overwritten with the
new macro
• To record a Quick Macro, select Macros from
the Tools menu and then click on Quick
Record
Assigning a Shortcut Key
to a Quick Macro
• Assigning a shortcut key to a macro allows
you to run the macro at any time simply by
pressing the shortcut keys

similar documents