Day 8: Excel Chapter 6

Report
“I HAVE GAINED THIS FROM
PHILOSOPHY: THAT I DO
WITHOUT BEING COMMANDED
WHAT OTHERS DO ONLY FROM
FEAR OF THE LAW.”
-ARISTOTLE
DAY 10:
EXCEL CHAPTER 6
Cody Cutright
CS 101
September 17th, 2014
UPCOMING DATES
• Homework #2
– Friday September 19th, by 11:55pm
• Homework #3
– Friday September 26th, by 11:55pm
• Exam #1
– Monday September 29th, Section 8
– Wednesday October 1st, Section 10
Outlines
An outline is a hierarchical structure of data.
Outlines – cont’d
Outlines are useful in Excel for grouping large
amounts of data into subgroups.
Excel contains a mechanism that will attempt to
auto-outline a spreadsheet.
*Excel will not create an outline or group data if
the dataset does not contain a formula or an
aggregate function (i.e. SUM or SUBTOTAL)
Grouping
• Grouping allows for more control in
creating an outline and is the process of
joining related rows or columns of data
into a single entity
Data -> Outline Group
Subtotaling Data
• Creating subgroups by row can be time
consuming because you have to enter
formula rows by group.
• Using the Subtotal dialog box can create
an automatic outline by rows AND insert
subtotals at the same time.
*Can be used with a range of data, but not a table
Before Subtotaling…
There are a few things to take care of:
1. Sort the data by a major category.
2. Organize data in a range of cells, not a table.
3. Click within the data range, then on the Data
tab.
4. Click Subtotal in the Outline group.
Example
• If we used Subtotal on
this data, it wouldn’t be
very helpful.
• How should we reorder
this?
Sort Dialog Box
This should
make our data
more
meaningful.
Sorted Data
• This is a little more
helpful, now we can
use subtotal.
Subtotal Dialog Box
We need to insert a
subtotal based on
each change in
Semester, and we
need to Sum the
enrollment.
Result
• We can see
that we have
successfully
subtotaled the
enrollment
based on each
class by
semester.
Auto Outline
• After subtotaling you can just use autooutline.
• Data tab -> Outline Group -> Group Button
• Auto-outline
PivotTables
Rearrange Fields
Creating
Filtering
Refreshing Data
Adding fields
Sorting
Grouping
Changing Values Field
Sorting
Why PivotTables?
PivotTables are an organized structure
that summarize large amount of data.
These can aid in data mining, which is
the process of analyzing large volumes of
data for trends.
Creating a PivotTable
1. Click inside the dataset (the range of cells or table).
2. Click the Insert tab, and then click Insert PivotTable in the Tables group to open the
Create PivotTable dialog box.
3. Specify the dataset by entering the range, if necessary, in the Table/Range box. If you
selected a cell in a range or table, the range of cells or table name reference shows in the
Table/Range box (see Figure 6.12).
4. Decide where you want to place the PivotTable. Click New Worksheet to create the
PivotTable on a new worksheet, or click Existing Worksheet and enter the starting cell
location for a particular worksheet to create the PivotTable on an existing worksheet. It is
beneficial to create a PivotTable on a new worksheet to separate the PivotTable from the
dataset. Doing so can prevent problems of accidentally inserting or deleting rows or
columns in the table that also affect the PivotTable.
5. Click OK.
Fields
Area
Description
Values
Displays summary statistics, such as
totals or averages.
Row Labels
Organizes and groups data into
categories on the left side of the
PivotTable. Each group name
occupies a single row.
Column Labels
Subdivides data into one or more
additional categories to add depth
to the PivotTable.
Report Filter
Filters the aggregated data to display
results based on particular
conditions you set.
Adding Fields
Click and drag to
the appropriate
fields.
Works for
rearranging as
well.
Value Field Settings
Further
customization can
be attained
through the Value
Field Settings.
Value Field Settings
• Specify Custom
Names, Formats,
the function to use.
Refresh!!
***If data is updated from the worksheet, you
need to refresh the PivotTable or PivotChart
to accurately reflect any changes in the
data!!!
Slicing
A slicer is a window listing all items in a field
and enables efficient filtering.
To insert a slicer:
Options Tab -> Insert Slicer -> Select the
boxes for slicers to be displayed
Hold control and click on the fields to display/or
hide their information.
Slicing – cont’d

similar documents