SIS Software Install - Multibeam Advisory Committee

Report
SIS Software Install Instructions
Cookbook
Multibeam Advisory Committee
March 21, 2012
SIS 3.8.3
Multibeam Advisory Committee – March 21, 2012
1
Contents
• How to install SIS software
• Configure the datagram distribution software
NOTE: These are directions for installing the SIS software. If you are doing this to
replace a corrupt database, please see the “SIS Configuration Backup” and “SIS
Software Uninstall” cookbook.
Multibeam Advisory Committee – March 21, 2012
2
SIS Software Install
Click Here
Insert the SIS software DVD. If a window does not automatically open, browse to the DVD using a file
explorer and double click on the start.html file. Click on the SIS SW Installation Link.
Multibeam Advisory Committee – March 21, 2012
3
SIS Software Install
Click Here
Once this SIS Software Installation opens up, click on the “Press here to install Seafloor Information
System”.
Multibeam Advisory Committee – March 21, 2012
4
SIS Software Install
If a security warning pops up click run to continue the installation.
Multibeam Advisory Committee – March 21, 2012
5
SIS Software Install
Choose your install language.
Multibeam Advisory Committee – March 21, 2012
6
SIS Software Install
Click on the “Next” button to continue installation.
Multibeam Advisory Committee – March 21, 2012
7
SIS Software Install
Verify that this is the version and build of SIS you want to install.
Multibeam Advisory Committee – March 21, 2012
8
SIS Software Install
Make sure that SIS is selected as an installable component.
Multibeam Advisory Committee – March 21, 2012
9
SIS Software Install
Choose where you want to store you raw data and where you want to store your grid data files.
Multibeam Advisory Committee – March 21, 2012
10
SIS Software Install
Define the IP number or hostname of the Database server. If the database is going to be on the same
machine you are running SIS (the normal operation mode) enter localhost.
Multibeam Advisory Committee – March 21, 2012
11
SIS Software Install
Choose the install location for the SIS software. The default value of C:\Program Files\Kongsberg
Maritime\SIS\ is the normal install location.
Multibeam Advisory Committee – March 21, 2012
12
SIS Software Install
If you want Shortcuts to be put under the Start menu in a SIS folder simply click “Install”. Otherwise
define a different folder name or click “Do not create shortcuts”.
Multibeam Advisory Committee – March 21, 2012
13
SIS Software Install
During the install process a dialog box will appear asking about installing a MATLAB compiler runtime,
click “OK”.
Multibeam Advisory Committee – March 21, 2012
14
SIS Software Install
After the install is done Reboot the machine to finish the process.
Multibeam Advisory Committee – March 21, 2012
15
SIS Software Install
Restart SIS and reconnect with the TRU through the pulldown menu. If the TRU does not appear,
Rescan, and select it.
Multibeam Advisory Committee – March 21, 2012
16
SIS Software Install
It is now time to import your PU settings (offsets, device settings, etc). Under the “File” menu select
“Import PU parameters….”
Multibeam Advisory Committee – March 21, 2012
17
SIS Software Install
A dialog box will appear. Browse to the location you saved you PU parameters (normally in the
E:/sisdata/common/pu_param directory. Select your saved file and click “OK”.
Multibeam Advisory Committee – March 21, 2012
18
SIS Software Install
Don’t worry if you see plenty of blinking red fields after doing this. Go to the “File” menu and select
quit….everything will be ok.
Multibeam Advisory Committee – March 21, 2012
19
SIS Software Install
Start up SIS again and connect to the TRU through the pulldown menu.
Multibeam Advisory Committee – March 21, 2012
20
SIS Software Install
It is now time to import all of you user settings such as screen layouts, datagram subscribtions, external
sensors, etc. Go the the “File” menu and select “User settings”.
Multibeam Advisory Committee – March 21, 2012
21
SIS Software Install
You should only load user settings from a machine with the same number of hard drives. This is not
normally a problem as the usual is to load settings from the same machine. Click “Ok”.
Multibeam Advisory Committee – March 21, 2012
22
SIS Software Install
The “Import User Settings” dialog box will appear. Click on the file selection box for User Parameters
(circled in the figure above).
Multibeam Advisory Committee – March 21, 2012
23
SIS Software Install
Select the User Settings parameters file. This file will end in a .params suffix.
Multibeam Advisory Committee – March 21, 2012
24
SIS Software Install
Click on the file selection box for “Datagram subscriptions”.
Multibeam Advisory Committee – March 21, 2012
25
SIS Software Install
Select the Datagram subscriptions file. This file will end in a .dgmsubs suffix.
Multibeam Advisory Committee – March 21, 2012
26
SIS Software Install
Click on the file selection box for “Survey templates”.
Multibeam Advisory Committee – March 21, 2012
27
SIS Software Install
Select the Survey template file. This file will end in a .srvtpl suffix.
Multibeam Advisory Committee – March 21, 2012
28
SIS Software Install
Click on the file selection box for “Projections”.
Multibeam Advisory Committee – March 21, 2012
29
SIS Software Install
Select the Projections file. This file will end in a .proj suffix. Make sure you DO NOT select the file that
ends with a .srvtpl.proj suffix.
Multibeam Advisory Committee – March 21, 2012
30
SIS Software Install
Click on the file selection box for “Frame settings”.
Multibeam Advisory Committee – March 21, 2012
31
SIS Software Install
Select the Frames file. This file will end in a .frames suffix.
Multibeam Advisory Committee – March 21, 2012
32
SIS Software Install
Click on the file selection box for “External sensor settings”.
Multibeam Advisory Committee – March 21, 2012
33
SIS Software Install
Select the External Sensors file. This file will end in a .extsens suffix.
Multibeam Advisory Committee – March 21, 2012
34
SIS Software Install
Click the “Accept” button now that you have filled out all of the fields.
Multibeam Advisory Committee – March 21, 2012
35
SIS Software Install
Click the “Accept” button. If you are importing these settings from another sounder make sure that you
change the Sounder’s serial to match the sounder you are importing for.
Multibeam Advisory Committee – March 21, 2012
36
SIS Software Install
Click the “Ok” button, you are done importing settings.
Multibeam Advisory Committee – March 21, 2012
37
SIS Software Install
Quit SIS in order to finalize the loading of the User settings.
Multibeam Advisory Committee – March 21, 2012
38
SIS Software Install
Start up SIS again and connect to the TRU through the pulldown menu.
Multibeam Advisory Committee – March 21, 2012
39
SIS Software Install
The one parameter that the above method does not correctly set (apparently) is the grid engines cell
size. To fix this select “View” -> “Tear Off” -> “New Survey”.
Multibeam Advisory Committee – March 21, 2012
40
SIS Software Install
Change the “Number of cells in processing grid:” to 128x128 and change the “Cell size (m) to 150 for the
EM122 and 5 for the EM710. It might be necessary to change to EM710’s grid cell size to 10m depending upon
the size of the survey area.
41
Multibeam Advisory Committee – March 21, 2012
Datagram Distribution Configuration
R/V Kilo Moana’s EM122 Data
Distribution settings.
R/V Kilo Moana’s EM710 Data
Distribution settings.
SIS as part of the install process wiped out the datagram distribution parameters. Open the software and add a
source port of 4310 for Centerbeam Depth and a the desired IP and destination port (for the Kilo Moana’s
EM120 you should enter 192.168.1.40:5634 and for the EM710 you should enter 192.168.50:5635).
42
Multibeam Advisory Committee – March 21, 2012

similar documents