Wordfast Pro Workshop CTA

Presenter: Jamie Lucero
[email protected]
Discuss translation process and TM
Discuss Wordfast applications
Learn and practice beginning–intermediate
WFP functions
Discuss questions and requested features
(time permitting)
What is TM?
 Database that saves translator’s work bilingually and can
suggest any of it as partial or complete translation for new
source text
 Segment: unit of text that ends w/ a stop
character (i.e., . ? ! : ¶ →)
 Translation unit (TU): bilingual unit composed of a source
segment and a target segment
Turn left at the light.
(source segment)
Turn left at the light.
(source segment)
Tournez à gauche au feu.
Tournez à gauche au feu.
(target segment)
(target segment)
Suggestion next
Two complementary TM tools
 Wordfast Classic (WFC)
▪ A TM tool that is a Microsoft Word add-in
▪ Translation work done in Word document
▪ For Office files and ease-of-use
 Wordfast Pro (WFP)
A standalone TM tool (no Word needed)
Translation files imported to tagged file (TXML)
Work done on TXML in Pro, exported to original file format
For complex file formats, large batches
Not part of Wordfast Studio
A free web-based tool
 Internet and free account required
Translation work can be done through upload
and download of files
Interesting features that complement Wordfast
 Alignment: Tools > Align your files
 Scanned PDFs: File > Upload document file,
click [Browse] to locate file, click [Upload] and
wait for conversion
Almost all of Wordfast’s functions have shortcut
assignments to speed its use
 Most of Wordfast’s shortcuts begin with a
combination of CTRL, ALT, and/or SHIFT
 Mac: CTRL = Command; ALT = Option; more below
▪ http://www.wordfast.net/wiki/Keyboard_shortcuts_on_Macs
Tip: Always press and continue holding each
shortcut key in the order given until you finish
the key combination
 Example: CTRL+ALT+C = press and continue holding
CTRL, then press and continue holding ALT, then
press C to finish
Text analysis
Project-specific glossary/style sheet
Edit style
Edit accuracy
Editing &
to save
Stop here for
unclean file
TM &
Create a project
 Go to File > Create Project
 Type a project name, select your languages, click
[OK] & [OK]
Create a TM
 Go to Translation Memory > New/Select TM (or
press CTRL+SHIFT+N) and click [Create TM]
 Click [Browse], type TM name, choose save
location, click [Save], click [OK]
 TM now appears in TM List. Click [OK] to finish.
Drag any supported file into interface and
wait for import to TXML
 NOTE: New source files must be saved as TXML
first. To do this, type a space in the first target
segment after import and then press CTRL+S
Go to Translation Memory > Analyze
Select and copy report contents to paste
elsewhere and save if desired; click [OK] to
100% (exact match)
word count
100% (exact
Total word count
Drag a supported file into interface and wait
for import to TXML
Type translation in empty target, but copy
any source tags like {ut1} first with
Press ALT+↓ to commit TU and continue
Complete 4–5 segments (rows) this way
Press ALT+↑ to commit and go up any time
Press ALT+END to commit TU and stop
Create a glossary
 Go to Terminology > New/Select Glossary (or
press ALT+N)
Click [Create]
Type glossary name, click [OK]
Glossary now appears in Glossary List
Click [OK] to finish
Click first source segment
Select text (word or phrase) for term in source segment
and press CTRL+ALT+T
 Add to Glossary box appears with source term filled
Select term’s in target segment and press CTRL+ALT+T
 Target term filled in Add to Glossary box
 Optional: Enter any extra info in Description field
 Verify your glossary name at bottom of box, click [OK] to add
Continue through translated segments and add 4–5 terms
 NOTE: Highlighted items in source are glossary terms. Type 2–3
letters of highlighted source term for translation suggestion.
Translate next 4–5 segments and add 4–5 more terms.
Spot edit
 Place cursor in desired target segment and type
 Press ALT+END to commit edited TU
Comprehensive edit
 Place your cursor at top right and review segment
▪ If no change, press CTRL+↓ to continue without committing
▪ If change, press ALT+↓ to commit and continue
 Move through doc segment by segment using this method
until you reach the end
Preview: Go to File > Save Translated File any time
during editing to export a preview of final document
 WARNING: Do not make changes in exported preview
because your changes are not committed to the TM.
Export target document (i.e., to source format)
 Go to File > Save Translated File
▪ Note: “FileName_TargetLanguageCode” is your exported
target document and will be saved next to source document
Compare target document formatting with
source document to complete job
 Note: If you find any formatting issues, there are likely
tags missing in the bilingual TXML. You can go back to
the TXML and look for the problem location.
Back to sample TXML file, click on first empty target
Translate and press ALT+↓ to commit and continue
Add terms at any time while translating by selecting
source term (left side), pressing CTRL+ALT+T,
selecting target term (right side), and pressing
 When I say “edit,” press ALT+END to stop, click on
first target segment, and start reviewing
 If no change, press CTRL+↓ to continue without saving
 If change, press ALT+↓ to commit and continue
When I say “stop,” press ALT+END and export
Check the final document formatting
ALT+PGDN to join current segment to next
 This doesn’t work sometimes because the
segments belong to different paragraphs in the
source text. It can be fixed if paragraphs are
combined in the source text before import.
ALT+PGDN to split segment after placing
cursor at desired split point in source
Press CTRL+ALT+ENTER to open highest
priority glossary or click the glossary editor
drop-down to choose any glossary (see image
Double-click any term to edit it
 Click [Modify] to accept edit or [Cancel] to
cancel edit
Single-click any Term to select it (turn it blue)
 Press DELETE and click [Yes] to delete it
Click [Search] to find word
Click the white cylinder icon on the upper left
side of the WFP interface (see image above)
to open the TM Admin view
Double-click TM listed to load it for editing
Double-click any target segment to edit it,
then type edit and press ENTER
Save edits to TM with CTRL+ALT+END
 NOTE: TUs cannot be deleted with TM Admin
Click [Search] to find word
Click [Find/Replace] to make global edit
ALT+↓ = commit/go ↓
ALT+↑ = commit/go ↑
CTRL+↓/↑ = go ↓/↑ (no
ALT+END = commit active
CTRL+ALT+T = add selected
more/less text to segment
ALT+DELETE = delete target
segment, restore to
CTRL+ALT+ →/←, ↓ = select
placeable, copy placeable
TAB = select source text after
typing 2-3 source characters
CTRL+ALT+C = concordance
search for selected text in TM
ALT+F12 = copy selected
concordance result to target
ALT+ENTER = toggle
uncomfirm/confirm segment
glossary editor
Join the very active WFP Yahoo Groups to ask
 http://tech.groups.yahoo.com/group/WF_PRO
WF YouTube channel
 http://www.youtube.com/user/WordfastTM
WF Wiki
 http://www.wordfast.net/wiki/Main_Page
 http://wordfast.com/WFP2/Wordfast_Pro_Help.ht

similar documents