MPLS TE

Report
MPLS TE
Przebieg laboratorium
• Konfiguracja sieci zgodnie z instrukcją
• Konfiguracja protokołu OSPF
• Konfiguracja MPLS Traffic-Eng
– Dynamiczna (rekonfiguracja: zmiana wag łączy, reakcja na
uszkodzenie)
– Statyczna (reakcja na uszkodzenie)
– Statyczno/dynamiczna (reakcja na uszkodzenia)
• Konfiguracja LDP
Dla każdego kroku proszę zaobserwować stan sieci i
jego opis umieścić w sprawozdaniu
Konfiguracja sieci zgodnie z instrukcją
!
no ip domain lookup
!
interface Loopback0
ip address 10.0.0.25 255.255.255.255
no shutdown
!
interface FastEthernet0/0
ip address 192.168.7.25 255.255.255.0
no shutdown
duplex auto
speed auto
ip load-sharing per-packet
!
interface Serial0/1/0
ip address 192.168.2.25 255.255.255.0
no shutdown
no fair-queue
ip load-sharing per-packet
!
Konfiguracja sieci zgodnie z instrukcją
- konfiguracja ruterów
!
no ip domain lookup
!
interface Loopback0
ip address 10.0.0.25 255.255.255.255
no shutdown
!
interface FastEthernet0/0
ip address 192.168.7.25 255.255.255.0
no shutdown
duplex auto
speed auto
ip load-sharing per-packet
!
interface Serial0/1/0
ip address 192.168.2.25 255.255.255.0
no shutdown
no fair-queue
ip load-sharing per-packet
!
Konfiguracja sieci zgodnie z instrukcją
– konfiguracja przełącznika
hostname S21
monitor session 1 source interface fastEthernet 0/1 both
monitor session 1 destination interface fastEthernet 0/3
no spanning-tree vlan 1
line console 0
logg syn
Konfiguracja protokołu OSPF
router ospf 1
log-adjacency-changes
network 10.0.0.25 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.7.0 0.0.0.255 area 0
!
Konfiguracja MPLS Traffic-Eng –
przygotowanie ruterów
!
ip cef
!
mpls traffic-eng tunnels
!
interface FastEthernet0/1
ip address 192.168.4.23 255.255.255.0
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1024 1024
no shutdown
!
Konfiguracja OSPF dla MPLS-TE
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 10.0.0.25 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.7.0 0.0.0.255 area 0
!
Konfiguracja MPLS Traffic-Eng –
zestawienie tunelu dynamicznego
!
interface Tunnel1
shutdown
ip unnumbered Loopback0
tunnel destination 10.0.0.22
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng path-option 1 dynamic
!
Konfiguracja MPLS Traffic-Eng –
zmiana trasy przez ustawienie wag
!
interface FastEthernet0/0
mpls tarffic-eng administrative-weight XX
!
!
mpls traffic-eng reoptimize
!
Konfiguracja MPLS Traffic-Eng –
zmiana trasy przez awarię
!
mpls traffic-eng reoptimize
!
!
mpls traffic-eng reoptimize events link-up
mpls traffic-eng reoptimize events timers
!
Konfiguracja MPLS Traffic-Eng –
zestawienie tunelu statycznego
!
interface Tunnel2
shutdown
ip unnumbered Loopback0
tunnel destination 10.0.0.XX
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng path-option 1 explicit name LSP1
tunnel mpls traffic-eng path-option 2 explicit name LSP2
no routing dynamic
!
Konfiguracja MPLS Traffic-Eng –
zestawienie tunelu statycznego
!
ip explicit-path name LSP1 enable
next-address 192.168.2.23
next-address 192.168.4.22
next-address 10.0.0.22
!
ip explicit-path name LSP2 enable
next-address 192.168.2.23
next-address 192.168.3.24
next-address 192.168.5.22
next-address 10.0.0.22
!
Konfiguracja MPLS Traffic-Eng –
zestawienie tunelu
statyczno/dynamicznego
!
interface Tunnel3
shutdown
ip unnumbered Loopback0
tunnel destination 10.0.0.XX
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng path-option 1 dynamic
tunnel mpls traffic-eng path-option 2 explicit name LSP2
!
MPLS - LDP
ip cef
!
interface Loopback0
ip address 10.0.0.25 255.255.255.255
no shutdown
!
interface Serial0/1/0
ip address 192.168.2.25 255.255.255.0
no shutdown
mpls ip
no fair-queue
ip load-sharing per-packet
!
mpls ldp router-id Loopback0
!
Tunele
• Static routing:
– ip route 192.168.8.0 255.255.255.0 tunnel 1
• Waga Tunelu dla protokołu OSPF:
– Na interfejsie tunnel:
– ip ospf cost 1
Przydatne komendy
• show running-config
• show ip route

similar documents