第1讲

Report
汇编语言实验演示
内容
• ——32位的Windows汇编程序:如MASM32V9
• ——16位的汇编程序:如MASM 6.15
MASM32V9
• 安装好MASM32后,进入MASM32所在文件夹,
双击QEDITOR.EXE的图标,这就进入了MASM32
的集成开发环境。
MASM32V9
• 输入源程序:然后使用菜单栏上的菜单File ->
Save ,需要输入文件名,注意要指定扩展
名 .ASM。
• 汇编源程序:使用菜单栏上的菜单Project ->
Assemblier ASM file。这时系统会打开一个控制
台窗口运行相关的批处理文件。结束后会弹出一
个名为“\masm32\bin\asmbl.txt”的窗口报告结
果。
MASM32V9
MASM32V9
• 链接目标文件:使用菜单栏上的菜单Project ->
Link OBJ file。这时系统会打开一个控制台窗口
运行相关的批处理文件,并弹出名为
“\masm32\bin\lnk.txt”的窗口报告.
MASM32V9
• 或者直接编译+链接:使用菜单栏上的菜单
Project -> Assemble & Link。系统同样会打开一
个控制台窗口运行相关的批处理文件,并弹出名
为窗口报告.
• 运行生成的可执行文件:使用菜单栏上的菜单
Project -> Run program。
VC++6.0编译
• 第一步:新建工程
• 新建空的Win32控制台程序。
VC++6.0编译
• 第二步:添加文件
把源程序和资源文件添加进新建的工程。当然也可以在VC++6.0里写源程序并编辑资源文件。
VC++6.0编译
在程序文件上右击,再点设置(Settings),然后在弹出的对话框中设置命令行参数和输出文
件名。命令行参数:ml /c /coff 123.asm 输出文件名:123.obj (123就是你写的源程序名字)
VC++6.0编译
• 点击 Tool:Options ,在弹出的对话框中选择
Directories页,设置编译汇编程序所需的include
文件、lib文件和编译程序ml.exe的路径。
VC++6.0编译
VC++6.0编译
第五步:编译与调试程序
MASM 6.15
•
•
•
•
•
•
•
•
•
MASM 6.15包含文件:
MASM.EXE
汇编器
EDIT.COM
DOS下的文本编辑器
EDIT.HLP
EDIT帮助文件
LIB.EXE
过程库管理程序
LINK.EXE
连接器
DOSXNT.EXE ml.err
汇编的错误信息文件
ml.exe(masm and link) 汇编连接器
DEBUG.EXE
调试器(一般是系统自带)
MASM 6.15
• 对于MASM 6.10以下的版本,汇编器和连接器是
分开的,
• 分别是MASM.EXE和LINK.EXE,使用时要先用
MASM.EXE生成.OBJ文件,再使用LINK.EXE生
成.EXE文件。
• MASM6.10以上的版本,ml.exe把MASM.EXE和
LINK.EXE整合到一起,可以一步生成.EXE文件。
MASM 6.15
• 在控制台环境下的编译过程如下:
• 1)在D:\MASM下的EDIT.COM建立.ASM文本文件
• 2) D:\MASM>ML EXP.ASM
其他
• 汇编语言编译器还有很多,例如64位的编译器,
比如MASM64V9,现在最新的MASM系列的当数
是MASM32V11,当然还有像TASM等等一系列的
编译器,大家有兴趣的可以课下自己查找。

similar documents