Practica_3_STD

Report
Sistemas de Transporte de Datos (9186). Curso 2010 -11
Ingeniería Informática
Carlos A. Jara Bravo (cajb@dfists.ua.es)
Grupo de Innovación Educativa en Automática
© 2010 GITE – IEA
Sistemas de Transporte de Datos (9186). Curso 2010 -11
Ingeniería Informática
PRACTICAS DE LABORATORIO DE SISTEMAS DE TRANSPORTE DE DATOS.
Práctica 1: Encaminamiento dinámico con IPv4.
Práctica 2: Túneles y VPNs.
Práctica 3: Control de calidad de servicio.
Carlos A. Jara Bravo (cajb@dfists.ua.es)
Grupo de Innovación Educativa en Automática
© 2010 GITE – IEA
Sistemas de Transporte de Datos (9186). Curso 2010 -11
Ingeniería Informática
PRÁCTICA Nº3
GESTIÓN DE LA CALIDAD DE SERVICIO CON ROUTERS CISCO
1. Introducción al concepto calidad de servicio
2. QoS Signaling con IP
3. Gestión de la QoS en los routers
4. Shaping
5. Policing
6. Redes inalámbricas IEEE 802.11
1ª sesión
2ª sesión
Carlos A. Jara Bravo (cajb@dfists.ua.es)
Grupo de Innovación Educativa en Automática
© 2010 GITE – IEA
Calidad de Servicio (QoS)
•
Gestión de la QoS: Administrar los recursos de la red (ancho de banda
retardos, fiabilidad, etc.) para asegurar los servicios demandados por
Sistemas de Transporte de Datos – Ingeniería Informática
las aplicaciones y evitar congestión.
•
•
Beneficios de la gestión de QoS:
o
Control sobre los recursos de la red para un uso más eficiente.
o
Diferenciación de servicios en la red.
o
Coexistencia de aplicaciones críticas.
Niveles de aplicación de la gestión de QoS:
o
En los routers: Estrategias de colas, clasificación/marcado de
tráfico (ACLs y route-maps), gestión de tráfico (shaping/policing).
o
En los protocolos: Campo QoS en protocolo IP (QoS Signaling).
o
En la administración: Políticas de contabilidad y mantenimiento.
Práctica 3. Control de calidad de servicio
QoS Signaling con IP
Differentiated Services Field
(DS Field)
• Campo TOS (1 byte): Diferencia el tipo de tráfico que viaja en los datos
Sistemas de Transporte de Datos – Ingeniería Informática
IP. Los tres bits de mayor peso (precedencia) identifican 8 tipos. En IPv6
se utiliza el campo DSCP de 6 bits.
Cabecera IPv4
Datos del paquete IPv4
Datagrama IPv4
ToS (IPv4)
0 – 000
1 – 001
2 – 010
3 – 011
4 – 100
5 – 101
6 – 110
7 – 111
•
Datos del paquete IPv6
Datagrama IPv6
Campo DS
Precedencia D T R M 0
7
6
5 4 3 2 1 0
Precendecia
Cabecera IPv6
Bits del ToS
ToS (Hex)
ToS (Dec)
Tipo de tráfico
00
20
40
60
80
A0
C0
E0
0
32
64
96
128
160
192
224
Routine
Priority
Inmediate
Flash
Flash override
Critic
Internetwork control
Network control
DSCP
ECN
6 bits
2 bits
Categorías (DSCP)
000 xxx
001 dd0
010 dd0
011 dd0
100 dd0
101 xxx
110 xxx
111 xxx
Significado
Best Effort (defecto)
Assured Forwarding (AF) clase 1
Assured Forwarding (AF) clase 2
Assured Forwarding (AF) clase 3
Assured Forwarding (AF) clase 4
Expedited Forwarding (EF)
Control de la red
Control de la red
En los túneles se suele copiar el campo QoS del pasajero al portador.
Práctica 3. Control de calidad de servicio
Gestión de la QoS en los routers
Sistemas de Transporte de Datos – Ingeniería Informática
•
Etapas de proceso QoS en un router:
2 o Clasificación y Marcado: El router explora los paquetes y clasifica
según protocolo, aplicación, tamaño, dirección, etc. Clasificar el
tráfico entrante según ACLs y marcar (QoS Signaling) determinados
tipos con route-map.
3
o
1
o
Gestión de tráfico: Monitorizar el tráfico de la red para prevenir la
congestión. Técnicas de shaping y policing.
Colas de salida: Estrategias de encolado de los paquetes en las
interfaces de salida para solucionar problemas de congestión (el
problema de congestión existe).
Clasificación y
marcado
Interfaz 1 (entrada)
Clasificación y
marcado
Interfaz N (entrada)
Práctica 3. Control de calidad de servicio
Gestión de
tráfico
Procesamiento y
enrutamiento (tabla
encaminamiento,
túneles, NAT...)
Colas de
salida
Interfaz 1 (salida)
Gestión de
tráfico
Interfaz N (salida)
Colas de
salida
Estrategias de Colas en los routers
•
Cuando la red se encuentra congestionada (no puede enviar todo el tráfico
que recibe), el router va almacenando los paquetes que tiene que enviar en
Sistemas de Transporte de Datos – Ingeniería Informática
colas de salida.
Cola de
salida
Múltiples
colas
De la
política de
gestión de
tráfico
Clasificación
Planificación
Tráfico de
salida a la
interfaz física
Criterios
Colas con tráfico clasificado
•
Existen diferentes estrategias para elegir el paquete a desencolar:
FIFO: Según el orden de llegada. No tiene en cuenta la prioridad.
o WFQ (encolado equitativo ponderado): Según el tipo de tráfico (interactivo o no
interactivo). Funcionamiento automático no configurable.
o PQ (priority queueing): Según la prioridad asignada al tráfico (alta, media,
normal y baja). Los paquetes se almacenan en 4 colas según su prioridad.
o CQ (custom queueing): Permite especificar el nº de bytes a enviar, nº bytes en
cada cola (basada en reservar una fracción de ancho de banda para tráfico).
o
Cisco
Systems
Práctica 3. Control de calidad de servicio
Clasificación y Marcado de paquetes (I)
•
Clasificación: Separar el tráfico entrante en el router en diferentes clases/grupos para
asignarles distintas prioridades.
Sistemas de Transporte de Datos – Ingeniería Informática
•
Para implementar la clasificación se utilizarán Listas de Acceso:
o
Listas de Acceso Estáticas:
access-list
access-list
access-list
access-list
o
101
101
101
101
remark Criterios para marcar precedencia 1
permit ip host 193.145.232.131 host 10.1.3.3
deny udp any 10.1.0.0 0.0.255.255 eq 80
permit ip host 193.145.232.132 host 10.1.2.2
Ámbito de actuación ACLs
IP Estándar: 1-99, 1300-1999
IP Extendida: 100-199,2000-2699
Listas de Acceso Dinámicas:
Definir plantilla ACL:
Nombre patrón
access-list 102 dynamic pre1 permit ip any any
Patrón de lista de
acceso dinámica
Añadir condiciones dinámicas a plantilla ACL (con temporizador):
access-template 102 pre1 permit ip any host 10.1.3.3 timeout 10
o
Se puede consultar las ACLs definidas con: show access-lists.
stdprac nR lst
Práctica 3. Control de calidad de servicio
10 min
Clasificación y Marcado de paquetes (II)
•
Marcado: Establecimiento de un valor de precedencia (campo ToS) del
paquete IP cuando cumple una condición definida por una ACL.
Sistemas de Transporte de Datos – Ingeniería Informática
•
Para implementar la clasificación se utilizarán route-maps:
o
Definición de un route-map:
route-map CLASIF1 permit 10
match ip address 101
set ip precedence priority
o
(Asignar ACL 101 al route-map)
(Establecer valor de precedencia en valor priority)
Asignación de route-map a una interfaz del router:
interface fastethernet 0
ip policy route-map CLASIF1
o
Consultar los route-maps definidos con: show route-map.
Router# show route-map
route-map CLASIF1, permit, sequence 10
Match clauses:
ip address (access-lists): 101
Set clauses:
ip precedence priority
Policy routing matches: 4 packets, 230 bytes
Práctica 3. Control de calidad de servicio
stdprac nR rmap
Gestión de tráfico en los routers
•
Gestión de tráfico: Técnicas para garantizar una tasa de transferencia media CIR
y así prevenir la congestión de la red.
La tasa CIR garantiza el envío de Bc bits cada Tc segundos: CIR= Bc/Tc.
o Se pueden enviar Be (ráfaga) bits adicionales sin garantías: MAX= Bc + Be.
Sistemas de Transporte de Datos – Ingeniería Informática
o
AB garantizado = CIR
•
AB máximo= (Bc+Be)/Tc
Bits transmitidos si la red
no está congestionada
Gestión del CIR (routers CISCO): Algoritmo del cubo de testigos (token bucket)
Un testigo representa el permiso para enviar un número de bits a la red.
o Los testigos se almacenan en un cubo con una determinada frecuencia.
o Al enviar un paquete, se comprueba si hay suficientes testigos en el cubo:
o
Si hay suficientes, se envía el paquete y se eliminan los testigos correspondientes del cubo.
Si no hay suficientes (posible congestión), se ejecuta la acción correspondiente (descartar -policing- o
encolar -shaping-).



Intervalo de generación de testigos: shaping  Tc=Bc/CIR (se añaden nº testigos
equivalentes a Bc en cada intervalo); policing  no se establece un intervalo fijo.
Práctica 3. Control de calidad de servicio
Gestión de tráfico con GTS: Shaping
Shaping (Perfilado de tráfico): Estrategia de gestión de tráfico que
almacena los paquetes en colas cuando se supera la tasa CIR (faltan
testigos en el cubo).
•
Establecer una tasa de velocidad media (CIR) de 50 Kbps a una interfaz.
Sistemas de Transporte de Datos – Ingeniería Informática
•
interface fastethernet0
traffic-shape 50000 8000 8000
Asignación de shaping a una interfaz (lista ACL): traffic-shape
•
access-list 103 permit tcp host 172.25.1.132 eq 80 any precedence routine
interface fastethernet0
traffic-shape group 103 50000 8000 8000
(opcional, para tener en cuenta
la precedencia del paquete, ToS)
CIR (bps) Bc (bits) Be (bits)
•
Visualización configuración de shaping: show traffic-shape
Router# show traffic-shape
Access Target
Byte
VC
List
Rate
Limit
103
50000
2000
stdprac nR traf
Sustain
bits/int
8000
CIR (bps) Bc+Be (Bytes) Bc (bits)
Excess
bits/int
8000
Be (bits)
Interval
(ms)
160
Tc (ms)
Increment Adapt
(bytes)
Active
1000
-
Testigos disponibles
en el cubo
Estadísticas de shaping: show traffic statistics stdprac nR traf2
•
Práctica 3. Control de calidad de servicio
Gestión de tráfico con CAR: Policing
Policing: Estrategia de gestión de tráfico que elimina los paquetes
cuando se supera la tasa CIR (faltan testigos en el cubo).
•
Sistemas de Transporte de Datos – Ingeniería Informática
•
Asignación de policing a una interfaz: rate-limit
access-list 102 permit tcp any any eq www
access-list 103 permit tcp any any eq ftp
CIR (bps) Bc (bytes) Bc+Be (bytes)
interface hssi0
rate-limit input access-group 102 20000000 24000 32000
conform-action transmit exceed-action drop
Acción para paquetes
que cumplen CIR
Acción para paquetes
que exceden CIR
rate-limit input access-group 103 10000000 24000 32000
conform-action set-prec-transmit 5 exceed-action drop
Cambia la precedencia del
paquete a 5 y lo envía
Configuración/Estadísticas de Policing: show interfaces rate-limit
Router# show interfaces rate-limit
stdprac nR rate
•
Hssi0 45Mbps to R2
Output
matches: access-group 103
params: 10000000 bps, 24000 limit, 32000 extended limit
conformed 0 packets, 0 bytes; action: set-prec-transmit 5
exceeded 0 packets, 0 bytes; action: drop
last packet: 19522612ms ago, current burst: 0 bytes
last cleared 00:07:18 ago, conformed 0 bps, exceeded 0 bps
Práctica 3. Control de calidad de servicio
Shaping vs Policing
Criterio
Policing
Almacenar temporalmente los paquetes que
superan las velocidades establecidas.
Las tasas de velocidad de los paquetes se
evalúan en intervalos. Se configura en bits por
segundo.
Eliminar los paquetes que superan las velocidades
establecidas.
Colas soportadas
CQ, PQ, FCFS, WFQ.
No se usan.
Efecto sobre las
ráfagas
Suaviza los cambios de tráfico tras varios
intervalos.
Si no hay exceso de tráfico, no elimina paquetes,
y no se requiere retransmitir.
Objetivo
Refresco
Sistemas de Transporte de Datos – Ingeniería Informática
Shaping
Ventajas
Desventajas
Puede introducir retardos en los paquetes, sobre
todo con colas grandes.
Remarcado
No.
Práctica 3. Control de calidad de servicio
Funcionamiento continúo. Se configura en bytes.
No se alteran las ráfagas de tráfico.
Evita los retardos de los paquetes en las colas.
Al eliminar muchos paquetes, TCP ajusta su
ventana a valores más pequeños, y esto disminuye
el rendimiento.
Permite un remarcado de los paquetes
procesados.
Sistemas de Transporte de Datos – Ingeniería Informática
Estructura de una red inalámbrica
•
Red Ad-Hoc: Interconexión directa de clientes inalámbricos entre sí.
•
Red de Infraestructura: Los clientes inalámbricos se conectan a un
punto de acceso (AP) que se encarga de reenviar la información.
o
BSS: Conjunto de clientes conectados a un AP. Se identifica con BSSID.
o
DS: Red (de cable o inalámbrica) que permite interconectar varios BSS.
o
ESS: BSS interconectados mediante un DS. Se identifica con SSID.
Práctica 3. Control de calidad de servicio
Formato Tramas 802.11
Sistemas de Transporte de Datos – Ingeniería Informática
•
Encapsulación Ethernet: Envío información Ethernet en trama 802.11.
o
Cabecera MAC 802.11: Contiene direcciones MAC.
o
Cabecera LLC: Contiene el tipo de datos (IP o ARP).
26 ó 30 bytes
Físico 802.11
2 bits
MAC 802.11
2 bits
LLC + Tipo
FCS MAC
Físico
2 bytes
2 bytes
6 bytes
6 bytes
6 bytes
2 bytes
6 bytes
Control
trama
Duración
Dirección 1
Dirección 2
Dirección 3
Secuencia
Dirección 4
(opcional)
4 bits
1 bit
Versión Tipo trama Subtipo trama Hacia DS
•
IP o ARP
1 bit
De DS
4 bits
12 bits
Nº de
fragmento
Número de secuencia
(0 a 4095)
1 bit
1 bit
1 bit
1 bit
Más frag. Reintentar Control de Más datos
potencia
1 bit
1 bit
Datos
encriptados
Orden
Al capturar tráfico inalámbrico (dependiendo del S.O, del adaptador de red y del
driver) se podrán visualizar las tramas 802.11 o las tramas Ethernet equivalentes.
Práctica 3. Control de calidad de servicio
Asociación de una estación a un AP
•
Tres pasos: escaneo activo(Probe) / pasivo(Beacon), autentificación y
Sistemas de Transporte de Datos – Ingeniería Informática
asociación. Después de la asociación, el AP le asignará IP mediante DHCP.
Probe Request
Escaneo
(Parámetros Conexión:
Velocidades, Canal Radio, SSID).
Broadcast
Probe Response
Authentication
Autentificación
(Open, Shared, WPA…).
Authentication
Association Request
Association Response
Asociación
(Velocidades, Association ID).
DHCP Request
Parámetros Configuración
(IP, Mask, DNS servers, Lease Time).
Broadcast
DHCP- ACK
Gratuitous ARP (IP-MAC Cliente)
Práctica 3. Control de calidad de servicio
Broadcast
Broadcast
Sistemas de Transporte de Datos – Ingeniería Informática
Topología L24
Práctica 3. Control de calidad de servicio

similar documents