PW 101 V8i - Chapter7

Report
ProjectWise 101
Chapter 7 - Environments
Gary Cochrane – Technical Director
Geospatial Sales – North America
ProjectWise Environments
• Provide additional/custom attributes:
– For Documents
• Appears to user on Document Properties dialog
– On tab> Attributes, and More Attributes
• As delivered, these tabs are empty, or undefined
• Part of ProjectWise deployment is to work with customer to
develop these tabs
• Also covered in ProjectWise Administrator class
Steps involved
• Plan the Environment
– Determine what fields are needed
• Decide what type and length the fields should be
– Create the layout for the Attribute tab
– Create the layout for the More Attributes tab
– Configure the fields
• Establish default values, pick-lists, formatting, etc.
Document Attributes / Properties
Lab 1a
• Use PW Administrator to Create new
Environment
– Log in to PW Administrator using adminpw account
•
•
•
•
Drill down to Environment category
Right-click, then choose New> Environment
At the Welcome Screen, select> Next
At the Environment Type screen, accept the default, and select>
Next
– Note: Second option is not implemented…
Lab 1b
• Create new Environment Wizard
– Name the Environment:
• Name> PW-101
• Description> PW 101 Class Environment
– Select> Next
– On the Database table screen
• Choose> Create New table (the default)
• Name> env_pw101
– Select> Next
Lab 1c
• Create New Environment Wizard
– Designing new table screen
• Press the Add button
Lab 1d
• Define the new attribute as follows:
– Name> drawnby
– Enable> Use Native data types
– From the data types pick-list
• Choose> varchar
– For Length, key-in> 64
– Press Add
• The new attribute appears in the list, but the Add dialog does not
close
Lab 1e
• Add a second new attribute
– Use all the same parameters, except Name
• Name the new attribute> checkedby
– Press the Add button
• Note: it makes sense to add similar attributes, and then change
parameters
Lab 1f
• Add a third attribute
– Use the following parameters
• Name> drawndate
• Type> datetime
– Press Add
• Note: On datetime type field, length parameter is not available
Lab 1g
• Add a fourth attribute
– Use the following parameters
• Name> checkeddate
• Type> datetime
– Rather than pressing Add, simply press OK
• Since this is the last one
– Press Next to continue
Lab 1h
• Environment Settings screen
– Leave both options unchecked
• Press Next to continue
– Press Finish to create the Environment
• What if we decide later that we need to add more attributes?
• Simply select the Environment, and choose to add attributes
• Prior to XM version, it was not possible…
Lab 2a
• Designing the Attributes tab
– First we need to create a name
• You can have multiple layouts for the Attributes tab, so each one
must have a name
– From PW Administrator, select> Interfaces
• Right-click, then choose New> Interface
• Name the new interface> English-US
• Press> OK
– Repeat the process to create another new interface
• Name> English-UK
Lab 2b
• Define the English-US Attribute tab
– Drill down to:
• Environments> PW-101> Attribute Layout> English-US>
Attributes tab
Lab 2c
• Layout the Attributes tab
– Right-click in the right-hand pane, then choose:
• Add Attributes
– Select all 4 fields (use CTRL+click)
• Press OK
– Now that all fields are added, arrange/size them to suit
your taste
• See next slide…
Lab 2d
• Change/correct tab order
– Select Display tab order button
• Make corrections as necessary using buttons>
• Move Top, Move Up, Move Down, Move Bottom
– Turn off tab order when done
Lab 2e
• Aesthetic changes
– Double-click> drawnby
• Properties dialog for the attribute appears
– Change to the Interface tab
• Change the label text from “drawnby” to “Drawn By:”
– Press OK to accept the change
– Repeat the process for the remaining attributes
Lab 2f
• Usability Changes
– Enter default value for Drawn Date:
– Double-click Drawn Date
• Change to Value tab
– Change Default Value type to> System Variable
• Pick browse (…) button by System Variable
• Choose> $DATETIME$
– Press OK to close the dialog
Lab 2g
• Usability Changes
– Enter default value for Drawn By:
– Double-click Drawn By
• Change to Value tab
– Change Default Value type to> System Variable
• Pick browse (…) button by System Variable
• Choose> $USER.DESCR$
– Press OK to close the dialog
Lab 2h
• Usability Changes
– Create pick-list for Checked By:
– Double-click Checked By
• Change to Value tab
– Change Value List type to> Fixed
• Pick browse (…) button by Fixed values field
– Enter Names and Descriptions for list of checkers
• Press Add…
Lab 2i
• Creating the pick-list for Checkers
– After pressing Add
• Enter value> King
• Description> Jerry King
– Press OK, then press Add again
• Enter value> Riddle
• Description> John Riddle
– Press OK
• Note: you must order list properly if you want it ordered…
Lab 2j
• Add one more value to list
– Select> King in the list, then press Add
• Enter value> Bentley
• Description> Keith Bentley
– Press OK
• Note new item appears above previously selected item
– Press OK twice more to close properties dialog
• Note pick-list on the Checked By item
Lab 2k
• Designate expanded size for button
– Grab bottom handle for Checked By button
• Drag down to indicate expanded size
• (otherwise button won’t expand)
Lab 2L
• Usability Changes
– Create automatic value for Checked Date:
– Double-click Checked Date
• Change to Value tab
– Change Update Value type to> System Variable
• Pick browse (…) button by System Variables field
– Choose> $DATETIME$
• Then press> OK
Creating a triggered update
Lab 2m
• Create the trigger condition
– Set Update field when> Specific attributes are updated
• Choose browse (…) button by specific attributes
• Choose Checked By and press the “>>” icon
• Press OK
– Press OK again to close the properties dialog
• We’re done defining attributes!
Assigning the Environment
• The Environment can now be assigned to PW
folders
– Each PW folder can be associated with an Environment
• But only one Environment. In other words, all documents in that
folder are subject to the same attributes
– Environments are considered an optional setting for the
folder
• Prior to PW XM, it was mandatory. In other words, you could not
create a folder until you had defined at least one Environment.
Lab 3a
• Assign the Environment to a folder
– Close and re-open ProjectWise Explorer
• Log in as User1
– Create a new folder underneath the User1 folder, using
the following parameters
• Name> Environment Example1
• Description> Class Environment Test
• Environment> PW-101
– Press OK to create the folder
Lab 3b
• Add some files to the new PW folder
– Open Windows Explorer, and browse to
• C:\PW-101 Class Files\Environments
– Drag/drop files A10.dgn & A11.dgn to the new PW
folder
– Once done, Open Document Properties for the first file
• Change to the Attributes tab
Document Properties
•Notes
– Dialog title reads
• Unsaved Default
Values
– Drawn By field
• Should show> User
One
– Drawn Date field
• Today’s date
– Checked By field
• Does your pick-list
work?
Lab 3c
• Populate the attributes
– Drawn By and Drawn Date should have default values
– Add Attributes for
• Approved by> Jerry King
– For Approved Date, do not key-in anything
• Either click in another field, or
• Press Save
– The Approved date field should be triggered
• Because the Approved by field was populated
Lab 3d
• Save the Attribute changes
– Press Save, and then Close the Properties dialog
– Repeat the process, adding attributes to document
A11.dgn
– Did you notice…
• The Interface option is now populated?
Interfaces
• A note on Interfaces
– We defined the English-US Interface for the PW-101
Environment,
• But did not define the English-UK Interface…
– Using the Interface pick-list, we can switch on-the-fly
• However the fewer interfaces, the better…
• Users should not have to constantly switch interfaces
Lab 3e
• Review the Interfaces
– Open Document Properties for A10.dgn again
• Change to the Attributes tab
• Note it no longer says “Unsaved Default Values”
– With the Properties dialog still open
• Change to the Interface> English-UK
– The dialog should be blank
• Change back to Interface> English-US
– Close the Properties dialog when done
Attribute Exchange
• ProjectWise has the ability to synchronize
Environment fields with placeholders:
– In MicroStation files
• Using Tag data
– In AutoCAD files
• Using Blocks with attributes
– In Word docs
• Using Word custom property fields
– And theoretically in Excel docs
Attribute Exchange w/ MicroStation
• In MicroStation, we need tag data placeholders
– Drawings A10.dgn & A11.dgn have this
• Let’s take a look
– Double-click A10.dgn
• Zoom to lower right corner
• Choose the MicroStation Tag Edit command (T-2)
• Pick any of the yellow text in the titleblock
– Record the Tag Set name, and Tag item Names
• I’ve done it for you on the next slide…
– Exit MicroStation when done
MicroStation Tag Set
•Notes:
– Tag Set Name
• tb (in lower case)
– Individual tags
•
•
•
•
•
•
description, title2
site1, site2
facility1, facility2
sheet
drawnby, drawndate
approvedby,
approveddate
• version, scale
Lab 4a
• Configuring Attribute Exchange
– Open PW Administrator
• Log in as adminpw
– Drill down to:
• Attribute Exchange Rules> MicroStation Title Blocks
– Right-click, and choose:
• New> Attribute Class
• Name the Attribute Class> tb
• (it should match the Tag Set name from MicroStation)
– Press OK
Lab 4b
• Adding individual attributes
– Select the new attribute class (tb)
• Then right-click, and choose New> Attribute
• We need to tell PW what the placeholder names are within
MicroStation, and which PW attribute to map to them
• Since our Environment was a quickie, we don’t have a PW match
for everthing that was in the DGN file tags
– At the Wizard Welcome screen
• Choose> Next
Lab 4c
• Create mapping for the description tag
– On the Attribute Name screen
• Enter> description (remember this was one of the tags in the
MicroStation file)
• Press> Next
– On the Binding the Attribute screen
• Press> Add
• (we now need to choose which attribute in PW will be mapped to
the description tag in MS)
Binding the attribute
• Choose from standard properties, or
Environment properties
Lab 4d
• Bind to Document Properties> Description
– Choose the default properties group
• Document Properties
– Then select> DocDescription
• Press OK when done
• Press Next to advance the wizard
– On the Format screen
• Highlight the item, then press Default Format
• Press Next
– Press Finish
Lab 4e
• Add a binding for Drawn By
– Select the new attribute class (tb)
• Then right-click, and choose New> Attribute
– At the Wizard Welcome screen
• Choose> Next
– On the Attribute Name screen
• Enter> drawnby (this is the tag name in the DGN file)
• Press> Next
– On the Binding the Attribute screen
• Press> Add
Lab 4f
• Choose a PW attribute for Drawn By
– Choose the Environment properties group
– Then select> drawnby
• Press OK when done
• Press Next to advance the wizard
– On the Format screen
• Highlight the item, then press Default Format
• Press Next
– Press Finish
Lab 4g
• Add a binding for Drawn Date
– Select the new attribute class (tb)
• Then right-click, and choose New> Attribute
– At the Wizard Welcome screen
• Choose> Next
– On the Attribute Name screen
• Enter> drawndate (this is the tag name in the DGN file)
• Press> Next
– On the Binding the Attribute screen
• Press> Add
Lab 4h
• Choose a PW attribute for Drawn Date
– Choose the Environment properties group
– Then select> drawndate
• Press OK when done
• Press Next to advance the wizard
– On the Format screen
• Highlight the item, then press Format
• Choose a Date format, and press OK
– Press Next, and then press Finish
More of the same
• We could add the rest, but it’s just repetition at
this point
– So we’ll skip it for the sake of brevity
– But we do need to establish when the synchronization
between PW and MS will occur
Lab 4i
•In PW Administrator
– Right-click>
MicroStation Title
Blocks
• Choose Properties
– Enable only:
• Document is Opened
– Press OK
Lab 5a
• Test the Attribute Exchange
– Close and re-open PW Explorer
• Log-in as User1
– Navigate to folder> Environment Example1
• Open Document Properties for A10.dgn
– Enter a better description value
• Description> FIRST FLOOR PLAN
• Press Save, and Close
– Double-click the file to open MicroStation
• Exit file, and check-in when done
Title Block Notes
• Attribute Exchange
– Is one-way, from PW to MicroStation
• Tag edits in MS will be overwritten at the next file open
– You can push tag edits back to PW using key-in:
• titleblock updatedms
– You can also modify PW properties from within MS
• Using key-in> titleblock modify
Environments made easy
• You may export an Environment definition to a
text file
– Someone else can import it, rather than creating from
nothing
– You may also Export/Import Title Block mappings
Lab 6a
• Import a previously exported Environment
– From PW Administrator
• Drill down to Environments, right-click, and select Import
– Browse to:
• C:\PW-101 Class Files\Environments
• Select> plant-env-07-07-2007.aam
• Press> Open, then select Close when done
– An Environment named Plant is imported:
• Including an Interface named> Standard
Lab 6b
• Drill down to look at the new Environment
– Environments> Plant> Attribute Layout> Standard
• Attributes, and More Attributes
– Now import corresponding Title Block Mapping
•
•
•
•
•
Right-click Attribute Exchange Rules, choose> Import Mappings
Answer Yes to warning
Browse to folder> C:\PW-101 Class Files\Environments
And choose file> plant-tb-mapping-07-07-2007.ini
Select> Open
Analysis
• Your mappings were overwritten
– But a complete set for the Plant environment was
imported
• Had the names not conflicted, then the old ones would have been
preserved
Lab 7a
• Test the Plant Environment
– Close and re-open PW Explorer
• Log in using User1
– Under User1 folder, create a new subfolder:
• Name> Environment Plant
• Description> Plant Environment Test
• Environment> Plant
– Press OK to create the folder
Lab 7b
• Import files
– From Windows Explorer, browse to:
• C:\PW-101 Class Files\Environments
– Drag/Drop files A1.dgn – A5.dgn into new PW folder
• When done, change Interface to> Standard
– Scroll through Document Properties for each new
document
• Specifically the Attributes/More Attributes tabs
– What would happen if we opened in MicroStation?
• Any values in the file would be overwritten with null values
Lab 7c
• Bulk Attribute Update
– Batch mode tool to populate PW from attribute values
in DGN (or DWG) files
– Open tool from Start menu
• All Programs> Bentley> ProjectWise V8i> Idesktop_integration>
Attribute Bulk Update
– Log in using adminpw account
• You’ll need to choose the datasource as well
Lab 7d
• Choose folder: User1/Plant Environment
– Select> Mark
• Will mark all files in the folder for processing
– Press Next
– Document Summary screen> Press Next
– Options screen, accept defaults, press Next
• You could create a log file if desired
– Perform bulk update screen
• Press> Start Update
Lab 7e
• Results screen
– Press close
– Return to PW Explorer
• Press F5 to update the view
• Descriptions should appear
– Scroll through Properties dialog for each document
• Look at Attributes, More Attributes tabs
Lab 8a
• Import an Environment for Word attribute
exchange
– From PW Administrator
•
•
•
•
Right-click Environments, choose Import
Select file> purchase-orders-env-07-07-2007.aam
Choose Open
Press close when done
Lab 8b
• Import Attribute mapping for Word docs
– From PW Administrator
•
•
•
•
Right-click Attribute Exchange Rules, choose Import
Select Yes to continue
Select file> po-tb-mapping-07-07-2007.ini
Choose Open
– Expand MS Office Attribute support
• Review results
Lab 8c
• Import files for Word Attribute Exchange
– Close and re-open PW Explorer
• Log in using User1
– Create a new folder as follows:
• Name> Environment Purchase Orders
• Description> Purchase Orders test
• Environment> Purchase Orders
– Press OK to create the folder
Lab 8d
• Open Windows Explorer
– Browse to:
• C:\PW-101 Class Files\Environments
– Drag/Drop to import file> PO-1002367.doc
– Once imported, open Document Properties
• Add some values such as:
– P.O. Number, Purchasing Agent, Region/Group
• Add some items to be purchased
– Quantity, Catalog No., Description, Price
• Save and Close properties
Lab 8e
• Test the attribute exchange
– Double-click the document to open MS Word
• VBA Macro runs at Word startup to perform attribute
synchronization (transparently to the user)
• Must set Macro security level such that Bentley/PW VBA macros
can run
• Close Word, and check the file back in
Review
• Topics covered in this Chapter
– Creating a new Environment
• Creating layouts for the Attribute and More Attributes tabs
–
–
–
–
–
Assigning the Environment to folders
Importing a pre-existing Environment
MicroStation Attribute (title-block) Exchange
Attribute Bulk Update
MS Word Attribute Exchange

similar documents