Create New and Edit Existing ABL code What is OpenEdge Architect?

Report
OpenEdge Architect
18.3.2010 Scandi PUG
Jarmo Nieminen
Senior Technical Account Manager
Nordics
[email protected]
1
What is OpenEdge Architect?
Navigate and
Edit Database
Schema
Extend
development
environment
easily
Create New
and Edit
Existing ABL
code
Debug and
Run ABL
code
Design
ProDataSets
Graphically
Compile ABL
code
2
© 2010 Progress Software Corporation. All rights reserved.
Design UI
Workspaces and Projects
Workspace
Projects
Resources (Programs, Files, Documentation, …)
 All objects are contained in a workspace
 Resources are accessible only in the context of a
project
© 2010 Progress Software Corporation. All rights reserved.
Workspaces in OpenEdge Architect
What is a
Workspace?
• A physical directory
containing projects, folders,
files and state data
• Multiple projects of
different kind can co-exist
in the same workspace e.g.
OpenEdge, Web, Sonic
etc…
Workspace Root
metadata
Project
Folder
Files
Files
Why have
multiple
workspaces?
• Different applications
• Different releases
• Different environments:
development, testing,
deployment
© 2010 Progress Software Corporation. All rights reserved.
Projects in OpenEdge Architect
• collection of folders and files
and some meta data
What is a
Project?
• enables different
functionalities i.e.
OpenEdge, Sonic etc…
What is a Project
Type?
© 2010 Progress Software Corporation. All rights reserved.
Projects in OpenEdge Architect
Why use
Projects?
How to structure
projects?
• Modularity
• builds, version management,
sharing
• By Application modules e.g.
Order Entry
• By application layers e.g.
server side, client side, shared
code etc…
• By different client types e.g.
Web, GUI
• By technology e.g. ABL, .NET
© 2010 Progress Software Corporation. All rights reserved.
Benefits of OpenEdge Architect ABL Editor
Code Navigation
Support
Appearance and
Organization of
Code
Coding assistance
in the Editor
© 2010 Progress Software Corporation. All rights reserved.
Navigation in ABL Editor

Resources View primary tool
•
•

Double click to open source files
Use Working sets to filter
Arrows to navigate to resources
•
•
Forward and Back buttons
Last edit location

Open Resource dialog (Ctrl+Shift+R)

Outline View
•
Provides overview of your code
-
•

Includes, Variables, Widgets, Procedures, Functions,
Triggers, Temp Tables, Buffers and ProDataSets
Synchronized with Editor
Follow includes
and Run statement
© 2010 Progress Software Corporation. All rights reserved.
Appearance & Organization in ABL Editor

Standard Colors and Fonts

ABL syntax coloring

Code Folding

Quick Diff

Tasks

Bookmarks

Local History
Additions
Changes
Deletions
Bookmark
Task marker
© 2010 Progress Software Corporation. All rights reserved.
Keyword Help
 Select keyword and press Shft+F2
© 2010 Progress Software Corporation. All rights reserved.
OpenEdge Architect support for Eclipse
versions
OpenEdge Architect
Release
Shipped
Eclipse
version
Additional certified
Eclipse version(s)
10.1A
3
N.A
10.1B
3.2
N.A
10.1C
3.2.2
N.A
10.1C01
3.2.2
3.3
10.1C02+
3.2.2
3.3, 3.4
10.2A
3.4
N.A
10.2B
3.4.2
3.5
11
© 2010 Progress Software Corporation. All rights reserved.
How to improve the performance of your
OpenEdge Architect 10.2A environment?
Code Location
 Preference: Refresh
workspace
automatically
• Turn this off if the code
is stored on a network
location
12
© 2010 Progress Software Corporation. All rights reserved.
How to improve the performance of your
OpenEdge Architect 10.2A environment?
OpenEdge Projects
 Close unused projects
to conserve resources
13
© 2010 Progress Software Corporation. All rights reserved.
How to improve the performance of your
OpenEdge Architect 10.2A environment?
ABL Editor preferences
 Tune Editor preferences:
• Expand and case keywords
14
© 2010 Progress Software Corporation. All rights reserved.
How to improve productivity in OpenEdge
Architect 10.2A environment?
ABL Code Navigation:
•
•
•
•
•
Open Resource – CTRL+SHIFT+R
Quick Outline – CTRL+O
Quick Access – CTRL+3
Open Editor List – CTRL+E
Navigate quickly to IP’s or UDF’s in your code:
CTRL+SHIFT+UP or CTRL+SHIFT+DOWN
• List of shortcuts - CTRL+SHIFT+L
Use working sets
15
© 2010 Progress Software Corporation. All rights reserved.
Got different questions?
 OpenEdge Architect forum on Progress Communities:
http://communities.progress.com/pcom/community/psdn/openedge
/architect
16
© 2010 Progress Software Corporation. All rights reserved.
Demo







Create new workspace and projects for OE Architect
Import existing .p, .w, .i files for Architect
Compile and run
Setup database connection
Use launch configurations
Share projects between developers
Version control / team developing with OpenEdge
Architect (subclipse)
 Sonic ESB - annotations
17
© 2010 Progress Software Corporation. All rights reserved.
How to create a new workspace from scratch?
 Xcopy or better still, zip & unzip
 Set up a single workspace exactly the way you want it
and then zip up the directory and extract it to another
machine. Note that this is only useful for initially creating
a workspace!!
 The same approach could be used for the pdt plugin
stuff. You can actually distribute the whole Eclipse
directory, complete with extra plugins including:
SubClipse, M2Eclipse, EdEmma, Mylyn, ...
18
© 2010 Progress Software Corporation. All rights reserved.
How to share project?
 Export
•
•
•
•
Database connection(s): File->Export->OpenEdge->Database Connections
Configuration(s): File->Export->Run/Debug->Launch Configurations
Project folder: File->Export->General->File System
Project settings: Project->Properties->OpenEdge->Custom->Share Settings
Import
•
•
•
•
19
Create a new Project for the workspace:
File->Import->General->Existing Projects into Workspace (or SVN)
Database connection(s): File->Import->OpenEdge->Database Connections
Configuration(s): File->Import->Run/Debug->Launch Configurations
Project settings: Project->Properties->OpenEdge->Custom->Import Settings
© 2010 Progress Software Corporation. All rights reserved.
OpenEdge Architect and version 9….
-Develop and Test with v10.2A.
-Compile and Test AGAIN with
v9.1C
-To have database information in
OEA(SQL view) you can use the
JDBC-BRIDGE on top a Merant
v3.6 ODBC System dsn
Datasource.
-Instead of the normal jdbc driver
if you have a version equal db.
20
© 2010 Progress Software Corporation. All rights reserved.
OpenEdge Architect and version 9….cont…
- The check syntax goes through the 4GL
Database Engine
- And you can connect via tcp to a major
release down.
- You need the ODBC stuff only for the dbnavigator and the db-outline views in OEA.
21
© 2010 Progress Software Corporation. All rights reserved.
- You can compile with native 9.1C
and use OEA for developing
- The fields aren’t shown in the
database structure(no
drag&drop) view but they are shown
in the db details view(db navigator
prerspective).
Questions?
© 2010 Progress Software Corporation. All rights reserved.
Thank you for
your time!
© 2010 Progress Software Corporation. All rights reserved.
© 2010 Progress Software Corporation. All rights reserved.

similar documents